Skip to content

Commit e9eb939

Browse files
committed
include: extend SetupHostCommand macro to accept more arguments
Commit d6d3db0 added more gcc version probes, exceeding the argument limit of the SetupHostCommand macro, leading to failing GCC/LLVM tests on OS X. Extend the handled number of arguments to restore proper functionality. Fixes FS#1470 Fixes d6d3db0 ("build: Improve GCC version detection") Signed-off-by: Jo-Philipp Wich <[email protected]>
1 parent 2b84f95 commit e9eb939

File tree

1 file changed

+2
-1
lines changed

1 file changed

+2
-1
lines changed

include/prereq.mk

+2-1
Original file line numberDiff line numberDiff line change
@@ -90,7 +90,8 @@ define SetupHostCommand
9090
for cmd in $(call QuoteHostCommand,$(3)) $(call QuoteHostCommand,$(4)) \
9191
$(call QuoteHostCommand,$(5)) $(call QuoteHostCommand,$(6)) \
9292
$(call QuoteHostCommand,$(7)) $(call QuoteHostCommand,$(8)) \
93-
$(call QuoteHostCommand,$(9)); do \
93+
$(call QuoteHostCommand,$(9)) $(call QuoteHostCommand,$(10)) \
94+
$(call QuoteHostCommand,$(11)) $(call QuoteHostCommand,$(12)); do \
9495
if [ -n "$$$$$$$$cmd" ]; then \
9596
bin="$$$$$$$$(PATH="$(subst $(space),:,$(filter-out $(STAGING_DIR_HOST)/%,$(subst :,$(space),$(PATH))))" \
9697
which "$$$$$$$${cmd%% *}")"; \

0 commit comments

Comments
 (0)