Skip to content

Commit e9fb9b7

Browse files
swegeneraparcar
authored andcommitted
build: drop ccache variables from specific targets
With commit 2ca084c ("build: improve ccache support") these variables are being set globally and we don't need them for specific targets. Signed-off-by: Sven Wegener <[email protected]>
1 parent 5eaf6d8 commit e9fb9b7

File tree

2 files changed

+0
-6
lines changed

2 files changed

+0
-6
lines changed

include/host-build.mk

-3
Original file line numberDiff line numberDiff line change
@@ -132,9 +132,6 @@ define Host/Exports/Default
132132
$(1) : export STAGING_PREFIX=$$(HOST_BUILD_PREFIX)
133133
$(1) : export PKG_CONFIG_PATH=$$(STAGING_DIR_HOST)/lib/pkgconfig:$$(HOST_BUILD_PREFIX)/lib/pkgconfig
134134
$(1) : export PKG_CONFIG_LIBDIR=$$(HOST_BUILD_PREFIX)/lib/pkgconfig
135-
$(if $(CONFIG_CCACHE),$(1) : export CCACHE_BASEDIR:=$(TOPDIR))
136-
$(if $(CONFIG_CCACHE),$(1) : export CCACHE_DIR:=$(if $(call qstrip,$(CONFIG_CCACHE_DIR)),$(call qstrip,$(CONFIG_CCACHE_DIR)),$(TOPDIR)/.ccache))
137-
$(if $(CONFIG_CCACHE),$(1) : export CCACHE_COMPILERCHECK:=%compiler% -dumpmachine; %compiler% -dumpversion)
138135
$(if $(HOST_CONFIG_SITE),$(1) : export CONFIG_SITE:=$(HOST_CONFIG_SITE))
139136
$(if $(IS_PACKAGE_BUILD),$(1) : export PATH=$$(TARGET_PATH_PKG))
140137
endef

include/package.mk

-3
Original file line numberDiff line numberDiff line change
@@ -175,9 +175,6 @@ define Build/Exports/Default
175175
$(1) : export CONFIG_SITE:=$$(CONFIG_SITE)
176176
$(1) : export PKG_CONFIG_PATH:=$$(PKG_CONFIG_PATH)
177177
$(1) : export PKG_CONFIG_LIBDIR:=$$(PKG_CONFIG_PATH)
178-
$(if $(CONFIG_CCACHE),$(1) : export CCACHE_BASEDIR:=$(TOPDIR))
179-
$(if $(CONFIG_CCACHE),$(1) : export CCACHE_DIR:=$(if $(call qstrip,$(CONFIG_CCACHE_DIR)),$(call qstrip,$(CONFIG_CCACHE_DIR)),$(TOPDIR)/.ccache))
180-
$(if $(CONFIG_CCACHE),$(1) : export CCACHE_COMPILERCHECK:=%compiler% -dumpmachine; %compiler% -dumpversion)
181178
endef
182179
Build/Exports=$(Build/Exports/Default)
183180

0 commit comments

Comments
 (0)