This repository has been archived by the owner on May 20, 2023. It is now read-only.
-
Notifications
You must be signed in to change notification settings - Fork 248
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
archrelease: copy trunk to staging-i686
git-svn-id: file:///srv/repos/svn-packages/svn@101422 eb2447ed-0c53-47e4-bac8-5bc4a241df78
- Loading branch information
allan
committed
Nov 29, 2010
1 parent
3ee3da8
commit 84d49fb
Showing
3 changed files
with
81 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,50 @@ | ||
# $Id$ | ||
# Maintainer: tobias <[email protected]> | ||
# Maintainer: Ray Rashif <[email protected]> | ||
# Contributor: Giovanni Scafora <[email protected]> | ||
|
||
# ardour, liblrdf and raptor are heavily dependent on each other. Updating of | ||
# one package mostly will require an update of all the other packages. I vote | ||
# for fixed dependencies speaking in terms of versions | ||
|
||
pkgname=ardour | ||
pkgver=2.8.11 | ||
pkgrel=2 | ||
pkgdesc="A multichannel hard disk recorder and digital audio workstation" | ||
arch=('i686' 'x86_64') | ||
url="http://ardour.org" | ||
license=('GPL') | ||
depends=('liblrdf' 'liblo' 'aubio' 'libusb-compat' | ||
'slv2' 'rubberband' 'libgnomecanvas') | ||
makedepends=('scons' 'boost' 'pkg-config') | ||
changelog=${pkgname}.changelog | ||
source=(ftp://ftp.archlinux.org/other/ardour/${pkgname}-${pkgver}.tar.bz2 | ||
${pkgname}.desktop) | ||
md5sums=('f451a8d0abc133a1700c3932e07a5612' | ||
'8aeaf433ebf781733db48e5a16b0c4da') | ||
|
||
build() { | ||
cd "${srcdir}/${pkgname}-${pkgver}" | ||
sed -i '/-O3/d' SConstruct | ||
|
||
scons ${MAKEFLAGS} ARCH="${CFLAGS}" \ | ||
PREFIX="/usr" \ | ||
DIST_LIBDIR="lib" \ | ||
FREEDESKTOP=0 \ | ||
FREESOUND=1 \ | ||
DESTDIR="${pkgdir}" | ||
} | ||
|
||
package() { | ||
cd "${srcdir}/${pkgname}-${pkgver}" | ||
|
||
scons PREFIX="/usr" \ | ||
FREEDESKTOP=0 \ | ||
FREESOUND=1 \ | ||
DESTDIR="${pkgdir}" install | ||
|
||
# install some freedesktop.org compatibility | ||
install -Dm644 "${srcdir}/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop" | ||
} | ||
|
||
# vim:set ts=2 sw=2 et: |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,22 @@ | ||
9 Aug 2010 (GMT+8) Ray Rashif <[email protected]> | ||
|
||
* 2.8.11-1 : | ||
Testing build. | ||
Updated to latest upstream release. | ||
Removed libgnomecanvasmm depend (ardour internal). | ||
Removed soundtouch makedepend (ardour internal, unneded). | ||
Added new depends | ||
- slv2 ("LV2" plug-ins support) | ||
- rubberband (can "do more" than soundtouch) | ||
- libgnomecanvas | ||
Not using SYSLIBS because upstream does not support it. | ||
Namcap warnings can be ignored; they're ardour internals. | ||
|
||
* PKGBUILD : | ||
Minor cosmetic ammendments. | ||
|
||
* ardour.changelog : | ||
Added this changelog. | ||
|
||
* ardour.install : | ||
Removed install scriptlet; old and deprecated information. |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,9 @@ | ||
[Desktop Entry] | ||
Name=Ardour | ||
Comment=Multitrack hard disk recorder | ||
Exec=ardour2 | ||
Icon=/usr/share/ardour2/icons/ardour_icon_48px.png | ||
Terminal=false | ||
Type=Application | ||
X-MultipleArgs=false | ||
Categories=GTK;Audio;AudioVideoEditing;AudioVideo;Video; |