forked from opnsense/ports
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Taken from: FreeBSD
- Loading branch information
Showing
11 changed files
with
136 additions
and
95 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -10,6 +10,38 @@ in the release notes and/or placed into UPDATING. | |
|
||
All ports committers are allowed to commit to this file. | ||
|
||
20150701: | ||
AUTHOR: [email protected] | ||
|
||
Make option target helpers have been added, it allows replacing: | ||
|
||
.include <bsd.port.options.mk> | ||
|
||
post-patch: | ||
${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' \ | ||
${WRKSRC}/Configure ${WRKSRC}/hints/freebsd.sh | ||
.if ${PORT_OPTIONS:MPTHREAD} | ||
${REINPLACE_CMD} -e 's|%%PTHREAD_LIBS%%|-lpthread|g;' \ | ||
${WRKSRC}/hints/freebsd.sh | ||
.else | ||
${REINPLACE_CMD} -e 's|%%PTHREAD_LIBS%%||g;' \ | ||
${WRKSRC}/hints/freebsd.sh | ||
.endif | ||
|
||
with: | ||
|
||
post-patch: | ||
${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' \ | ||
${WRKSRC}/Configure ${WRKSRC}/hints/freebsd.sh | ||
|
||
post-patch-PTHREAD-on: | ||
${REINPLACE_CMD} -e 's|%%PTHREAD_LIBS%%|-lpthread|g;' \ | ||
${WRKSRC}/hints/freebsd.sh | ||
|
||
post-patch-PTHREAD-off: | ||
${REINPLACE_CMD} -e 's|%%PTHREAD_LIBS%%||g;' \ | ||
${WRKSRC}/hints/freebsd.sh | ||
|
||
20150622: | ||
AUTHOR: [email protected] | ||
|
||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,39 @@ | ||
#!/bin/sh | ||
# MAINTAINER: [email protected] | ||
# $FreeBSD$ | ||
|
||
set -e | ||
|
||
. ${dp_SCRIPTSDIR}/functions.sh | ||
|
||
validate_env dp_ALLDEPENDS dp_PORTSDIR dp_PKGNAME dp_MAKE | ||
|
||
set -u | ||
|
||
check_dep() { | ||
for _dep ; do | ||
myifs=${IFS} | ||
IFS=: | ||
set -- ${_dep} | ||
IFS=${myifs} | ||
|
||
case "${2}" in | ||
/*) d=${2} ;; | ||
*) d=${dp_PORTSDIR}/${2} ;; | ||
esac | ||
|
||
case " ${checked} " in | ||
*\ ${d}\ *) continue ;; # Already checked | ||
esac | ||
checked="${checked} ${d}" | ||
if [ ! -d ${d} ]; then | ||
echo "${dp_PKGNAME}: \"${d}\" non-existent -- dependency list incomplete" >&2 | ||
continue | ||
fi | ||
echo ${d} | ||
check_dep $(${dp_MAKE} -C ${d} -V_UNIFIED_DEPENDS) | ||
done | ||
} | ||
|
||
checked= | ||
check_dep ${dp_ALLDEPENDS} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file was deleted.
Oops, something went wrong.
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters