Skip to content

Commit 33e98a2

Browse files
committed
*/*: sync with upstream
Taken from: FreeBSD
1 parent 61458af commit 33e98a2

File tree

2,904 files changed

+39671
-19581
lines changed

Some content is hidden

Large Commits have some content hidden by default. Use the searchbox below for content that may be hidden.

2,904 files changed

+39671
-19581
lines changed

accessibility/linux-c6-atk/Makefile

+1-2
Original file line numberDiff line numberDiff line change
@@ -12,8 +12,7 @@ LICENSE= GPLv3
1212

1313
CONFLICTS= linux-atk-[0-9]* linux-f10-atk-[0-9]*
1414

15-
ONLY_FOR_ARCHS= i386 amd64
16-
USE_LINUX= c6
15+
USES= linux:c6
1716
RPMVERSION= 1.el6
1817
USE_LINUX_RPM= yes
1918
USE_LDCONFIG= yes

accessibility/linux-f10-atk/Makefile

+1-3
Original file line numberDiff line numberDiff line change
@@ -5,15 +5,13 @@ PORTNAME= atk
55
PORTVERSION= 1.24.0
66
PORTREVISION= 1
77
CATEGORIES= accessibility linux
8-
MASTER_SITES= LOCAL/ehaupt/rpm/${LINUX_RPM_ARCH}/fedora/${LINUX_DIST_VER}
98

109
MAINTAINER= [email protected]
1110
COMMENT= Accessibility Toolkit, Linux/i386 binary (Linux Fedora 10)
1211

1312
CONFLICTS= linux-atk-[0-9]* linux-f8-atk-[0-9]*
1413

15-
ONLY_FOR_ARCHS= i386 amd64
16-
USE_LINUX= f10
14+
USES= linux:f10
1715
USE_LINUX_RPM= yes
1816

1917
RPMVERSION= 1.fc10

archivers/Makefile

+2-1
Original file line numberDiff line numberDiff line change
@@ -142,8 +142,8 @@
142142
SUBDIR += pecl-lzf
143143
SUBDIR += pecl-phk
144144
SUBDIR += pecl-rar
145+
SUBDIR += pecl-snappy
145146
SUBDIR += php-horde_lz4
146-
SUBDIR += php5-snappy
147147
SUBDIR += php55-bz2
148148
SUBDIR += php55-phar
149149
SUBDIR += php55-zip
@@ -171,6 +171,7 @@
171171
SUBDIR += py-lz4
172172
SUBDIR += py-lzma
173173
SUBDIR += py-pyliblzma
174+
SUBDIR += py-python-lhafile
174175
SUBDIR += py-python-snappy
175176
SUBDIR += py-rarfile
176177
SUBDIR += py-rcssmin

archivers/deb2targz/Makefile

+1
Original file line numberDiff line numberDiff line change
@@ -11,6 +11,7 @@ MAINTAINER= [email protected]
1111
COMMENT= Command-line utility for converting a Debian .deb file to a .tar.gz
1212

1313
NO_BUILD= yes
14+
NO_ARCH= yes
1415

1516
PLIST_FILES= bin/deb2targz
1617

archivers/gcpio/Makefile

-1
Original file line numberDiff line numberDiff line change
@@ -17,7 +17,6 @@ CPE_VENDOR= gnu
1717

1818
GNU_CONFIGURE= yes
1919
CONFIGURE_ARGS= --program-prefix=g \
20-
--disable-silent-rules \
2120
--with-rmt=/etc/rmt
2221
TEST_TARGET= check
2322

archivers/gtar/Makefile

+1-2
Original file line numberDiff line numberDiff line change
@@ -18,8 +18,7 @@ INFO= tar
1818
USES= charsetfix cpe iconv:${STATIC_ARGS} localbase makeinfo tar:xz
1919
CPE_VENDOR= gnu
2020
GNU_CONFIGURE= yes
21-
CONFIGURE_ARGS= --program-prefix=g \
22-
--disable-silent-rules
21+
CONFIGURE_ARGS= --program-prefix=g
2322
CONFIGURE_ENV= DEFAULT_ARCHIVE=/dev/sa0 \
2423
DEFAULT_RMT_COMMAND=/etc/rmt
2524
# supply result to skip a test that will abort configure if run as root

archivers/kzip/Makefile

+1-1
Original file line numberDiff line numberDiff line change
@@ -16,7 +16,7 @@ RESTRICTED= ${NO_CDROM}
1616

1717
ONLY_FOR_ARCHS= amd64 i386
1818

19-
USE_LINUX= yes
19+
USES= linux
2020
NO_BUILD= yes
2121
WRKSRC_SUBDIR= i686
2222

archivers/lhasa/Makefile

+1-2
Original file line numberDiff line numberDiff line change
@@ -17,8 +17,7 @@ USES= autoreconf pathfix libtool
1717
PATHFIX_MAKEFILEIN= Makefile.am
1818
GNU_CONFIGURE= yes
1919
USE_LDCONFIG= yes
20-
CONFIGURE_ARGS= --disable-silent-rules \
21-
--program-suffix=sa
20+
CONFIGURE_ARGS= --program-suffix=sa
2221
INSTALL_TARGET= install-strip
2322

2423
PORTDOCS= ChangeLog README AUTHORS TODO NEWS

archivers/linux-f10-ucl/Makefile

+1-3
Original file line numberDiff line numberDiff line change
@@ -4,20 +4,18 @@
44
PORTNAME= ucl
55
PORTVERSION= 1.03
66
CATEGORIES= archivers linux
7-
MASTER_SITES= LOCAL/ehaupt/rpm/${LINUX_RPM_ARCH}/fedora/${LINUX_DIST_VER}
87

98
MAINTAINER= [email protected]
109
COMMENT= UCL, a lossless data compression library (Linux Fedora 10)
1110

1211
CONFLICTS= linux-ucl-[0-9]* linux-f8-ucl-[0-9]*
1312

14-
USE_LINUX= f10
13+
USES= linux:f10
1514
USE_LINUX_RPM= yes
1615
RPMVERSION= 8.fc9
1716
USE_LDCONFIG= yes
1817

1918
PLIST_FILES= usr/lib/libucl.so.1 usr/lib/libucl.so.1.0.0
20-
DOCSDIR= ${PREFIX}/usr/share/doc/${PORTNAME}-${PORTVERSION}
2119
PORTDOCS= COPYING NEWS README THANKS TODO
2220
DESCR= ${.CURDIR}/../${PORTNAME}/pkg-descr
2321

archivers/linux-f10-upx/Makefile

+2-5
Original file line numberDiff line numberDiff line change
@@ -4,22 +4,19 @@
44
PORTNAME= upx
55
PORTVERSION= 3.03
66
CATEGORIES= archivers linux
7-
MASTER_SITES= LOCAL/ehaupt/rpm/${LINUX_RPM_ARCH}/fedora/${LINUX_DIST_VER}
87
PKGNAMEPREFIX= linux-f10-
98

109
MAINTAINER= [email protected]
1110
COMMENT= UPX, a high-performance executable packer (Linux Fedora 10)
1211

1312
CONFLICTS= linux-upx-[0-9]* linux-f8-upx-[0-9]*
1413

15-
USE_LINUX= f10
14+
USES= linux:f10
1615
USE_LINUX_RPM= yes
17-
USE_LINUX_APPS= ucl
16+
USE_LINUX= ucl
1817
RPMVERSION= 1.fc10
19-
BRANDELF_FILES= usr/bin/upx
2018

2119
PLIST_FILES= usr/bin/upx usr/share/man/man1/upx.1.gz
22-
DOCSDIR= ${PREFIX}/usr/share/doc/${PORTNAME}-${PORTVERSION}
2320
PORTDOCS= BUGS COPYING LICENSE NEWS PROJECTS README README.1ST \
2421
THANKS TODO elf-to-mem.txt filter.txt loader.txt selinux.txt
2522
DESCR= ${.CURDIR}/../${PORTNAME}/pkg-descr

archivers/pecl-phk/Makefile

-2
Original file line numberDiff line numberDiff line change
@@ -14,8 +14,6 @@ COMMENT= PHK is a PHP-oriented package/archive system
1414

1515
LICENSE= PHP301
1616

17-
BROKEN_powerpc64= Does not build
18-
1917
USES= php:ext tar:tgz
2018
USE_PHP= hash:build
2119
IGNORE_WITH_PHP= 70

archivers/pecl-snappy/Makefile

+28
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,28 @@
1+
# Created by: Melvyn Sopacua <[email protected]>
2+
# $FreeBSD$
3+
4+
PORTNAME= php5-snappy
5+
PORTVERSION= 0.1.5
6+
CATEGORIES= archivers
7+
8+
MAINTAINER= [email protected]
9+
COMMENT= PHP extension for the snappy compression algorithm
10+
11+
LICENSE= BSD2CLAUSE
12+
13+
LIB_DEPENDS= libsnappy.so:archivers/snappy
14+
15+
USES= php:ext
16+
USE_GITHUB= yes
17+
GH_ACCOUNT= kjdev
18+
GH_PROJECT= php-ext-snappy
19+
PHP_MODNAME= snappy
20+
CONFIGURE_ARGS= --with-snappy-includedir=${LOCALBASE}/include
21+
22+
do-test:
23+
(cd ${WRKSRC} && ${DO_MAKE_BUILD} NO_INTERACTION=yes test < /dev/null)
24+
25+
post-install:
26+
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/php/${PHP_EXT_DIR}/snappy.so
27+
28+
.include <bsd.port.mk>

archivers/pecl-snappy/distinfo

+3
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,3 @@
1+
TIMESTAMP = 1473896952
2+
SHA256 (kjdev-php-ext-snappy-0.1.5_GH0.tar.gz) = 78d407290ca7d75eed5127642d8dcb5c08a71ec611efa5f197980e48b3623dab
3+
SIZE (kjdev-php-ext-snappy-0.1.5_GH0.tar.gz) = 9516
File renamed without changes.

archivers/php5-snappy/Makefile

-32
This file was deleted.

archivers/php5-snappy/distinfo

-2
This file was deleted.

archivers/php5-snappy/files/patch-config.m4

-44
This file was deleted.

archivers/php55-phar/Makefile

-2
Original file line numberDiff line numberDiff line change
@@ -8,6 +8,4 @@ MASTERDIR= ${.CURDIR}/../../lang/php55
88

99
PKGNAMESUFFIX= -phar
1010

11-
BROKEN_powerpc64= Does not build
12-
1311
.include "${MASTERDIR}/Makefile"

archivers/py-borgbackup/Makefile

+1-1
Original file line numberDiff line numberDiff line change
@@ -2,7 +2,7 @@
22
# $FreeBSD$
33

44
PORTNAME= borgbackup
5-
PORTVERSION= 1.0.6
5+
PORTVERSION= 1.0.7
66
CATEGORIES= archivers python
77
MASTER_SITES= CHEESESHOP
88
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}

archivers/py-borgbackup/distinfo

+3-3
Original file line numberDiff line numberDiff line change
@@ -1,3 +1,3 @@
1-
TIMESTAMP = 1468508239
2-
SHA256 (borgbackup-1.0.6.tar.gz) = b72444d260b66538b6b5394f4f1919ab095214d130b5ffbb18ed83dac94db6b7
3-
SIZE (borgbackup-1.0.6.tar.gz) = 469242
1+
TIMESTAMP = 1473606772
2+
SHA256 (borgbackup-1.0.7.tar.gz) = 203353a299b6ea0c092a1f23b6bb5414a0b795712c213c68f7a1f4c24be131d1
3+
SIZE (borgbackup-1.0.7.tar.gz) = 462509

archivers/py-python-lhafile/Makefile

+22
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,22 @@
1+
# Created by: Carsten Larsen <[email protected]>
2+
# $FreeBSD$
3+
4+
PORTNAME= python-lhafile
5+
PORTVERSION= 0.2.1
6+
CATEGORIES= archivers python
7+
MASTER_SITES= http://fengestad.no/python-lhafile/
8+
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
9+
10+
MAINTAINER= [email protected]
11+
COMMENT= LHA(.lzh) file extract interface
12+
13+
LICENSE= BSD3CLAUSE
14+
LICENSE_FILE= ${WRKSRC}/COPYING.txt
15+
16+
USES= python
17+
USE_PYTHON= distutils autoplist
18+
19+
post-install:
20+
@${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/lzhlib.so
21+
22+
.include <bsd.port.mk>

archivers/py-python-lhafile/distinfo

+3
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,3 @@
1+
TIMESTAMP = 1469201699
2+
SHA256 (python-lhafile-0.2.1.tar.gz) = ccddfa7312d08a48159fa702c5e92efcc0e341d580e4dfb2c5a1bbdc2704e35e
3+
SIZE (python-lhafile-0.2.1.tar.gz) = 265756

archivers/py-python-lhafile/pkg-descr

+4
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,4 @@
1+
The interface is like zipfile extension included in regular
2+
python distribution.
3+
4+
WWW: http://fengestad.no/python-lhafile/

archivers/quazip/Makefile

+1-1
Original file line numberDiff line numberDiff line change
@@ -6,7 +6,7 @@ PORTVERSION= 0.7.1
66
CATEGORIES= archivers
77
MASTER_SITES= SF
88

9-
MAINTAINER= nivit@FreeBSD.org
9+
MAINTAINER= kde@FreeBSD.org
1010
COMMENT= Qt/C++ wrapper for ZIP/UNZIP package
1111

1212
LICENSE= LGPL21

archivers/rar/Makefile

+6-3
Original file line numberDiff line numberDiff line change
@@ -2,7 +2,7 @@
22
# $FreeBSD$
33

44
PORTNAME= rar
5-
PORTVERSION= 5.3.0
5+
PORTVERSION= 5.4.0
66
PORTEPOCH= 3
77
CATEGORIES= archivers
88
MASTER_SITES= http://www.rarlab.com/rar/
@@ -22,7 +22,10 @@ WRKSRC= ${WRKDIR}/rar
2222
PLIST_FILES= bin/rar lib/default.sfx etc/rarfiles.lst man/cat1/rar.1.gz
2323
PORTDOCS= license.txt whatsnew.txt order.htm readme.txt
2424

25-
OPTIONS_DEFINE= DOCS
25+
OPTIONS_DEFINE= DOCS SFX
26+
OPTIONS_DEFAULT=SFX
27+
28+
SFX_DESC= SFX archive support (implies compat9x on FreeBSD 10 and up)
2629

2730
.include <bsd.port.pre.mk>
2831

@@ -37,7 +40,7 @@ IGNORE= requires a kernel with compiled-in IA32 compatibility
3740
.endif
3841
.endif
3942

40-
.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1000054
43+
.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1000054 && ${PORT_OPTIONS:MSFX}
4144
RUN_DEPENDS+= ${LOCALBASE}/lib/compat/libstdc++.so.6:misc/compat9x
4245
.endif
4346

archivers/rar/distinfo

+3-2
Original file line numberDiff line numberDiff line change
@@ -1,2 +1,3 @@
1-
SHA256 (rarbsd-5.3.0.tar.gz) = 54554a9d83d7386d9850d714af375bb30576a72b7a4bcb3242bcc8bf183ccb7a
2-
SIZE (rarbsd-5.3.0.tar.gz) = 1406335
1+
TIMESTAMP = 1473360405
2+
SHA256 (rarbsd-5.4.0.tar.gz) = 55698e907dba868c04d3e98e715938cf51999b3f4a5b9af95b2c8f5f60c0a309
3+
SIZE (rarbsd-5.4.0.tar.gz) = 1602855

archivers/snappy-java/Makefile

+2
Original file line numberDiff line numberDiff line change
@@ -23,6 +23,8 @@ COMMENT= Fast compressor/decompressor library
2323

2424
LICENSE= APACHE20
2525

26+
BROKEN= Unfetchable (google code has gone away)
27+
2628
BUILD_DEPENDS= ${LOCALBASE}/share/java/maven3/bin/mvn:devel/maven3
2729

2830
USE_GITHUB= yes

archivers/stuffit/Makefile

+1-1
Original file line numberDiff line numberDiff line change
@@ -15,7 +15,7 @@ RESTRICTED= Only unmodified original package can be distributed
1515

1616
ONLY_FOR_ARCHS= i386 amd64
1717

18-
USE_LINUX= yes
18+
USES= linux
1919
NO_WRKSUBDIR= yes
2020
STUFFIT_FILES= bin/unstuff bin/stuff
2121
STUFFIT_MAN= man/man1/stuff.1 man/man1/unstuff.1

archivers/xar/Makefile

+1-1
Original file line numberDiff line numberDiff line change
@@ -5,7 +5,7 @@ PORTNAME= xar
55
PORTVERSION= 1.5.2
66
PORTREVISION= 2
77
CATEGORIES= archivers
8-
MASTER_SITES= GOOGLE_CODE GENTOO
8+
MASTER_SITES= GENTOO
99

1010
MAINTAINER= [email protected]
1111
COMMENT= OpenDarwin XML eXtensible ARchiver

0 commit comments

Comments
 (0)