Skip to content

Commit 54a51c4

Browse files
committed
*/*: sync with upstream
Taken from: FreeBSD
1 parent 800f38a commit 54a51c4

File tree

242 files changed

+1359
-621
lines changed

Some content is hidden

Large Commits have some content hidden by default. Use the searchbox below for content that may be hidden.

242 files changed

+1359
-621
lines changed

astro/libosmpbf/Makefile

+1-1
Original file line numberDiff line numberDiff line change
@@ -4,7 +4,7 @@
44
PORTNAME= libosmpbf
55
PORTVERSION= 1.3.3
66
DISTVERSIONPREFIX= v
7-
PORTREVISION= 1
7+
PORTREVISION= 2
88
CATEGORIES= astro geography devel
99

1010
MAINTAINER= [email protected]

astro/merkaartor/Makefile

+1-1
Original file line numberDiff line numberDiff line change
@@ -3,7 +3,7 @@
33

44
PORTNAME= merkaartor
55
PORTVERSION= 0.18.2
6-
PORTREVISION= 3
6+
PORTREVISION= 4
77
CATEGORIES= astro
88

99
MAINTAINER= [email protected]

audio/clementine-player/Makefile

+1-1
Original file line numberDiff line numberDiff line change
@@ -3,7 +3,7 @@
33

44
PORTNAME= clementine
55
PORTVERSION= 1.3.1
6-
PORTREVISION= 5
6+
PORTREVISION= 6
77
CATEGORIES= audio
88
PKGNAMESUFFIX= -player
99

audio/mixxx/Makefile

+1-1
Original file line numberDiff line numberDiff line change
@@ -4,7 +4,7 @@
44
PORTNAME= mixxx
55
PORTVERSION= 1.11.0
66
DISTVERSIONSUFFIX= -src
7-
PORTREVISION= 13
7+
PORTREVISION= 14
88
CATEGORIES= audio
99
MASTER_SITES= http://downloads.mixxx.org/${PORTNAME}-${PORTVERSION}/
1010

audio/mumble/Makefile

+1-1
Original file line numberDiff line numberDiff line change
@@ -3,7 +3,7 @@
33

44
PORTNAME= mumble
55
PORTVERSION= 1.2.18
6-
PORTREVISION= 1
6+
PORTREVISION= 2
77
CATEGORIES= audio
88

99
MAINTAINER= [email protected]

audio/murmur/Makefile

+1-1
Original file line numberDiff line numberDiff line change
@@ -3,7 +3,7 @@
33

44
PORTNAME= murmur
55
PORTVERSION= 1.2.18
6-
PORTREVISION= 1
6+
PORTREVISION= 2
77
CATEGORIES= audio net
88

99
MAINTAINER= [email protected]

devel/Makefile

+2
Original file line numberDiff line numberDiff line change
@@ -1312,6 +1312,7 @@
13121312
SUBDIR += libgsf
13131313
SUBDIR += libgta
13141314
SUBDIR += libgtop
1315+
SUBDIR += libgudev
13151316
SUBDIR += libgutenfetch
13161317
SUBDIR += libhash
13171318
SUBDIR += libhid
@@ -1448,6 +1449,7 @@
14481449
SUBDIR += libtpl
14491450
SUBDIR += libtuntap
14501451
SUBDIR += libublio
1452+
SUBDIR += libudev-devd
14511453
SUBDIR += libukcprog
14521454
SUBDIR += libunicode
14531455
SUBDIR += libuninum

devel/elixir-lager_logger/Makefile

-2
Original file line numberDiff line numberDiff line change
@@ -11,8 +11,6 @@ COMMENT= Lager backend for Elixir's Logger
1111

1212
LICENSE= APACHE20
1313

14-
BROKEN= does not build with elixir 1.4.1
15-
1614
USES= elixir
1715
USE_GITHUB= yes
1816
GH_ACCOUNT= PSPDFKit-labs

devel/elixir-lager_logger/files/patch-mix.exs

+7-4
Original file line numberDiff line numberDiff line change
@@ -1,8 +1,11 @@
1-
--- mix.exs.orig 2015-09-28 11:36:41 UTC
1+
--- mix.exs.orig 2016-06-28 18:41:37 UTC
22
+++ mix.exs
3-
@@ -6,8 +6,7 @@ defmodule LagerLogger.Mixfile do
4-
version: "1.0.1",
5-
elixir: ">= 1.0.0 and <= 1.2.0",
3+
@@ -4,10 +4,9 @@ defmodule LagerLogger.Mixfile do
4+
def project do
5+
[app: :lager_logger,
6+
version: "1.0.3",
7+
- elixir: ">= 1.1.0 and <= 1.4.0",
8+
+ elixir: ">= 1.1.0 and < 1.5.0",
69
package: package,
710
- description: description,
811
- deps: deps]
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,186 @@
1+
--- python/modules/IcePy/Operation.cpp.orig 2017-01-29 22:23:51.186130998 +0100
2+
+++ python/modules/IcePy/Operation.cpp 2017-01-29 22:24:55.929130998 +0100
3+
@@ -1682,11 +1682,11 @@
4+
}
5+
else
6+
{
7+
- if(PyTuple_SET_ITEM(results.get(), info->pos, Unset) < 0)
8+
+ if(PyTuple_SetItem(results.get(), info->pos, Unset) < 0)
9+
{
10+
return 0;
11+
}
12+
- Py_INCREF(Unset); // PyTuple_SET_ITEM steals a reference.
13+
+ Py_INCREF(Unset); // PyTuple_SetItem steals a reference.
14+
}
15+
}
16+
17+
@@ -2546,7 +2546,7 @@
18+
throwPythonException();
19+
}
20+
21+
- if(PyTuple_SET_ITEM(result.get(), 0, ok ? incTrue() : incFalse()) < 0)
22+
+ if(PyTuple_SetItem(result.get(), 0, ok ? incTrue() : incFalse()) < 0)
23+
{
24+
throwPythonException();
25+
}
26+
@@ -2586,11 +2586,11 @@
27+
}
28+
#endif
29+
30+
- if(PyTuple_SET_ITEM(result.get(), 1, op.get()) < 0)
31+
+ if(PyTuple_SetItem(result.get(), 1, op.get()) < 0)
32+
{
33+
throwPythonException();
34+
}
35+
- op.release(); // PyTuple_SET_ITEM steals a reference.
36+
+ op.release(); // PyTuple_SetItem steals a reference.
37+
38+
return result.release();
39+
}
40+
@@ -2827,7 +2827,7 @@
41+
return 0;
42+
}
43+
44+
- if(PyTuple_SET_ITEM(args.get(), 0, ok ? incTrue() : incFalse()) < 0)
45+
+ if(PyTuple_SetItem(args.get(), 0, ok ? incTrue() : incFalse()) < 0)
46+
{
47+
return 0;
48+
}
49+
@@ -2867,11 +2867,11 @@
50+
memcpy(buf, results.first, sz);
51+
#endif
52+
53+
- if(PyTuple_SET_ITEM(args.get(), 1, op.get()) < 0)
54+
+ if(PyTuple_SetItem(args.get(), 1, op.get()) < 0)
55+
{
56+
return 0;
57+
}
58+
- op.release(); // PyTuple_SET_ITEM steals a reference.
59+
+ op.release(); // PyTuple_SetItem steals a reference.
60+
61+
return args.release();
62+
}
63+
@@ -2910,7 +2910,7 @@
64+
return;
65+
}
66+
67+
- if(PyTuple_SET_ITEM(args.get(), 0, ok ? incTrue() : incFalse()) < 0)
68+
+ if(PyTuple_SetItem(args.get(), 0, ok ? incTrue() : incFalse()) < 0)
69+
{
70+
assert(PyErr_Occurred());
71+
PyErr_Print();
72+
@@ -2958,13 +2958,13 @@
73+
memcpy(buf, results.first, sz);
74+
#endif
75+
76+
- if(PyTuple_SET_ITEM(args.get(), 1, op.get()) < 0)
77+
+ if(PyTuple_SetItem(args.get(), 1, op.get()) < 0)
78+
{
79+
assert(PyErr_Occurred());
80+
PyErr_Print();
81+
return;
82+
}
83+
- op.release(); // PyTuple_SET_ITEM steals a reference.
84+
+ op.release(); // PyTuple_SetItem steals a reference.
85+
86+
PyObjectHandle tmp = PyObject_Call(_response, args.get(), 0);
87+
if(PyErr_Occurred())
88+
@@ -3126,7 +3126,7 @@
89+
return;
90+
}
91+
92+
- if(PyTuple_SET_ITEM(args.get(), 0, ok ? incTrue() : incFalse()) < 0)
93+
+ if(PyTuple_SetItem(args.get(), 0, ok ? incTrue() : incFalse()) < 0)
94+
{
95+
assert(PyErr_Occurred());
96+
PyErr_Print();
97+
@@ -3174,13 +3174,13 @@
98+
memcpy(buf, results.first, sz);
99+
#endif
100+
101+
- if(PyTuple_SET_ITEM(args.get(), 1, op.get()) < 0)
102+
+ if(PyTuple_SetItem(args.get(), 1, op.get()) < 0)
103+
{
104+
assert(PyErr_Occurred());
105+
PyErr_Print();
106+
return;
107+
}
108+
- op.release(); // PyTuple_SET_ITEM steals a reference.
109+
+ op.release(); // PyTuple_SetItem steals a reference.
110+
111+
const string methodName = "ice_response";
112+
if(!PyObject_HasAttrString(_callback, STRCAST(methodName.c_str())))
113+
@@ -3302,11 +3302,11 @@
114+
}
115+
else
116+
{
117+
- if(PyTuple_SET_ITEM(args.get(), info->pos + offset, Unset) < 0)
118+
+ if(PyTuple_SetItem(args.get(), info->pos + offset, Unset) < 0)
119+
{
120+
throwPythonException();
121+
}
122+
- Py_INCREF(Unset); // PyTuple_SET_ITEM steals a reference.
123+
+ Py_INCREF(Unset); // PyTuple_SetItem steals a reference.
124+
}
125+
}
126+
127+
@@ -3329,11 +3329,11 @@
128+
// Create an object to represent Ice::Current. We need to append this to the argument tuple.
129+
//
130+
PyObjectHandle curr = createCurrent(current);
131+
- if(PyTuple_SET_ITEM(args.get(), PyTuple_GET_SIZE(args.get()) - 1, curr.get()) < 0)
132+
+ if(PyTuple_SetItem(args.get(), PyTuple_GET_SIZE(args.get()) - 1, curr.get()) < 0)
133+
{
134+
throwPythonException();
135+
}
136+
- curr.release(); // PyTuple_SET_ITEM steals a reference.
137+
+ curr.release(); // PyTuple_SetItem steals a reference.
138+
139+
if(_op->amd)
140+
{
141+
@@ -3347,7 +3347,7 @@
142+
}
143+
obj->upcall = new UpcallPtr(this);
144+
obj->encoding = current.encoding;
145+
- if(PyTuple_SET_ITEM(args.get(), 0, (PyObject*)obj) < 0) // PyTuple_SET_ITEM steals a reference.
146+
+ if(PyTuple_SetItem(args.get(), 0, (PyObject*)obj) < 0) // PyTuple_SetItem steals a reference.
147+
{
148+
Py_DECREF(obj);
149+
throwPythonException();
150+
@@ -3698,23 +3698,23 @@
151+
}
152+
#endif
153+
154+
- if(PyTuple_SET_ITEM(args.get(), start, ip.get()) < 0)
155+
+ if(PyTuple_SetItem(args.get(), start, ip.get()) < 0)
156+
{
157+
throwPythonException();
158+
}
159+
++start;
160+
- ip.release(); // PyTuple_SET_ITEM steals a reference.
161+
+ ip.release(); // PyTuple_SetItem steals a reference.
162+
163+
//
164+
// Create an object to represent Ice::Current. We need to append
165+
// this to the argument tuple.
166+
//
167+
PyObjectHandle curr = createCurrent(current);
168+
- if(PyTuple_SET_ITEM(args.get(), start, curr.get()) < 0)
169+
+ if(PyTuple_SetItem(args.get(), start, curr.get()) < 0)
170+
{
171+
throwPythonException();
172+
}
173+
- curr.release(); // PyTuple_SET_ITEM steals a reference.
174+
+ curr.release(); // PyTuple_SetItem steals a reference.
175+
176+
string dispatchName = "ice_invoke";
177+
if(_amd)
178+
@@ -3730,7 +3730,7 @@
179+
}
180+
obj->upcall = new UpcallPtr(this);
181+
obj->encoding = current.encoding;
182+
- if(PyTuple_SET_ITEM(args.get(), 0, (PyObject*)obj) < 0) // PyTuple_SET_ITEM steals a reference.
183+
+ if(PyTuple_SetItem(args.get(), 0, (PyObject*)obj) < 0) // PyTuple_SetItem steals a reference.
184+
{
185+
Py_DECREF(obj);
186+
throwPythonException();

devel/libepoll-shim/Makefile

+4
Original file line numberDiff line numberDiff line change
@@ -20,6 +20,10 @@ USE_LDCONFIG= yes
2020
USES= uidfix
2121
MAKE_ARGS= LIBDIR=${PREFIX}/lib INCLUDEDIR=${PREFIX}/include
2222

23+
post-patch:
24+
# -Weverything is not recognized by GCC
25+
@${REINPLACE_CMD} -e 's|Weverything|Wall|' ${WRKSRC}/Makefile
26+
2327
pre-install:
2428
@${MKDIR} ${STAGEDIR}/${PREFIX}/include/libepoll-shim/sys
2529

devel/libgudev/Makefile

+24
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,24 @@
1+
# Created by [email protected]
2+
# $FreeBSD$
3+
4+
PORTNAME= libgudev
5+
PORTVERSION= 230
6+
PORTREVISION= 1
7+
CATEGORIES= devel
8+
MASTER_SITES= https://download.gnome.org/sources/libgudev/${PORTVERSION}/
9+
10+
MAINTAINER= [email protected]
11+
COMMENT= GObject bindings for libudev.
12+
13+
LICENSE= LGPL21
14+
LICENSE_FILE= ${WRKSRC}/COPYING
15+
16+
LIB_DEPENDS= libudev.so:devel/libudev-devd
17+
18+
USES= gettext-runtime gmake libtool pathfix pkgconfig tar:xz
19+
USE_GNOME= glib20 introspection:build
20+
GNU_CONFIGURE= yes
21+
USE_LDCONFIG= yes
22+
INSTALL_TARGET= install-strip
23+
24+
.include <bsd.port.mk>

devel/libgudev/distinfo

+3
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,3 @@
1+
TIMESTAMP = 1485731896
2+
SHA256 (libgudev-230.tar.xz) = a2e77faced0c66d7498403adefcc0707105e03db71a2b2abd620025b86347c18
3+
SIZE (libgudev-230.tar.xz) = 257528

devel/libgudev/pkg-descr

+3
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,3 @@
1+
This library provides GObject bindings for libudev.
2+
3+
WWW: https://wiki.gnome.org/Projects/libgudev

devel/libgudev/pkg-plist

+13
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,13 @@
1+
include/gudev-1.0/gudev/gudev.h
2+
include/gudev-1.0/gudev/gudevclient.h
3+
include/gudev-1.0/gudev/gudevdevice.h
4+
include/gudev-1.0/gudev/gudevenumerator.h
5+
include/gudev-1.0/gudev/gudevenums.h
6+
include/gudev-1.0/gudev/gudevenumtypes.h
7+
include/gudev-1.0/gudev/gudevtypes.h
8+
lib/girepository-1.0/GUdev-1.0.typelib
9+
lib/libgudev-1.0.so
10+
lib/libgudev-1.0.so.0
11+
lib/libgudev-1.0.so.0.2.0
12+
libdata/pkgconfig/gudev-1.0.pc
13+
share/gir-1.0/GUdev-1.0.gir

devel/libudev-devd/Makefile

+30
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,30 @@
1+
# $FreeBSD$
2+
3+
PORTNAME= libudev-devd
4+
PORTVERSION= 0.2
5+
CATEGORIES= devel
6+
7+
MAINTAINER= [email protected]
8+
COMMENT= libudev-compatible interface for devd
9+
10+
LICENSE= BSD2CLAUSE
11+
12+
BUILD_DEPENDS= v4l_compat>=0:multimedia/v4l_compat
13+
LIB_DEPENDS= libevdev.so:devel/libevdev
14+
15+
USE_GITHUB= yes
16+
GH_ACCOUNT= FreeBSDDesktop
17+
GH_TAGNAME= 5a9d2b9
18+
19+
USES= dos2unix autoreconf gmake libtool localbase pathfix pkgconfig
20+
USE_LDCONFIG= yes
21+
GNU_CONFIGURE= yes
22+
INSTALL_TARGET= install-strip
23+
24+
PLIST_FILES= include/libudev.h \
25+
lib/libudev.so \
26+
lib/libudev.so.0 \
27+
lib/libudev.so.0.0.0 \
28+
libdata/pkgconfig/libudev.pc
29+
30+
.include <bsd.port.mk>

devel/libudev-devd/distinfo

+3
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,3 @@
1+
TIMESTAMP = 1485731600
2+
SHA256 (FreeBSDDesktop-libudev-devd-0.2-5a9d2b9_GH0.tar.gz) = 847111e0e34b434d647f7f8ce5ebf3546cea539b29e124abccfe9606492348d8
3+
SIZE (FreeBSDDesktop-libudev-devd-0.2-5a9d2b9_GH0.tar.gz) = 16411
+13
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,13 @@
1+
--- utils.h.orig 2017-01-07 22:21:49 UTC
2+
+++ utils.h
3+
@@ -5,8 +5,8 @@
4+
#include <unistd.h>
5+
6+
7+
-#define ENABLE_TRACE
8+
-#define LOG_LEVEL 1
9+
+/* #define ENABLE_TRACE */
10+
+#define LOG_LEVEL 0
11+
12+
/*
13+
#ifndef LOG_LEVEL

devel/libudev-devd/pkg-descr

+5
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,5 @@
1+
libudev-compatible interface for devd
2+
3+
Intended to work with xorg-server and libinput
4+
5+
WWW: https://github.com/FreeBSDDesktop/libudev-devd

0 commit comments

Comments
 (0)