Skip to content

Commit 65f14c3

Browse files
committed
*/*: sync with upstream
Taken from: FreeBSD
1 parent 009ad78 commit 65f14c3

File tree

100 files changed

+1036
-363
lines changed

Some content is hidden

Large Commits have some content hidden by default. Use the searchbox below for content that may be hidden.

100 files changed

+1036
-363
lines changed

archivers/py-borgbackup/Makefile

+7-5
Original file line numberDiff line numberDiff line change
@@ -27,17 +27,19 @@ USES= python:3.4+
2727
USE_PYTHON= autoplist distutils
2828
USE_OPENSSL= yes
2929

30-
.include <bsd.port.pre.mk>
31-
32-
.if defined(PACKAGE_BUILDING) && ${PYTHON_VER} != ${PYTHON_DEFAULT}
33-
IGNORE= you have python ${PYTHON_DEFAULT} set as the default, and this needs ${PYTHON_VER}
34-
.endif
30+
.include <bsd.port.options.mk>
3531

3632
# borg requires openssl>=1.0.0
3733
.if ${OSVERSION} < 1000015
3834
WITH_OPENSSL_PORT=yes
3935
.endif
4036

37+
.include <bsd.port.pre.mk>
38+
39+
.if defined(PACKAGE_BUILDING) && ${PYTHON_VER} != ${PYTHON_DEFAULT}
40+
IGNORE= you have python ${PYTHON_DEFAULT} set as the default, and this needs ${PYTHON_VER}
41+
.endif
42+
4143
post-install:
4244
${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/borg/*.so
4345

benchmarks/fio/Makefile

+1-1
Original file line numberDiff line numberDiff line change
@@ -2,7 +2,7 @@
22
# $FreeBSD$
33

44
PORTNAME= fio
5-
PORTVERSION= 2.11
5+
PORTVERSION= 2.12
66
CATEGORIES= benchmarks
77
MASTER_SITES= http://brick.kernel.dk/snaps/
88

benchmarks/fio/distinfo

+3-3
Original file line numberDiff line numberDiff line change
@@ -1,3 +1,3 @@
1-
TIMESTAMP = 1464561760
2-
SHA256 (fio-2.11.tar.bz2) = be0130047a396e7b76a3cd2bd21705e0497807c037bbaeade273a4c3ea9be4af
3-
SIZE (fio-2.11.tar.bz2) = 527395
1+
TIMESTAMP = 1466083025
2+
SHA256 (fio-2.12.tar.bz2) = 72fd4bb9fb20bce003ea0cda98cb89f38d2a345a3112b253ff76402c3cde8407
3+
SIZE (fio-2.12.tar.bz2) = 529288

converters/R-cran-jsonlite/Makefile

+1-1
Original file line numberDiff line numberDiff line change
@@ -2,7 +2,7 @@
22
# $FreeBSD$
33

44
PORTNAME= jsonlite
5-
PORTVERSION= 0.9.21
5+
PORTVERSION= 0.9.22
66
CATEGORIES= converters
77
DISTNAME= ${PORTNAME}_${PORTVERSION}
88

converters/R-cran-jsonlite/distinfo

+3-3
Original file line numberDiff line numberDiff line change
@@ -1,3 +1,3 @@
1-
TIMESTAMP = 1465155284
2-
SHA256 (jsonlite_0.9.21.tar.gz) = 079349342ea6eb92bd5fa8f6a7c08d9e3652c3d41010b64afbc3297671eb3791
3-
SIZE (jsonlite_0.9.21.tar.gz) = 1057400
1+
TIMESTAMP = 1466076246
2+
SHA256 (jsonlite_0.9.22.tar.gz) = 381d97ca92b14a87774e75e4b3b83bd8799bccd70b6fdd93faff896ac78f1d0a
3+
SIZE (jsonlite_0.9.22.tar.gz) = 1057097

databases/adabase/Makefile

+1-1
Original file line numberDiff line numberDiff line change
@@ -2,7 +2,7 @@
22
# $FreeBSD$
33

44
PORTNAME= adabase
5-
PORTVERSION= 3.0
5+
PORTVERSION= 3.1
66
DISTVERSIONPREFIX= v
77
CATEGORIES= databases
88

databases/adabase/distinfo

+3-2
Original file line numberDiff line numberDiff line change
@@ -1,2 +1,3 @@
1-
SHA256 (jrmarino-AdaBase-v3.0_GH0.tar.gz) = 65b2b81b1b083951771ff6f8c4efa6dadb84ecdc7147659dffb10527803b54c5
2-
SIZE (jrmarino-AdaBase-v3.0_GH0.tar.gz) = 132468
1+
TIMESTAMP = 1466107071
2+
SHA256 (jrmarino-AdaBase-v3.1_GH0.tar.gz) = 115967a90abf94f102aa4916a2ed14fb7aac2382f56113b791f2fd08b909444a
3+
SIZE (jrmarino-AdaBase-v3.1_GH0.tar.gz) = 163154

databases/adabase/pkg-plist

+6
Original file line numberDiff line numberDiff line change
@@ -55,6 +55,10 @@ include/adabase/adabase-statement.ads
5555
include/adabase/adabase.ads
5656
include/adabase/commontext.adb
5757
include/adabase/commontext.ads
58+
include/adabase/spatial_data-well_known_binary.adb
59+
include/adabase/spatial_data-well_known_binary.ads
60+
include/adabase/spatial_data.adb
61+
include/adabase/spatial_data.ads
5862
%%MYSQL%%lib/adabase/adabase-bindings-mysql.ali
5963
%%PGSQL%%lib/adabase/adabase-bindings-postgresql.ali
6064
%%SQLITE%%lib/adabase/adabase-bindings-sqlite.ali
@@ -92,4 +96,6 @@ lib/adabase/adabase-statement.ali
9296
lib/adabase/adabase.ali
9397
lib/adabase/commontext.ali
9498
lib/adabase/libadabase.a
99+
lib/adabase/spatial_data-well_known_binary.ali
100+
lib/adabase/spatial_data.ali
95101
lib/gnat/adabase.gpr

databases/mariadb101-server/Makefile

+4-4
Original file line numberDiff line numberDiff line change
@@ -144,12 +144,12 @@ post-install:
144144
${STAGEDIR}/${PREFIX}/share/pkgconfig
145145
.endif # defined(CLIENT_ONLY)
146146

147-
.if defined(WITH_OPENSSL_PORT)
148-
GSSAPI_BASE_IGNORE= BASE_GSSAPI is not compatible with OpenSSL from ports. Use other GSSAPI options or OpenSSL from base system
149-
.endif
150-
151147
.include <bsd.port.pre.mk>
152148

149+
.if ${SSL_DEFAULT} != base && ${PORT_OPTIONS:MGSSAPI_BASE}
150+
IGNORE= BASE_GSSAPI is not compatible with OpenSSL from ports. Use other GSSAPI options or OpenSSL from base system
151+
.endif
152+
153153
.if ${OPSYS} == DragonFly
154154
CMAKE_ARGS+= -DWITHOUT_TOKUDB
155155
.endif

databases/mysql57-server/Makefile

+7-3
Original file line numberDiff line numberDiff line change
@@ -129,18 +129,22 @@ PERFSCHM_SUB_LIST+= PERFSCHEMRC=""
129129
PERFSCHM_SUB_LIST_OFF+= PERFSCHEMRC="--skip-performance-schema"
130130
.endif
131131

132-
.include <bsd.port.pre.mk>
132+
.include <bsd.port.options.mk>
133133

134134
### Just for the sake of FreeBSD 9.X ###
135135
.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000000
136136
.if !defined(CLIENT_ONLY)
137137
EXTRA_PATCHES+= ${PATCHDIR}/rapid_plugin-patch-_x_mysqlxtest__src_mysqlxtest.cc
138138
.endif
139139
WITH_OPENSSL_PORT= yes
140+
CMAKE_ARGS+= -DWITH_SSL=${OPENSSLBASE}
141+
.endif
142+
143+
.include <bsd.port.pre.mk>
140144

141145
### FreeBSD Version > 9.X ###
142-
.else
143-
.if defined(WITH_OPENSSL_BASE)
146+
.if ${OPSYS} == FreeBSD && ${OSVERSION} > 1000000
147+
.if ${SSL_DEFAULT} == base
144148
CMAKE_ARGS+= -DWITH_SSL=system
145149
.else
146150
CMAKE_ARGS+= -DWITH_SSL=${OPENSSLBASE}

devel/Makefile

+1
Original file line numberDiff line numberDiff line change
@@ -43,6 +43,7 @@
4343
SUBDIR += R-cran-reshape2
4444
SUBDIR += R-cran-rngtools
4545
SUBDIR += R-cran-rstudioapi
46+
SUBDIR += R-cran-tibble
4647
SUBDIR += R-cran-tidyr
4748
SUBDIR += SpecTcl
4849
SUBDIR += aap

devel/R-cran-caret/Makefile

+1-1
Original file line numberDiff line numberDiff line change
@@ -2,7 +2,7 @@
22
# $FreeBSD$
33

44
PORTNAME= caret
5-
DISTVERSION= 6.0-68
5+
DISTVERSION= 6.0-70
66
CATEGORIES= devel
77
DISTNAME= ${PORTNAME}_${DISTVERSION}
88

devel/R-cran-caret/distinfo

+3-2
Original file line numberDiff line numberDiff line change
@@ -1,2 +1,3 @@
1-
SHA256 (caret_6.0-68.tar.gz) = 4636a974eb187a7a53199a1b5e5189dbbe11d2c892c5aea0c3ab4be41f47d213
2-
SIZE (caret_6.0-68.tar.gz) = 4181028
1+
TIMESTAMP = 1465982430
2+
SHA256 (caret_6.0-70.tar.gz) = 21c5bdf7cf07bece38729465366564d8ca104c2466ee9fd800ca1fd88eb82f38
3+
SIZE (caret_6.0-70.tar.gz) = 4287504

devel/R-cran-tibble/Makefile

+20
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,20 @@
1+
# Created by: TAKATSU Tomonari <[email protected]>
2+
# $FreeBSD$
3+
4+
PORTNAME= tibble
5+
PORTVERSION= 1.0
6+
CATEGORIES= devel
7+
DISTNAME= ${PORTNAME}_${DISTVERSION}
8+
9+
MAINTAINER= [email protected]
10+
COMMENT= Simple Data Frames
11+
12+
LICENSE= MIT
13+
14+
RUN_DEPENDS= R-cran-assertthat>0:math/R-cran-assertthat \
15+
R-cran-lazyeval>0.0.10:math/R-cran-lazyeval \
16+
R-cran-Rcpp>0:devel/R-cran-Rcpp
17+
18+
USES= cran:auto-plist
19+
20+
.include <bsd.port.mk>

devel/R-cran-tibble/distinfo

+3
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,3 @@
1+
TIMESTAMP = 1466077159
2+
SHA256 (tibble_1.0.tar.gz) = c61285cc07dc9182b7a631c648eaf6f8994f5fde0f603736ada2c2da6b55b180
3+
SIZE (tibble_1.0.tar.gz) = 38038

devel/R-cran-tibble/pkg-descr

+4
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,4 @@
1+
tibble provides a 'tbl_df' class that offers better checking and
2+
printing capabilities than traditional data frames.
3+
4+
WWW: https://cran.r-project.org/web/packages/tibble/

devel/R-cran-tidyr/Makefile

+3-2
Original file line numberDiff line numberDiff line change
@@ -2,7 +2,7 @@
22
# $FreeBSD$
33

44
PORTNAME= tidyr
5-
PORTVERSION= 0.4.1
5+
PORTVERSION= 0.5.1
66
CATEGORIES= devel
77
DISTNAME= ${PORTNAME}_${PORTVERSION}
88

@@ -11,7 +11,8 @@ COMMENT= Easily tidy data with spread and gather functions
1111

1212
LICENSE= MIT
1313

14-
RUN_DEPENDS= R-cran-dplyr>=0.4:math/R-cran-dplyr \
14+
RUN_DEPENDS= R-cran-tibble>0:devel/R-cran-tibble \
15+
R-cran-dplyr>=0.4:math/R-cran-dplyr \
1516
R-cran-stringi>0:textproc/R-cran-stringi \
1617
R-cran-lazyeval>0:math/R-cran-lazyeval \
1718
R-cran-magrittr>0:devel/R-cran-magrittr \

devel/R-cran-tidyr/distinfo

+3-2
Original file line numberDiff line numberDiff line change
@@ -1,2 +1,3 @@
1-
SHA256 (tidyr_0.4.1.tar.gz) = 506cfb48b9fc697c9c259588b8e1aab8547e14ab98741a73153d122ab2a7e676
2-
SIZE (tidyr_0.4.1.tar.gz) = 158472
1+
TIMESTAMP = 1465983461
2+
SHA256 (tidyr_0.5.1.tar.gz) = dbab642ac7231cbfe3e2a0d4553fb4ffb3699c6d6b432be2bb5812dfbbdbdace
3+
SIZE (tidyr_0.5.1.tar.gz) = 344562

devel/acsccid/Makefile

+4-4
Original file line numberDiff line numberDiff line change
@@ -13,22 +13,22 @@ LICENSE= GPLv2
1313

1414
LIB_DEPENDS= libpcsclite.so:devel/pcsc-lite
1515

16-
USES= perl5 pkgconfig tar:bz2
16+
USES= perl5 pkgconfig tar:bz2
1717

18-
PLIST_FILES= lib/pcsc/drivers/ifd-acsccid.bundle/Contents/FreeBSD/libacsccid.so \
18+
PLIST_FILES= lib/pcsc/drivers/ifd-acsccid.bundle/Contents/${OPSYS}/libacsccid.so \
1919
lib/pcsc/drivers/ifd-acsccid.bundle/Contents/Info.plist
2020

2121
GNU_CONFIGURE= yes
2222

2323
.include <bsd.port.pre.mk>
2424

2525
# Old versions don't have pkgconfig files for libusb
26-
.if ${OSVERSION} < 1000024
26+
.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000024
2727
CONFIGURE_ENV+= LIBUSB_CFLAGS="-I${LOCALBASE}/include" \
2828
LIBUSB_LIBS="-L${LOCALBASE}/lib -lusb"
2929
.endif
3030

3131
post-install:
32-
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/pcsc/drivers/ifd-acsccid.bundle/Contents/FreeBSD/libacsccid.so
32+
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/pcsc/drivers/ifd-acsccid.bundle/Contents/${OPSYS}/libacsccid.so
3333

3434
.include <bsd.port.post.mk>

devel/erlang-gpb/Makefile

+1-1
Original file line numberDiff line numberDiff line change
@@ -1,7 +1,7 @@
11
# $FreeBSD$
22

33
PORTNAME= gpb
4-
PORTVERSION= 3.22.2
4+
PORTVERSION= 3.22.3
55
CATEGORIES= devel
66
PKGNAMEPREFIX= erlang-
77

devel/erlang-gpb/distinfo

+3-3
Original file line numberDiff line numberDiff line change
@@ -1,3 +1,3 @@
1-
TIMESTAMP = 1465199162
2-
SHA256 (tomas-abrahamsson-gpb-3.22.2_GH0.tar.gz) = ee73ad6ee2dee84da66ab936edd0789444cda0ef7c46dd8bde597e3e7855ec30
3-
SIZE (tomas-abrahamsson-gpb-3.22.2_GH0.tar.gz) = 316758
1+
TIMESTAMP = 1466071499
2+
SHA256 (tomas-abrahamsson-gpb-3.22.3_GH0.tar.gz) = 8151e12798e85f077441167919a9575e9cf1072a53d6b4715e84fb21982b0be1
3+
SIZE (tomas-abrahamsson-gpb-3.22.3_GH0.tar.gz) = 317184

devel/fossil/Makefile

+2-1
Original file line numberDiff line numberDiff line change
@@ -1,7 +1,7 @@
11
# $FreeBSD$
22

33
PORTNAME= fossil
4-
PORTVERSION= 1.34
4+
PORTVERSION= 1.35
55
DISTVERSIONPREFIX= src-
66
PORTEPOCH= 2
77
CATEGORIES= devel www
@@ -23,6 +23,7 @@ MAKE_JOBS_UNSAFE=yes
2323

2424
OPTIONS_DEFINE= JSON FUSE STATIC
2525
OPTIONS_DEFAULT= JSON
26+
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
2627
JSON_DESC= JSON API support
2728
FUSE_DESC= Enable fossil fusefs command
2829

devel/fossil/distinfo

+3-2
Original file line numberDiff line numberDiff line change
@@ -1,2 +1,3 @@
1-
SHA256 (fossil-src-1.34.tar.gz) = 53a6b83e878feced9ac7705f87e5b6ea82727314e3e19202ae1c46c7e4dba49f
2-
SIZE (fossil-src-1.34.tar.gz) = 4449452
1+
TIMESTAMP = 1466078387
2+
SHA256 (fossil-src-1.35.tar.gz) = c1f92f925a87c9872cb40d166f56ba08b90edbab01a8546ff37025836136ba1d
3+
SIZE (fossil-src-1.35.tar.gz) = 4642421

devel/libgit2/Makefile

+1-1
Original file line numberDiff line numberDiff line change
@@ -40,7 +40,7 @@ BROKEN_sparc64= does not install: thread-local storage not supported
4040
post-patch:
4141
@${REINPLACE_CMD} -e "s|/pkgconfig|/../libdata/pkgconfig|; \
4242
/LIBGIT2_PC_REQUIRES.*zlib/ d" ${WRKSRC}/CMakeLists.txt
43-
.if defined(WITH_OPENSSL_BASE)
43+
.if ${SSL_DEFAULT} == base
4444
@${REINPLACE_CMD} -e "/LIBGIT2_PC_REQUIRES.*openssl/ d" \
4545
${WRKSRC}/CMakeLists.txt
4646
.endif

devel/libopkele/Makefile

+1-1
Original file line numberDiff line numberDiff line change
@@ -41,7 +41,7 @@ USE_OPENSSL= yes
4141
post-patch:
4242
@ ${REINPLACE_CMD} -e "s|pkgconfigdir =.*|pkgconfigdir = ${PREFIX}/libdata/pkgconfig|g" \
4343
${WRKSRC}/Makefile.in
44-
.if !defined(WITH_OPENSSL_PORT)
44+
.if ${SSL_DEFAULT} == base
4545
@ ${REINPLACE_CMD} -e "s|Requires: openssl|Requires:|" ${WRKSRC}/libopkele.pc.in
4646
.endif
4747

devel/ocaml-pomap/Makefile

+6-3
Original file line numberDiff line numberDiff line change
@@ -10,7 +10,8 @@ PKGNAMEPREFIX= ocaml-
1010
MAINTAINER= [email protected]
1111
COMMENT= OCaml library to maintain a list of partially ordered elements
1212

13-
LICENSE= LGPL21
13+
LICENSE= LGPL20+ # source says LGPL20+, COPYING says LGPL21
14+
LICENSE_FILE= ${WRKSRC}/COPYING.txt
1415

1516
USE_GITHUB= yes
1617
GH_ACCOUNT= mmottl
@@ -32,11 +33,13 @@ PORTEXAMPLES= *
3233

3334
OPTIONS_DEFINE= DOCS EXAMPLES
3435

35-
post-install:
36+
post-install-DOCS-on:
3637
@${MKDIR} ${STAGEDIR}${DOCSDIR}
3738
.for i in AUTHORS.txt CHANGES.txt README.md
38-
(cd ${WRKSRC} && ${INSTALL_DATA} ${i} ${STAGEDIR}${DOCSDIR})
39+
${INSTALL_DATA} ${WRKSRC}/${i} ${STAGEDIR}${DOCSDIR}
3940
.endfor
41+
42+
post-install-EXAMPLES-on:
4043
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
4144
@(cd ${WRKSRC}/examples && \
4245
${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR})

devel/pep8/Makefile

+1-1
Original file line numberDiff line numberDiff line change
@@ -15,7 +15,7 @@ LICENSE= MIT
1515

1616
NO_ARCH= yes
1717
USES= python
18-
USE_PYTHON= autoplist concurrent distutils py3kplist
18+
USE_PYTHON= autoplist concurrent distutils
1919

2020
do-test: extract
2121
@(cd ${WRKSRC}; ${PYTHON_CMD} ${PORTNAME}.py \

devel/thrift-cpp/Makefile

+1-1
Original file line numberDiff line numberDiff line change
@@ -47,7 +47,7 @@ CONFIGURE_ARGS+= \
4747

4848
.include <bsd.port.pre.mk>
4949

50-
.if !defined(WITH_OPENSSL_PORT) && \
50+
.if ${SSL_DEFAULT} == base && \
5151
${OPSYS} == FreeBSD && ${OSVERSION} < 1000015
5252
# src/thrift/transport/TSSLSocket.cpp:147: error: 'TLSv1_1_method' was not declared in this scope
5353
# src/thrift/transport/TSSLSocket.cpp:149: error: 'TLSv1_2_method' was not declared in this scope

dns/bind9-devel/Makefile

+2-2
Original file line numberDiff line numberDiff line change
@@ -207,9 +207,9 @@ PORTDOCS= *
207207

208208
.include <bsd.port.pre.mk>
209209

210-
.if ( ${PORT_OPTIONS:MGOST} || ${PORT_OPTIONS:MGOST_ASN1} ) && defined(WITH_OPENSSL_BASE)
210+
.if ( ${PORT_OPTIONS:MGOST} || ${PORT_OPTIONS:MGOST_ASN1} ) && ${SSL_DEFAULT} == base
211211
BROKEN= OpenSSL from the base system does not support GOST, add \
212-
WITH_OPENSSL_PORT=yes to your /etc/make.conf and rebuild everything \
212+
DEFAULT_VERSIONS+=ssl=openssl to your /etc/make.conf and rebuild everything \
213213
that needs SSL.
214214
.endif
215215

dns/bind99/Makefile

+2-2
Original file line numberDiff line numberDiff line change
@@ -191,9 +191,9 @@ PORTDOCS= *
191191

192192
.include <bsd.port.pre.mk>
193193

194-
.if ( ${PORT_OPTIONS:MGOST} ) && defined(WITH_OPENSSL_BASE)
194+
.if ( ${PORT_OPTIONS:MGOST} ) && ${SSL_DEFAULT} == base
195195
BROKEN= OpenSSL from the base system does not support GOST, add \
196-
WITH_OPENSSL_PORT=yes to your /etc/make.conf and rebuild everything \
196+
DEFAULT_VERSIONS+=ssl=openssl to your /etc/make.conf and rebuild everything \
197197
that needs SSL.
198198
.endif
199199

dns/py-pycares/Makefile

+1-1
Original file line numberDiff line numberDiff line change
@@ -2,7 +2,7 @@
22
# $FreeBSD$
33

44
PORTNAME= pycares
5-
PORTVERSION= 2.0.1
5+
PORTVERSION= 2.1.0
66
CATEGORIES= dns python
77
MASTER_SITES= CHEESESHOP
88
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}

dns/py-pycares/distinfo

+3-3
Original file line numberDiff line numberDiff line change
@@ -1,3 +1,3 @@
1-
TIMESTAMP = 1464695332
2-
SHA256 (pycares-2.0.1.tar.gz) = 3a684c09b753e143d86190b57d71bd82d24492062d11d6ab6acc21349d2da34d
3-
SIZE (pycares-2.0.1.tar.gz) = 225788
1+
TIMESTAMP = 1466077939
2+
SHA256 (pycares-2.1.0.tar.gz) = 449ad785ecb594ae063c0c86537ef97513385117a2eb172f747ad2a29221e898
3+
SIZE (pycares-2.1.0.tar.gz) = 226838

0 commit comments

Comments
 (0)