Skip to content

Commit 673ddea

Browse files
committed
*/*: sync with upstream
Taken from: FreeBSD
1 parent b4c8239 commit 673ddea

File tree

440 files changed

+2792
-30687
lines changed

Some content is hidden

Large Commits have some content hidden by default. Use the searchbox below for content that may be hidden.

440 files changed

+2792
-30687
lines changed

astro/marble/files/patch-git_486f618

+63
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,63 @@
1+
Backport of the the commit 486f618 to old marble.
2+
3+
From 486f6181d6fef15c9b6c72504e3588be502bea80 Mon Sep 17 00:00:00 2001
4+
From: =?UTF-8?q?Dennis=20Nienh=C3=BCser?= <[email protected]>
5+
Date: Sun, 20 Mar 2016 17:43:25 +0100
6+
Subject: [PATCH] Use std::isnan from cmath
7+
8+
--- src/plugins/positionprovider/gpsd/GpsdPositionProviderPlugin.cpp.orig 2014-10-23 21:53:08 UTC
9+
+++ src/plugins/positionprovider/gpsd/GpsdPositionProviderPlugin.cpp
10+
@@ -12,7 +12,7 @@
11+
12+
#include "GpsdThread.h"
13+
#include "MarbleDebug.h"
14+
-#include <math.h>
15+
+#include <cmath>
16+
17+
using namespace Marble;
18+
/* TRANSLATOR Marble::GpsdPositionProviderPlugin */
19+
@@ -76,7 +76,7 @@ void GpsdPositionProviderPlugin::update(
20+
{
21+
PositionProviderStatus oldStatus = m_status;
22+
GeoDataCoordinates oldPosition = m_position;
23+
- if ( data.status == STATUS_NO_FIX || isnan( data.fix.longitude ) || isnan( data.fix.latitude ) )
24+
+ if ( data.status == STATUS_NO_FIX || std::isnan( data.fix.longitude ) || std::isnan( data.fix.latitude ) )
25+
m_status = PositionProviderStatusUnavailable;
26+
else {
27+
m_status = PositionProviderStatusAvailable;
28+
@@ -88,29 +88,29 @@ void GpsdPositionProviderPlugin::update(
29+
30+
m_accuracy.level = GeoDataAccuracy::Detailed;
31+
#if defined( GPSD_API_MAJOR_VERSION ) && ( GPSD_API_MAJOR_VERSION >= 3 )
32+
- if ( !isnan( data.fix.epx ) && !isnan( data.fix.epy ) ) {
33+
+ if ( !std::isnan( data.fix.epx ) && !std::isnan( data.fix.epy ) ) {
34+
m_accuracy.horizontal = qMax( data.fix.epx, data.fix.epy );
35+
}
36+
#else
37+
- if ( !isnan( data.fix.eph ) ) {
38+
+ if ( !std::isnan( data.fix.eph ) ) {
39+
m_accuracy.horizontal = data.fix.eph;
40+
}
41+
#endif
42+
- if ( !isnan( data.fix.epv ) ) {
43+
+ if ( !std::isnan( data.fix.epv ) ) {
44+
m_accuracy.vertical = data.fix.epv;
45+
}
46+
47+
- if( !isnan(data.fix.speed ) )
48+
+ if( !std::isnan(data.fix.speed ) )
49+
{
50+
m_speed = data.fix.speed;
51+
}
52+
53+
- if( !isnan( data.fix.track ) )
54+
+ if( !std::isnan( data.fix.track ) )
55+
{
56+
m_track = data.fix.track;
57+
}
58+
59+
- if ( !isnan( data.fix.time ) )
60+
+ if ( !std::isnan( data.fix.time ) )
61+
{
62+
m_timestamp = QDateTime::fromMSecsSinceEpoch( data.fix.time * 1000 );
63+
}

audio/bristol/Makefile

+1
Original file line numberDiff line numberDiff line change
@@ -25,6 +25,7 @@ CONFIGURE_ARGS+= --disable-alsa --enable-oss \
2525
--enable-jack-default-midi \
2626
--disable-version-check
2727

28+
BROKEN_aarch64= Does not build: error: unknown FP unit 'sse'
2829
BROKEN_powerpc64= Does not build
2930

3031
PORTDATA= *

audio/mp3unicode/Makefile

+7-1
Original file line numberDiff line numberDiff line change
@@ -8,6 +8,9 @@ MASTER_SITES= http://github.com/downloads/alonbl/mp3unicode/
88
MAINTAINER= [email protected]
99
COMMENT= ID3 tags charset converter
1010

11+
LICENSE= GPLv2
12+
LICENSE_FILE= ${WRKSRC}/COPYING
13+
1114
LIB_DEPENDS= libtag.so:audio/taglib
1215

1316
USES= iconv pkgconfig tar:bzip2
@@ -17,8 +20,11 @@ CONFIGURE_ENV= ICONV_CFLAGS="-I${LOCALBASE}/include" \
1720

1821
PLIST_FILES= bin/mp3unicode \
1922
man/man1/mp3unicode.1.gz
20-
PORTDOCS= COPYING README
23+
PORTDOCS= README
2124

2225
OPTIONS_DEFINE= DOCS
2326

27+
post-patch:
28+
@${REINPLACE_CMD} -e '/dist_doc_DATA/ s|COPYING||' ${WRKSRC}/Makefile.*
29+
2430
.include <bsd.port.mk>

biology/avida/Makefile

+4-1
Original file line numberDiff line numberDiff line change
@@ -12,7 +12,10 @@ COMMENT= Auto-adaptive genetic system designed for ALife research
1212

1313
LICENSE= GPLv3
1414

15-
BROKEN_sparc64= missing atomics implementation
15+
BROKEN_aarch64= invokes x86 asm
16+
BROKEN_mips= invokes x86 asm
17+
BROKEN_mips64= invokes x86 asm
18+
BROKEN_sparc64= missing atomics implementation
1619
BROKEN_powerpc64= Does not build on powerpc64
1720

1821
USES= cmake:outsource ncurses

biology/gmap/Makefile

+3
Original file line numberDiff line numberDiff line change
@@ -24,7 +24,10 @@ OPTIONS_DEFINE= SIMD
2424

2525
SIMD_CONFIGURE_OFF= --disable-builtin-popcount --disable-simd
2626

27+
BROKEN_aarch64= Does not build: invokes x86 asm
28+
BROKEN_mips64= Does not build: invokes x86 asm
2729
BROKEN_powerpc64= Does not build on powerpc64
30+
BROKEN_sparc64= Does not build: invokes x86 asm
2831

2932
# shebang_fix operates during patch.
3033
# These scripts are created during configure.

biology/ugene/Makefile

+2
Original file line numberDiff line numberDiff line change
@@ -18,6 +18,8 @@ LICENSE= GPLv2
1818

1919
RUN_DEPENDS= bash:shells/bash
2020

21+
BROKEN_aarch64= Fails to build: invokes x86 asm
22+
2123
USES= desktop-file-utils execinfo qmake
2224
USE_GL= glu
2325
USE_QT5= buildtools_build linguisttools_build scripttools_build \

cad/librecad/Makefile

+12-12
Original file line numberDiff line numberDiff line change
@@ -10,36 +10,36 @@ COMMENT= 2D CAD system
1010
BUILD_DEPENDS= ${LOCALBASE}/include/boost/version.hpp:devel/boost-libs
1111
LIB_DEPENDS= libmuparser.so:math/muparser
1212

13-
USE_QT4= gui help network sql svg help-tools_build \
14-
linguisttools_build moc_build rcc_build uic_build
15-
USES= compiler:c++11-lib desktop-file-utils pkgconfig qmake
16-
1713
USE_GITHUB= yes
1814
GH_ACCOUNT= LibreCAD
1915
GH_PROJECT= LibreCAD
2016

17+
USE_QT4= gui help network sql svg help-tools_build \
18+
linguisttools_build moc_build rcc_build uic_build
19+
USES= compiler:c++11-lib desktop-file-utils pkgconfig qmake
20+
2121
# Unhide std::to_string() to fix build with GCC (ports/193528)
22-
CFLAGS= -D_GLIBCXX_USE_C99
22+
CFLAGS+= -D_GLIBCXX_USE_C99
2323

2424
post-patch:
25-
${REINPLACE_CMD} -e 's,/usr/share,${PREFIX}/share,' \
25+
@${REINPLACE_CMD} -e 's,/usr/share,${PREFIX}/share,' \
2626
${WRKSRC}/librecad/src/lib/engine/rs_settings.cpp \
2727
${WRKSRC}/librecad/src/lib/engine/rs_system.cpp
28-
${REINPLACE_CMD} -e \
28+
@${REINPLACE_CMD} -e \
2929
'/^Icon/s,librecad,${PREFIX}/share/pixmaps/librecad.png,' \
3030
${WRKSRC}/desktop/librecad.desktop
3131

3232
pre-install:
33-
${CHMOD} +w ${WRKSRC}/unix/resources/plugins/*.so
34-
${STRIP_CMD} ${WRKSRC}/unix/resources/plugins/*.so
33+
@${CHMOD} +w ${WRKSRC}/unix/resources/plugins/*.so
34+
@${STRIP_CMD} ${WRKSRC}/unix/resources/plugins/*.so
3535

3636
do-install:
3737
${INSTALL_PROGRAM} ${WRKSRC}/unix/librecad ${STAGEDIR}${PREFIX}/bin
3838
${INSTALL_PROGRAM} ${WRKSRC}/unix/ttf2lff ${STAGEDIR}${PREFIX}/bin
3939
(cd ${WRKSRC}/unix/resources && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR})
40-
(${MKDIR} ${STAGEDIR}${PREFIX}/share/appdata && \
41-
${INSTALL_DATA} ${WRKSRC}/unix/appdata/librecad.appdata.xml \
42-
${STAGEDIR}${PREFIX}/share/appdata)
40+
@${MKDIR} ${STAGEDIR}${PREFIX}/share/appdata
41+
${INSTALL_DATA} ${WRKSRC}/unix/appdata/librecad.appdata.xml \
42+
${STAGEDIR}${PREFIX}/share/appdata
4343
${INSTALL_DATA} ${WRKSRC}/desktop/librecad.desktop \
4444
${STAGEDIR}${PREFIX}/share/applications
4545
${INSTALL_DATA} ${WRKSRC}/librecad/res/main/librecad.png \

cad/librecad/pkg-descr

+1-1
Original file line numberDiff line numberDiff line change
@@ -1,4 +1,4 @@
11
LibreCAD is a 2D CAD drawing application based on the community
22
edition of QCad (www.qcad.org).
33

4-
WWW: http://librecad.org
4+
WWW: http://librecad.org/

chinese/Makefile

+1
Original file line numberDiff line numberDiff line change
@@ -31,6 +31,7 @@
3131
SUBDIR += enscript
3232
SUBDIR += eric6
3333
SUBDIR += eterm
34+
SUBDIR += fandol
3435
SUBDIR += fcitx
3536
SUBDIR += fcitx-chewing
3637
SUBDIR += fcitx-cloudpinyin

chinese/fandol/Makefile

+52
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,52 @@
1+
# Created by: <[email protected]>
2+
# $FreeBSD$
3+
4+
PORTNAME= fandol
5+
PORTVERSION= 0.3
6+
CATEGORIES= chinese
7+
MASTER_SITES= http://mirrors.ctan.org/fonts/
8+
DISTNAME= ${PORTNAME}
9+
10+
MAINTAINER= [email protected]
11+
COMMENT= CTAN Fandol: Four GNU GPLv3-licensed Chinese OpenType fonts
12+
13+
LICENSE= GPLv3
14+
15+
USE_XORG= x11
16+
USES= zip fonts
17+
NO_WRKSUBDIR= yes
18+
NO_BUILD= yes
19+
20+
FONTNAME= fandol
21+
22+
SUB_FILES= pkg-message
23+
24+
PORTDOCS= README COPYING
25+
26+
do-install:
27+
${MKDIR} ${STAGEDIR}${FONTSDIR}
28+
29+
${INSTALL_DATA} ${WRKSRC}/fandol/FandolSong-Bold.otf \
30+
${STAGEDIR}${FONTSDIR}
31+
${INSTALL_DATA} ${WRKSRC}/fandol/FandolSong-Regular.otf \
32+
${STAGEDIR}${FONTSDIR}
33+
${INSTALL_DATA} ${WRKSRC}/fandol/FandolHei-Regular.otf \
34+
${STAGEDIR}${FONTSDIR}
35+
${INSTALL_DATA} ${WRKSRC}/fandol/FandolHei-Bold.otf \
36+
${STAGEDIR}${FONTSDIR}
37+
${INSTALL_DATA} ${WRKSRC}/fandol/FandolFang-Regular.otf \
38+
${STAGEDIR}${FONTSDIR}
39+
${INSTALL_DATA} ${WRKSRC}/fandol/FandolKai-Regular.otf \
40+
${STAGEDIR}${FONTSDIR}
41+
${INSTALL_DATA} ${WRKSRC}/fandol/FandolBraille-Display.otf \
42+
${STAGEDIR}${FONTSDIR}
43+
${INSTALL_DATA} ${WRKSRC}/fandol/FandolBraille-Regular.otf \
44+
${STAGEDIR}${FONTSDIR}
45+
46+
${MKDIR} ${STAGEDIR}${DOCSDIR}
47+
${INSTALL_DATA} \
48+
${WRKSRC}/fandol/README \
49+
${WRKSRC}/fandol/COPYING \
50+
${STAGEDIR}${DOCSDIR}
51+
52+
.include <bsd.port.mk>

chinese/fandol/distinfo

+3
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,3 @@
1+
TIMESTAMP = 1478478970
2+
SHA256 (fandol.zip) = 9278f01b417ded5766d98c3937192a1a6a2c73a5e94a3493fdfc932b2a55005a
3+
SIZE (fandol.zip) = 26688406

chinese/fandol/files/pkg-message.in

+18
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,18 @@
1+
**************************************************************************
2+
For old programs that use XLFD, please add %%FONTSDIR%%
3+
to your X server either by:
4+
5+
# xset fp+ %%FONTSDIR%%
6+
# xset fp rehash
7+
8+
or by adding the following line to the section "Files" of
9+
your X-server configuration file (usually /etc/X11/xorg.conf)
10+
and restarting the X-server:
11+
12+
Section "Files"
13+
...
14+
FontPath "%%FONTSDIR%%"
15+
...
16+
EndSection
17+
18+
**************************************************************************

chinese/fandol/pkg-descr

+6
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,6 @@
1+
fandol - Four basic fonts for Chinese typesetting
2+
3+
Fandol fonts designed for Chinese typesetting. The current version contains
4+
four styles: Song, Hei, Kai, Fang. All fonts are in OpenType format.
5+
6+
WWW: http://www.ctan.org/pkg/fandol

chinese/fandol/pkg-plist

+9
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,9 @@
1+
%%FONTSDIR%%/FandolBraille-Display.otf
2+
%%FONTSDIR%%/FandolBraille-Regular.otf
3+
%%FONTSDIR%%/FandolFang-Regular.otf
4+
%%FONTSDIR%%/FandolHei-Bold.otf
5+
%%FONTSDIR%%/FandolHei-Regular.otf
6+
%%FONTSDIR%%/FandolKai-Regular.otf
7+
%%FONTSDIR%%/FandolSong-Bold.otf
8+
%%FONTSDIR%%/FandolSong-Regular.otf
9+

comms/gpredict/files/patch-trsp.c

+13
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,13 @@
1+
--- src/trsp-conf.c.orig 2016-06-04 02:02:30.359797000 -0500
2+
+++ src/trsp-conf.c 2016-06-04 02:02:47.233560000 -0500
3+
@@ -186,9 +186,9 @@
4+
for (i = 0; i < n; i++) {
5+
trsp = (trsp_t *) g_slist_nth_data (trsplist, i);
6+
g_free (trsp->name);
7+
- g_free (trsp);
8+
if (trsp->mode)
9+
g_free (trsp->mode);
10+
+ g_free (trsp);
11+
}
12+
g_slist_free (trsplist);
13+
trsplist = NULL;

comms/pear-Horde_ActiveSync/Makefile

+1-1
Original file line numberDiff line numberDiff line change
@@ -1,7 +1,7 @@
11
# $FreeBSD$
22

33
PORTNAME= Horde_ActiveSync
4-
PORTVERSION= 2.37.1
4+
PORTVERSION= 2.37.2
55
PORTREVISION= 1
66
CATEGORIES= comms www pear
77

comms/pear-Horde_ActiveSync/distinfo

+3-3
Original file line numberDiff line numberDiff line change
@@ -1,3 +1,3 @@
1-
TIMESTAMP = 1475181637
2-
SHA256 (Horde/Horde_ActiveSync-2.37.1.tgz) = 4a7166d428ed7d124db432468831b1998e9334771813503070fc70bf8ed2bf1c
3-
SIZE (Horde/Horde_ActiveSync-2.37.1.tgz) = 379967
1+
TIMESTAMP = 1478647736
2+
SHA256 (Horde/Horde_ActiveSync-2.37.2.tgz) = a75a3bfeadbe3f4c649580609897d50f066cff2f369ea4eb8cffe2ba1a75b12a
3+
SIZE (Horde/Horde_ActiveSync-2.37.2.tgz) = 380236

converters/py-pisa/Makefile

+3
Original file line numberDiff line numberDiff line change
@@ -13,6 +13,9 @@ COMMENT= PDF generator using HTML and CSS
1313

1414
LICENSE= APACHE20
1515

16+
DEPRECATED= Deprecated upstream, depends on broken and expired py-reportlab2
17+
EXPIRATION_DATE= 2016-12-08
18+
1619
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}html5lib>=0.11.1:www/py-html5lib \
1720
${PYTHON_PKGNAMEPREFIX}reportlab2>=2.1:print/py-reportlab2 \
1821
${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow \

databases/p5-DBICx-Sugar/Makefile

+1-1
Original file line numberDiff line numberDiff line change
@@ -2,7 +2,7 @@
22
# $FreeBSD$
33

44
PORTNAME= DBICx-Sugar
5-
PORTVERSION= 0.0001
5+
PORTVERSION= 0.0100
66
CATEGORIES= databases perl5
77
MASTER_SITES= CPAN
88
MASTER_SITE_SUBDIR= CPAN:IRONCAMEL

databases/p5-DBICx-Sugar/distinfo

+3-2
Original file line numberDiff line numberDiff line change
@@ -1,2 +1,3 @@
1-
SHA256 (DBICx-Sugar-0.0001.tar.gz) = 3a49f29602d9368b41ce1ac47cbfa11907d7aec0af51b5d355490a8696857c33
2-
SIZE (DBICx-Sugar-0.0001.tar.gz) = 16046
1+
TIMESTAMP = 1476373953
2+
SHA256 (DBICx-Sugar-0.0100.tar.gz) = a1b4b52bb58b6af67e83115a756e38f71e0faf5c7f3514dd385a1ae2765c7afa
3+
SIZE (DBICx-Sugar-0.0100.tar.gz) = 17009

databases/p5-Tie-LevelDB/Makefile

+2
Original file line numberDiff line numberDiff line change
@@ -16,7 +16,9 @@ LICENSE_COMB= dual
1616

1717
LIB_DEPENDS= libleveldb.so:databases/leveldb
1818

19+
BROKEN_aarch64= does not build: error: Please implement AtomicPointer for this platform
1920
BROKEN_powerpc64= does not build
21+
BROKEN_sparcpc64= does not build: unrecognized command line options
2022

2123
MAKE_ARGS= CC="${CXX}"
2224
USE_PERL5= configure

databases/pg_citus/Makefile

+1-1
Original file line numberDiff line numberDiff line change
@@ -2,7 +2,7 @@
22
# $FreeBSD$
33

44
PORTNAME= citus
5-
PORTVERSION= 5.2.1
5+
PORTVERSION= 5.2.2
66
DISTVERSIONPREFIX= v
77
CATEGORIES= databases
88
PKGNAMEPREFIX= pg_

databases/pg_citus/distinfo

+3-3
Original file line numberDiff line numberDiff line change
@@ -1,3 +1,3 @@
1-
TIMESTAMP = 1473248732
2-
SHA256 (citusdata-citus-v5.2.1_GH0.tar.gz) = 5014839eb7f20b1bd338e482340faedbd8162979992a6475d5dfea516dd0657c
3-
SIZE (citusdata-citus-v5.2.1_GH0.tar.gz) = 1688751
1+
TIMESTAMP = 1478593024
2+
SHA256 (citusdata-citus-v5.2.2_GH0.tar.gz) = 5eb593567bd2e173c4850d13a17416addb9a5e0cf20b0437cfd173853eb520e7
3+
SIZE (citusdata-citus-v5.2.2_GH0.tar.gz) = 1693732

databases/py-Elixir/Makefile

+3
Original file line numberDiff line numberDiff line change
@@ -14,6 +14,9 @@ COMMENT= Declarative Mapper for SQLAlchemy
1414

1515
LICENSE= MIT
1616

17+
DEPRECATED= Depends on expired py-sqlalchemy06
18+
EXPIRATION_DATE= 2016-12-08
19+
1720
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlalchemy06>=0.4.0:databases/py-sqlalchemy06
1821

1922
USES= python

0 commit comments

Comments
 (0)