Skip to content

Commit 7949c59

Browse files
committed
*/*: sync with upstream
Taken from: FreeBSD
1 parent 3c91441 commit 7949c59

File tree

642 files changed

+2148
-249
lines changed

Some content is hidden

Large Commits have some content hidden by default. Use the searchbox below for content that may be hidden.

642 files changed

+2148
-249
lines changed

archivers/Makefile

+1
Original file line numberDiff line numberDiff line change
@@ -31,6 +31,7 @@
3131
SUBDIR += freeze
3232
SUBDIR += gcab
3333
SUBDIR += gcpio
34+
SUBDIR += gnome-autoar
3435
SUBDIR += go-compress
3536
SUBDIR += grzip
3637
SUBDIR += gtar

archivers/gnome-autoar/Makefile

+23
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,23 @@
1+
# Created by: Koop Mast <[email protected]>
2+
# $FreeBSD$
3+
4+
PORTNAME= gnome-autoar
5+
PORTVERSION= 0.2.2
6+
CATEGORIES= archivers
7+
MASTER_SITES= GNOME
8+
DIST_SUBDIR= gnome3
9+
10+
MAINTAINER= [email protected]
11+
COMMENT= Glib wrapper around libarchives
12+
13+
LICENSE= LGPL21
14+
LICENSE_FILE= ${WRKSRC}/COPYING
15+
16+
BUILD_DEPENDS= valac:lang/vala
17+
18+
USES= gettext-runtime gmake libarchive libtool pkgconfig tar:xz
19+
USE_GNOME= cairo gdkpixbuf2 gtk30 introspection:build
20+
GNU_CONFIGURE= yes
21+
INSTALL_TARGET= install-strip
22+
23+
.include <bsd.port.mk>

archivers/gnome-autoar/distinfo

+3
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,3 @@
1+
TIMESTAMP = 1497213634
2+
SHA256 (gnome3/gnome-autoar-0.2.2.tar.xz) = e1fe2c06eed30305c38bf0939c72b0e51b4716658e2663a0cf4a4bf57874ca62
3+
SIZE (gnome3/gnome-autoar-0.2.2.tar.xz) = 295488

archivers/gnome-autoar/pkg-descr

+4
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,4 @@
1+
Gnome-autoar provides functions, widgets, and gschemas for GNOME applications
2+
which want to use archives as a convient method to tranfer directories over
3+
the internet.
4+

archivers/gnome-autoar/pkg-plist

+46
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,46 @@
1+
include/gnome-autoar-0/gnome-autoar/autoar-compressor.h
2+
include/gnome-autoar-0/gnome-autoar/autoar-enum-types.h
3+
include/gnome-autoar-0/gnome-autoar/autoar-extractor.h
4+
include/gnome-autoar-0/gnome-autoar/autoar-format-filter.h
5+
include/gnome-autoar-0/gnome-autoar/autoar-gtk-chooser.h
6+
include/gnome-autoar-0/gnome-autoar/autoar-gtk.h
7+
include/gnome-autoar-0/gnome-autoar/autoar-mime-types.h
8+
include/gnome-autoar-0/gnome-autoar/autoar-misc.h
9+
include/gnome-autoar-0/gnome-autoar/gnome-autoar.h
10+
lib/girepository-1.0/GnomeAutoar-0.1.typelib
11+
lib/girepository-1.0/GnomeAutoarGtk-0.1.typelib
12+
lib/libgnome-autoar-0.a
13+
lib/libgnome-autoar-0.so
14+
lib/libgnome-autoar-0.so.0
15+
lib/libgnome-autoar-0.so.0.0.0
16+
lib/libgnome-autoar-gtk-0.a
17+
lib/libgnome-autoar-gtk-0.so
18+
lib/libgnome-autoar-gtk-0.so.0
19+
lib/libgnome-autoar-gtk-0.so.0.0.0
20+
libdata/pkgconfig/gnome-autoar-0.pc
21+
libdata/pkgconfig/gnome-autoar-gtk-0.pc
22+
share/gir-1.0/GnomeAutoar-0.1.gir
23+
share/gir-1.0/GnomeAutoarGtk-0.1.gir
24+
share/gtk-doc/html/gnome-autoar/AutoarCompressor.html
25+
share/gtk-doc/html/gnome-autoar/AutoarExtractor.html
26+
share/gtk-doc/html/gnome-autoar/annotation-glossary.html
27+
share/gtk-doc/html/gnome-autoar/api-index-full.html
28+
share/gtk-doc/html/gnome-autoar/ch01.html
29+
share/gtk-doc/html/gnome-autoar/ch02.html
30+
share/gtk-doc/html/gnome-autoar/ch03.html
31+
share/gtk-doc/html/gnome-autoar/gnome-autoar-autoar-format-filter.html
32+
share/gtk-doc/html/gnome-autoar/gnome-autoar-autoar-gtk-chooser.html
33+
share/gtk-doc/html/gnome-autoar/gnome-autoar-autoar-misc.html
34+
share/gtk-doc/html/gnome-autoar/gnome-autoar.devhelp2
35+
share/gtk-doc/html/gnome-autoar/home.png
36+
share/gtk-doc/html/gnome-autoar/index.html
37+
share/gtk-doc/html/gnome-autoar/left-insensitive.png
38+
share/gtk-doc/html/gnome-autoar/left.png
39+
share/gtk-doc/html/gnome-autoar/object-tree.html
40+
share/gtk-doc/html/gnome-autoar/right-insensitive.png
41+
share/gtk-doc/html/gnome-autoar/right.png
42+
share/gtk-doc/html/gnome-autoar/style.css
43+
share/gtk-doc/html/gnome-autoar/up-insensitive.png
44+
share/gtk-doc/html/gnome-autoar/up.png
45+
share/vala/vapi/gnome-autoar-0.vapi
46+
share/vala/vapi/gnome-autoar-gtk-0.vapi

archivers/gtar/Makefile

+2
Original file line numberDiff line numberDiff line change
@@ -10,6 +10,8 @@ PKGNAMEPREFIX= g
1010
MAINTAINER= [email protected]
1111
COMMENT= GNU version of the traditional tape archiver
1212

13+
EXPLICIT_SAFESTACK= yes
14+
1315
LICENSE= GPLv3+
1416
LICENSE_FILE= ${WRKSRC}/COPYING
1517

archivers/lzma/Makefile

+2
Original file line numberDiff line numberDiff line change
@@ -10,6 +10,8 @@ DISTNAME= lzma${PORTVERSION:S/.//g}
1010
MAINTAINER= [email protected]
1111
COMMENT= High-ratio LZMA compressor
1212

13+
EXPLICIT_SAFESTACK= yes
14+
1315
CONFLICTS= lzmautils-[0-9]* xz-[0-9]*
1416

1517
USES= 7z gmake dos2unix

archivers/unrar/Makefile

+4
Original file line numberDiff line numberDiff line change
@@ -18,6 +18,8 @@ LICENSE_FILE= ${WRKSRC}/license.txt
1818
LICENSE_NAME= UnRAR license
1919
LICENSE_PERMS= auto-accept dist-mirror pkg-mirror
2020

21+
EXPLICIT_SAFESTACK= yes
22+
2123
BROKEN_SSL= openssl-devel
2224

2325
OPTIONS_DEFINE= OPENSSL_AES
@@ -39,6 +41,8 @@ OPENSSL_AES_CPPFLAGS= -DOPENSSL_AES -I${OPENSSLINC}
3941
OPENSSL_AES_LDFLAGS= -L${OPENSSLLIB} -lcrypto
4042
OPENSSL_AES_USES= ssl
4143

44+
NOPIE_PORTS= yes
45+
4246
do-install:
4347
${INSTALL_PROGRAM} ${WRKSRC}/unrar ${STAGEDIR}${PREFIX}/bin/
4448

astro/fowsr/Makefile

+3
Original file line numberDiff line numberDiff line change
@@ -19,6 +19,9 @@ GH_TAGNAME= 571db38
1919

2020
USES= gmake dos2unix
2121

22+
NOPIE_PORTS= yes
23+
NORELRO_PORTS= yes
24+
2225
PLIST_FILES= bin/fowsr
2326

2427
post-patch:

astro/openuniverse/Makefile

+2
Original file line numberDiff line numberDiff line change
@@ -22,4 +22,6 @@ CONFIGURE_ARGS= --includedir="${LOCALBASE}/include" \
2222
CPPFLAGS+= -I${LOCALBASE}/include/GL -I${LOCALBASE}/include
2323
LIBS+= -L${LOCALBASE}/lib -lm -lcompat
2424

25+
NOPIE_PORTS= yes
26+
2527
.include <bsd.port.mk>

audio/beast/Makefile

+3
Original file line numberDiff line numberDiff line change
@@ -37,6 +37,9 @@ CXXFLAGS+= -fpermissive
3737
CPPFLAGS+= -I${LOCALBASE}/include
3838
LDFLAGS+= -L${LOCALBASE}/lib
3939

40+
NOPIE_PORTS= yes
41+
NORELRO_PORTS= yes
42+
4043
PLIST_SUB= VERSION="${PORTVERSION}"
4144
OPTIONS_SUB= yes
4245

audio/csound6/Makefile

+3
Original file line numberDiff line numberDiff line change
@@ -37,6 +37,9 @@ CMAKE_ARGS= -DBUILD_CSOUNDVST:BOOL=OFF \
3737
USE_LDCONFIG= yes
3838
SSP_UNSAFE= yes
3939

40+
NOPIE_PORTS= yes
41+
NORELRO_PORTS= yes
42+
4043
SUB_FILES= pkg-message
4144

4245
CONFLICTS= csound-5.*

audio/forked-daapd/Makefile

+2
Original file line numberDiff line numberDiff line change
@@ -33,6 +33,8 @@ INSTALL_TARGET= install-strip
3333
USE_LDCONFIG= ${LOCALBASE}/lib/forked-daapd
3434
CONFIGURE_ARGS+=--localstatedir=/var
3535

36+
NOPIE_PORTS= yes
37+
3638
USE_RC_SUBR= ${PORTNAME}
3739
SUB_FILES= pkg-message
3840

audio/goobox/Makefile

+3
Original file line numberDiff line numberDiff line change
@@ -27,6 +27,9 @@ GNU_CONFIGURE= yes
2727
INSTALLS_ICONS= yes
2828
INSTALL_TARGET= install-strip
2929

30+
NOPIE_PORTS= yes
31+
NORELRO_PORTS= yes
32+
3033
GLIB_SCHEMAS= org.gnome.Goobox.gschema.xml
3134

3235
OPTIONS_DEFINE= NOTIFY

audio/icegenerator/Makefile

+3
Original file line numberDiff line numberDiff line change
@@ -16,6 +16,9 @@ GNU_CONFIGURE= yes
1616
USES= gmake pkgconfig
1717
CONFIGURE_ARGS= --exec-prefix=${PREFIX}
1818

19+
NOPIE_PORTS= yes
20+
NORELRO_PORTS= yes
21+
1922
OPTIONS_DEFINE= DOCS MYSQL PGSQL
2023

2124
MYSQL_USE= MYSQL=YES

audio/madplay/Makefile

+2
Original file line numberDiff line numberDiff line change
@@ -30,6 +30,8 @@ NLS_CONFIGURE_ENABLE= nls
3030
ESOUND_USE= GNOME=esound
3131
ESOUND_CONFIGURE_WITH= esd
3232

33+
NOPIE_PORTS= yes
34+
3335
post-install:
3436
${INSTALL_PROGRAM} ${WRKSRC}/madtime ${STAGEDIR}${PREFIX}/bin
3537

audio/mp3guessenc/Makefile

+3
Original file line numberDiff line numberDiff line change
@@ -15,6 +15,9 @@ LICENSE_FILE= ${WRKSRC}/COPYING
1515
PLIST_FILES= bin/mp3guessenc
1616
SRC= decode.c mp3guessenc.c bit_utils.c tags.c
1717

18+
NOPIE_PORTS= yes
19+
NORELRO_PORTS= yes
20+
1821
do-build:
1922
.for f in ${SRC}
2023
${CC} ${CFLAGS} ${WRKSRC}/${f} -c -o ${WRKSRC}/${f:C/\.c/.o/}

audio/muse/Makefile

+2
Original file line numberDiff line numberDiff line change
@@ -26,6 +26,8 @@ CONFIGURE_ARGS= --disable-debug --disable-lubrify --disable-rpath
2626
CPPFLAGS+= -I${LOCALBASE}/include -DHAVE_SYS_UIO_H
2727
LDFLAGS+= -lpthread -L${LOCALBASE}/lib -lintl
2828

29+
NOPIE_PORTS= yes
30+
2931
PORTDOCS= AUTHORS ChangeLog NEWS KNOWN-BUGS README TODO USAGE
3032

3133
LAME_LIB_DEPENDS= libmp3lame.so:audio/lame

audio/oss/Makefile

+3
Original file line numberDiff line numberDiff line change
@@ -24,6 +24,9 @@ USE_RC_SUBR= oss
2424
SUB_FILES= pkg-install pkg-deinstall
2525
ONLY_FOR_ARCHS= amd64 i386
2626

27+
NOPIE_PORTS= yes
28+
NORELRO_PORTS= yes
29+
2730
KMODDIR= ${PREFIX}/lib/oss/modules
2831

2932
OSS_CONF_FILES= oss_audigyls oss_audioloop oss_cs461x oss_emu10k1x \

audio/patchage/Makefile

+2
Original file line numberDiff line numberDiff line change
@@ -31,6 +31,8 @@ CONFIGURE_ARGS+= --mandir=${MANPREFIX}/man \
3131

3232
CFLAGS+= -I${LOCALBASE}/include
3333

34+
EXPLICIT_SAFESTACK= yes
35+
3436
post-patch:
3537
@${REINPLACE_CMD} -e \
3638
"s|$$[{]LIBDIRNAME[}]/pkgconfig|libdata/pkgconfig| ; \

audio/raop_play/Makefile

+2
Original file line numberDiff line numberDiff line change
@@ -27,6 +27,8 @@ LDFLAGS+= `fltk-config --ldflags`
2727
USES= gmake
2828
USE_GNOME= glib20
2929

30+
NOPIE_PORTS= yes
31+
3032
post-patch:
3133
@${REINPLACE_CMD} 's/-lssl/-lcrypto/' \
3234
${WRKSRC}/configure ${WRKSRC}/raop_play/Makefile.in

audio/shairport/Makefile

+10-24
Original file line numberDiff line numberDiff line change
@@ -2,48 +2,34 @@
22
# $FreeBSD$
33

44
PORTNAME= shairport
5-
PORTVERSION= 0.05
6-
PORTREVISION= 1
5+
PORTVERSION= 1.1.1
76
CATEGORIES= audio
87

98
MAINTAINER= [email protected]
109
COMMENT= Airtunes emulator
1110

1211
LIB_DEPENDS= libao.so:audio/libao
13-
RUN_DEPENDS= p5-MIME-Base64>=0:converters/p5-MIME-Base64 \
14-
p5-Getopt-Long>=0:devel/p5-Getopt-Long \
15-
p5-URI>=0:net/p5-URI \
16-
p5-Crypt-OpenSSL-RSA>=0:security/p5-Crypt-OpenSSL-RSA \
17-
p5-Digest-MD5>=0:security/p5-Digest-MD5 \
18-
p5-HTTP-Message>=0:www/p5-HTTP-Message \
19-
avahi-publish-service:net/avahi-app
20-
21-
USES= gmake perl5 pkgconfig ssl
22-
USE_PERL5= run
12+
RUN_DEPENDS= avahi-publish-service:net/avahi-app
13+
14+
USES= gmake pkgconfig ssl
2315
USE_GITHUB= yes
24-
GH_ACCOUNT= miks
25-
GH_TAGNAME= b1cb9ea
16+
GH_ACCOUNT= abrasive
2617

2718
USE_RC_SUBR= ${PORTNAME}
2819
SUB_LIST= PERL=${PERL}
2920

30-
PLIST_FILES= bin/${PORTNAME} bin/hairtunes bin/${PORTNAME}.pl
21+
PLIST_FILES= bin/${PORTNAME}
3122
PORTDOCS= README.md
3223

3324
OPTIONS_DEFINE= DOCS
3425

3526
post-patch:
36-
@${REINPLACE_CMD} -e 's|avahi-|${LOCALBASE}/bin/avahi-|g' \
37-
-e 's|$$FindBin.*|"${PREFIX}/bin/hairtunes";|' \
38-
-e '/use FindBin;/d;s|/usr/bin/env perl|${PERL}|' \
39-
${WRKSRC}/shairport.c ${WRKSRC}/shairport.pl
40-
@${REINPLACE_CMD} 's/-lssl/-lcrypto/' ${WRKSRC}/Makefile
27+
@${ECHO_CMD} '"'${PORTVERSION}'"' > ${WRKSRC}/version.h
4128

4229
do-install:
43-
${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.pl ${STAGEDIR}${PREFIX}/bin
44-
.for file in ${PORTNAME} hairtunes
45-
${INSTALL_PROGRAM} ${WRKSRC}/${file} ${STAGEDIR}${PREFIX}/bin
46-
.endfor
30+
cd ${WRKSRC} ; ${GMAKE} PREFIX=${STAGEDIR}${PREFIX} install
31+
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/shairport
32+
4733
do-install-DOCS-on:
4834
@${MKDIR} ${STAGEDIR}${DOCSDIR}
4935
.for i in ${PORTDOCS}

audio/shairport/distinfo

+3-2
Original file line numberDiff line numberDiff line change
@@ -1,2 +1,3 @@
1-
SHA256 (miks-shairport-0.05-b1cb9ea_GH0.tar.gz) = 0e38b57a90c170a8cd798efe6df00beace91fc30a97da9e6f5568a2e06f6499f
2-
SIZE (miks-shairport-0.05-b1cb9ea_GH0.tar.gz) = 40413
1+
TIMESTAMP = 1497172386
2+
SHA256 (abrasive-shairport-1.1.1_GH0.tar.gz) = 1b60df6d40bab874c1220d7daecd68fcff3e47bda7c6d7f91db0a5b5c43c0c72
3+
SIZE (abrasive-shairport-1.1.1_GH0.tar.gz) = 59487

audio/shairport/files/patch-Makefile

+22
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,22 @@
1+
--- Makefile.orig 2014-10-05 01:39:58 UTC
2+
+++ Makefile
3+
@@ -48,19 +48,9 @@
4+
install -m 755 -d $(PREFIX)/bin
5+
install -m 755 shairport $(PREFIX)/bin/shairport
6+
7+
-GITREV=$(shell git describe --always)
8+
-DIRTY:=$(shell if ! git diff --quiet --exit-code; then echo -dirty; fi)
9+
-VERSION=\"$(GITREV)$(DIRTY)\"
10+
-__version_file:
11+
- @if [ ! -f version.h -o "`cat .version 2>/dev/null`" != '$(VERSION)' ]; then \
12+
- echo $(VERSION) > version.h; \
13+
- fi
14+
-
15+
%.o: %.c $(DEPS)
16+
$(CC) -c $(CFLAGS) $<
17+
18+
-shairport.o: __version_file
19+
-
20+
OBJS := $(SRCS:.c=.o)
21+
shairport: $(OBJS)
22+
$(CC) $(OBJS) $(LDFLAGS) -o shairport

audio/shairport/files/patch-configure

+31
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,31 @@
1+
--- configure.orig 2014-07-01 11:54:43 UTC
2+
+++ configure
3+
@@ -1,6 +1,6 @@
4+
#!/bin/sh
5+
6+
-[ -z "${CC}" ] && CC=gcc
7+
+[ -z "${CC}" ] && CC=cc
8+
9+
echo Configuring Shairport
10+
11+
@@ -59,7 +59,7 @@
12+
fi
13+
}
14+
15+
-do_pkg_config OpenSSL openssl
16+
+do_pkg_config OpenSSL openssl CONFIG_OPENSSL
17+
do_pkg_config libao ao CONFIG_AO
18+
do_pkg_config PulseAudio libpulse-simple CONFIG_PULSE
19+
do_pkg_config ALSA alsa CONFIG_ALSA
20+
@@ -80,9 +80,9 @@
21+
22+
23+
echo "CFLAGS+=${CFLAGS}" >> config.mk
24+
-echo "LDFLAGS+=${LDFLAGS}" >> config.mk
25+
+echo "LDFLAGS+=${LDFLAGS} -lcrypto" >> config.mk
26+
27+
echo CFLAGS: ${CFLAGS}
28+
-echo LDFLAGS: ${LDFLAGS}
29+
+echo LDFLAGS: ${LDFLAGS} -lcrypto
30+
31+
echo "Configure successful. You may now build with 'make'"

audio/shairport/files/patch-shairport.pl

-18
This file was deleted.

audio/shairport/files/shairport.in

+2-3
Original file line numberDiff line numberDiff line change
@@ -27,11 +27,10 @@ load_rc_config ${name}
2727
: ${shairport_enable="NO"}
2828
: ${shairport_user="nobody"}
2929

30-
command="%%PREFIX%%/bin/${name}.pl"
30+
command="%%PREFIX%%/bin/${name}"
3131
pidfile="/var/run/${name}/${name}.pid"
32-
command_interpreter="%%PERL%%"
3332

34-
command_args="-d -w ${pidfile}"
33+
command_args="-d -P ${pidfile}"
3534
start_precmd="install -d -o ${shairport_user} -g wheel -m 755 /var/run/${name}"
3635

3736
run_rc_command "$1"

0 commit comments

Comments
 (0)