Skip to content

Commit 0f6e5b7

Browse files
author
Felix Fietkau
committedOct 15, 2012
build: add back the package/cleanup step to remove the root staging dir for mklibs
SVN-Revision: 33777
1 parent 6d1884c commit 0f6e5b7

File tree

2 files changed

+6
-2
lines changed

2 files changed

+6
-2
lines changed
 

‎Makefile

+1-1
Original file line numberDiff line numberDiff line change
@@ -40,7 +40,7 @@ else
4040

4141
$(toolchain/stamp-install): $(tools/stamp-install)
4242
$(target/stamp-compile): $(toolchain/stamp-install) $(tools/stamp-install) $(BUILD_DIR)/.prepared
43-
$(package/stamp-compile): $(target/stamp-compile)
43+
$(package/stamp-compile): $(target/stamp-compile) $(package/stamp-cleanup)
4444
$(package/stamp-install): $(package/stamp-compile)
4545
$(target/stamp-install): $(package/stamp-compile) $(package/stamp-install)
4646

‎package/Makefile

+5-1
Original file line numberDiff line numberDiff line change
@@ -73,9 +73,12 @@ OPKG:= \
7373
PACKAGE_INSTALL:=$(sort $(foreach pkg,$(package-y),$(lastword $(subst /,$(space),$(pkg)))))
7474
PACKAGE_INSTALL_FILES:=$(patsubst %,$(PKG_INFO_DIR)/%.install,$(PACKAGE_INSTALL))
7575

76+
$(curdir)/cleanup: $(TMP_DIR)/.build
77+
rm -rf $(STAGING_DIR_ROOT)
78+
7679
$(curdir)/install: $(TMP_DIR)/.build
7780
- find $(STAGING_DIR_ROOT) -type d | $(XARGS) chmod 0755
78-
rm -rf $(TARGET_DIR) $(STAGING_DIR_ROOT)
81+
rm -rf $(TARGET_DIR)
7982
[ -d $(TARGET_DIR)/tmp ] || mkdir -p $(TARGET_DIR)/tmp
8083
$(OPKG) install `cat $(PACKAGE_INSTALL_FILES) | sed -e 's,^\(.*\)$$,$(PACKAGE_DIR)/\1_*.ipk,'`
8184
@for pkg in $(PACKAGE_INSTALL); do \
@@ -121,6 +124,7 @@ $(curdir)/preconfig:
121124
$(curdir)/flags-install:= -j1
122125

123126
$(eval $(call stampfile,$(curdir),package,prereq,.config))
127+
$(eval $(call stampfile,$(curdir),package,cleanup,$(TMP_DIR)/.build))
124128
$(eval $(call stampfile,$(curdir),package,compile,$(TMP_DIR)/.build))
125129
$(eval $(call stampfile,$(curdir),package,install,$(TMP_DIR)/.build))
126130

0 commit comments

Comments
 (0)