Commit 1a5863d 1 parent 66222dd commit 1a5863d Copy full SHA for 1a5863d
File tree 2 files changed +6
-7
lines changed
package/network/ipv6/odhcp6c
2 files changed +6
-7
lines changed Original file line number Diff line number Diff line change 8
8
include $(TOPDIR ) /rules.mk
9
9
10
10
PKG_NAME: =odhcp6c
11
- PKG_RELEASE: =9
11
+ PKG_RELEASE: =10
12
12
13
13
PKG_SOURCE_PROTO: =git
14
14
PKG_SOURCE_URL =$(PROJECT_GIT ) /project/odhcp6c.git
Original file line number Diff line number Diff line change @@ -40,6 +40,10 @@ proto_dhcpv6_add_prefix() {
40
40
append " $3 " " $1 "
41
41
}
42
42
43
+ proto_dhcpv6_add_sendopts () {
44
+ [ -n " $1 " ] && append " $3 " " -x$1 "
45
+ }
46
+
43
47
proto_dhcpv6_setup () {
44
48
local config=" $1 "
45
49
local iface=" $2 "
@@ -80,12 +84,7 @@ proto_dhcpv6_setup() {
80
84
append opts " -r$opt "
81
85
done
82
86
83
- sendopts_cb () {
84
- local val=" $1 "
85
- [ -n " $val " ] && append opts " -x$val "
86
- }
87
-
88
- json_for_each_item sendopts_cb sendopts
87
+ json_for_each_item proto_dhcpv6_add_sendopts sendopts opts
89
88
90
89
append opts " -t${soltimeout:- 120} "
91
90
You can’t perform that action at this time.
0 commit comments