Skip to content

Commit 694f0bb

Browse files
committed
gre: squash grev4 and grev6 packages into gre (FS#1399)
The split-up into packages gre, grev4 and grev6 causes confusion for the users as reported in FS#1399. As IPv4 and IPv6 are considered now as bundled; squash the grev4 and grev6 packages into the gre package and let gre provide both grev4 and grev6. Signed-off-by: Hans Dedecker <[email protected]>
1 parent 175b262 commit 694f0bb

File tree

1 file changed

+5
-34
lines changed

1 file changed

+5
-34
lines changed

package/network/config/gre/Makefile

+5-34
Original file line numberDiff line numberDiff line change
@@ -15,40 +15,21 @@ PKG_LICENSE:=GPL-2.0
1515
include $(INCLUDE_DIR)/package.mk
1616

1717
define Package/gre/Default
18-
SECTION:=net
19-
CATEGORY:=Network
20-
MAINTAINER:=Hans Dedecker <[email protected]>
2118
endef
2219

2320
define Package/gre
24-
$(call Package/gre/Default)
21+
SECTION:=net
22+
CATEGORY:=Network
23+
MAINTAINER:=Hans Dedecker <[email protected]>
2524
TITLE:=Generic Routing Encapsulation config support
25+
DEPENDS:=+kmod-gre +IPV6:kmod-gre6 +resolveip
26+
PROVIDES:=grev4 grev6
2627
endef
2728

2829
define Package/gre/description
2930
Generic Routing Encapsulation config support (IPv4 and IPv6) in /etc/config/network.
3031
endef
3132

32-
define Package/grev4
33-
$(call Package/gre/Default)
34-
TITLE:=Generic Routing Encapsulation (IPv4) config support
35-
DEPENDS:=@(PACKAGE_gre) +kmod-gre +resolveip
36-
endef
37-
38-
define Package/grev4/description
39-
Generic Routing Encapsulation config support (IPv4) in /etc/config/network.
40-
endef
41-
42-
define Package/grev6
43-
$(call Package/gre/Default)
44-
TITLE:=Generic Routing Encapsulation (IPv6) config support
45-
DEPENDS:=@(PACKAGE_gre) @IPV6 +kmod-gre6 +resolveip
46-
endef
47-
48-
define Package/grev6/description
49-
Generic Routing Encapsulation config support (IPv6) in /etc/config/network.
50-
endef
51-
5233
define Build/Compile
5334
endef
5435

@@ -60,14 +41,4 @@ define Package/gre/install
6041
$(INSTALL_BIN) ./files/gre.sh $(1)/lib/netifd/proto/gre.sh
6142
endef
6243

63-
define Package/grev4/install
64-
:
65-
endef
66-
67-
define Package/grev6/install
68-
:
69-
endef
70-
7144
$(eval $(call BuildPackage,gre))
72-
$(eval $(call BuildPackage,grev4))
73-
$(eval $(call BuildPackage,grev6))

0 commit comments

Comments
 (0)