Skip to content

Commit cc7a005

Browse files
committed
odhcp6c: add defaultreqopts config option
By default odhcp6c asks for a default list of options; the config option defaultreqopts allows to tweak this behavior. When set to 0 odhcp6c will not ask for any options except for the options specified in the reqopts config option. Signed-off-by: Hans Dedecker <[email protected]>
1 parent 3f7908d commit cc7a005

File tree

2 files changed

+6
-3
lines changed

2 files changed

+6
-3
lines changed

package/network/ipv6/odhcp6c/Makefile

+1-1
Original file line numberDiff line numberDiff line change
@@ -8,7 +8,7 @@
88
include $(TOPDIR)/rules.mk
99

1010
PKG_NAME:=odhcp6c
11-
PKG_RELEASE:=5
11+
PKG_RELEASE:=6
1212

1313
PKG_SOURCE_PROTO:=git
1414
PKG_SOURCE_URL=$(PROJECT_GIT)/project/odhcp6c.git

package/network/ipv6/odhcp6c/files/dhcpv6.sh

+5-2
Original file line numberDiff line numberDiff line change
@@ -11,6 +11,7 @@ proto_dhcpv6_init_config() {
1111
proto_config_add_string 'reqprefix:or("auto","no",range(0, 64))'
1212
proto_config_add_string clientid
1313
proto_config_add_string 'reqopts:list(uinteger)'
14+
proto_config_add_string 'defaultreqopts:bool'
1415
proto_config_add_string 'noslaaconly:bool'
1516
proto_config_add_string 'forceprefix:bool'
1617
proto_config_add_string 'extendprefix:bool'
@@ -39,8 +40,8 @@ proto_dhcpv6_setup() {
3940
local config="$1"
4041
local iface="$2"
4142

42-
local reqaddress reqprefix clientid reqopts noslaaconly forceprefix extendprefix norelease ip6prefix iface_dslite iface_map iface_464xlat ifaceid userclass vendorclass sendopts delegate zone_dslite zone_map zone_464xlat zone soltimeout fakeroutes sourcefilter keep_ra_dnslifetime ra_holdoff
43-
json_get_vars reqaddress reqprefix clientid reqopts noslaaconly forceprefix extendprefix norelease ip6prefix iface_dslite iface_map iface_464xlat ifaceid userclass vendorclass sendopts delegate zone_dslite zone_map zone_464xlat zone soltimeout fakeroutes sourcefilter keep_ra_dnslifetime ra_holdoff
43+
local reqaddress reqprefix clientid reqopts defaultreqopts noslaaconly forceprefix extendprefix norelease ip6prefix iface_dslite iface_map iface_464xlat ifaceid userclass vendorclass sendopts delegate zone_dslite zone_map zone_464xlat zone soltimeout fakeroutes sourcefilter keep_ra_dnslifetime ra_holdoff
44+
json_get_vars reqaddress reqprefix clientid reqopts defaultreqopts noslaaconly forceprefix extendprefix norelease ip6prefix iface_dslite iface_map iface_464xlat ifaceid userclass vendorclass sendopts delegate zone_dslite zone_map zone_464xlat zone soltimeout fakeroutes sourcefilter keep_ra_dnslifetime ra_holdoff
4445

4546

4647
# Configure
@@ -52,6 +53,8 @@ proto_dhcpv6_setup() {
5253

5354
[ -n "$clientid" ] && append opts "-c$clientid"
5455

56+
[ "$defaultreqopts" = "0" ] && append opts "-R"
57+
5558
[ "$noslaaconly" = "1" ] && append opts "-S"
5659

5760
[ "$forceprefix" = "1" ] && append opts "-F"

0 commit comments

Comments
 (0)