Skip to content

Commit

Permalink
dev-python/python-box: Bump to 7.3.0
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Dec 10, 2024
1 parent f20eee9 commit 21efe97
Show file tree
Hide file tree
Showing 2 changed files with 59 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/python-box/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST Box-7.2.0.gh.tar.gz 87699 BLAKE2B d6f033919e5451adfdcb0c14c28a47e25b619eb531280a39b68912179ad3a21638d4fadd6dbee2b09bc445b1adc2dd31e042d1e816dc5fc36098ea5eadab8a30 SHA512 8f2ec95a0539c8000d08353eccd66dd9de4049408b0cef9095f3bf98486424214e1d47ef5c408e425c5c2958652624efa512701138d91d51356f07795c508b9f
DIST Box-7.3.0.gh.tar.gz 87791 BLAKE2B eba82f4fa083f2f7725547254143d86d034d1dbf0ad540eb4cef8eb387846053a44a7b7dc6b94878a124f98336cade4c6a64c89beb779e5db6008393b721ecc9 SHA512 9425dc339abac6649f9e78b279720ce191559e1629eb4451fc1a63495df1d5c64bf20a339407bbfc6f8e64d9def4accf312087958880a5300c83369ee9d6ceb4
58 changes: 58 additions & 0 deletions dev-python/python-box/python-box-7.3.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,58 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

DISTUTILS_EXT=1
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{10..13} )

inherit distutils-r1

MY_P=Box-${PV}
DESCRIPTION="Python dictionaries with advanced dot notation access"
HOMEPAGE="
https://github.com/cdgriffith/Box/
https://pypi.org/project/python-box/
"
SRC_URI="
https://github.com/cdgriffith/Box/archive/${PV}.tar.gz
-> ${MY_P}.gh.tar.gz
"
S=${WORKDIR}/${MY_P}

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64"
IUSE="+native-extensions"

RDEPEND="
dev-python/msgpack[${PYTHON_USEDEP}]
dev-python/ruamel-yaml[${PYTHON_USEDEP}]
$(python_gen_cond_dep '
dev-python/tomli[${PYTHON_USEDEP}]
' 3.8 3.9 3.10)
dev-python/tomli-w[${PYTHON_USEDEP}]
"
BDEPEND="
native-extensions? (
dev-python/cython[${PYTHON_USEDEP}]
)
"

distutils_enable_tests pytest

src_prepare() {
if ! use native-extensions; then
# a cheap hack, extensions are auto-disabled if Cython.Build
# is not importable
> Cython.py || die
fi

distutils-r1_src_prepare
}

python_test() {
rm -rf box || die
epytest
}

0 comments on commit 21efe97

Please sign in to comment.