Skip to content

Commit

Permalink
dev-util/spirv-tools: add 1.3.296.0
Browse files Browse the repository at this point in the history
Signed-off-by: Nick Sarnie <[email protected]>
  • Loading branch information
sarnex committed Oct 18, 2024
1 parent f7d6b3d commit 4fe69f7
Show file tree
Hide file tree
Showing 2 changed files with 43 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-util/spirv-tools/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST spirv-tools-1.3.290.0.tar.gz 3170780 BLAKE2B 37609534f77e411ffb90e2904e847b2baec80332b5f3d3d3fb6950d835f9526fb95778d4c903574cf8be142370a69cace50d2e69d41e2eccf5f74a764464c148 SHA512 d4e8440c0843fb084dde4a576b95442783ab8204670b199798bd87f754d77f3c258bb69ab1d4dd7859c1d2c681ed8813309c76c6f70b5a7d8d21b6a48ef63b67
DIST spirv-tools-1.3.296.0.tar.gz 3195963 BLAKE2B ea20efe36090a0e8d46c2fab0c6d08b4f5dc02dce176b88331cbddd8a8bc2fe507abb07e98bcdd15295a311480366d83837e3de2f7d175013b1518682e88b5a4 SHA512 62f0a6034bd016aedfb8975bbd3bb134ef928bd6bafbb61d9f73c46760019597b9841b80243c86e5e5e0576824cd20255067e447590eb0d2d51593439152215e
42 changes: 42 additions & 0 deletions dev-util/spirv-tools/spirv-tools-1.3.296.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,42 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

MY_PN=SPIRV-Tools
PYTHON_COMPAT=( python3_{10..13} )
PYTHON_REQ_USE="xml(+)"
inherit cmake-multilib python-any-r1

if [[ ${PV} == *9999* ]]; then
EGIT_REPO_URI="https://github.com/KhronosGroup/${MY_PN}.git"
inherit git-r3
else
EGIT_COMMIT="vulkan-sdk-${PV}"
SRC_URI="https://github.com/KhronosGroup/${MY_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
S="${WORKDIR}"/${MY_PN}-${EGIT_COMMIT}
fi

DESCRIPTION="Provides an API and commands for processing SPIR-V modules"
HOMEPAGE="https://github.com/KhronosGroup/SPIRV-Tools"

LICENSE="Apache-2.0"
SLOT="0"
# Tests fail upon finding symbols that do not match a regular expression
# in the generated library. Easily hit with non-standard compiler flags
RESTRICT="test"

DEPEND="~dev-util/spirv-headers-${PV}"
# RDEPEND=""
BDEPEND="${PYTHON_DEPS}"

multilib_src_configure() {
local mycmakeargs=(
-DSPIRV-Headers_SOURCE_DIR="${ESYSROOT}"/usr/
-DSPIRV_WERROR=OFF
-DSPIRV_TOOLS_BUILD_STATIC=OFF
)

cmake_src_configure
}

0 comments on commit 4fe69f7

Please sign in to comment.