Skip to content

Commit

Permalink
kernel: bump 5.10 to 5.10.120
Browse files Browse the repository at this point in the history
All patches automatically rebased.

Build system: x86_64
Build-tested: ipq806x/R7800, x86/64

Signed-off-by: John Audia <[email protected]>
  • Loading branch information
graysky2 authored and hauke committed Jun 6, 2022
1 parent cd634af commit f800f8d
Show file tree
Hide file tree
Showing 9 changed files with 12 additions and 12 deletions.
4 changes: 2 additions & 2 deletions include/kernel-5.10
Original file line number Diff line number Diff line change
@@ -1,2 +1,2 @@
LINUX_VERSION-5.10 = .119
LINUX_KERNEL_HASH-5.10.119 = 3e353e55a2b7074c905c7c517c6dae83eae440f98a12ffd471dc4df1d5172511
LINUX_VERSION-5.10 = .120
LINUX_KERNEL_HASH-5.10.120 = 5b7a756004158ece2f5e41795ba523ec201743a736e34ce41cbe09177f7d0e8b
4 changes: 2 additions & 2 deletions target/linux/ath25/patches-5.10/700-swconfig_mvswitch.patch
Original file line number Diff line number Diff line change
Expand Up @@ -13,8 +13,8 @@
select SWCONFIG
--- a/drivers/net/phy/Makefile
+++ b/drivers/net/phy/Makefile
@@ -29,6 +29,7 @@ obj-$(CONFIG_ADM6996_PHY) += adm6996.o
obj-$(CONFIG_AR8216_PHY) += ar8216.o ar8327.o
@@ -31,6 +31,7 @@ ar8xxx-y += ar8216.o
ar8xxx-y += ar8327.o
obj-$(CONFIG_SWCONFIG_B53) += b53/
obj-$(CONFIG_IP17XX_PHY) += ip17xx.o
+obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -70,7 +70,7 @@ Signed-off-by: Pablo Neira Ayuso <[email protected]>
nft_trans_table_update(trans) = true;
list_add_tail(&trans->list, &ctx->net->nft.commit_list);
return 0;
@@ -7908,11 +7912,10 @@ static int nf_tables_commit(struct net *
@@ -7918,11 +7922,10 @@ static int nf_tables_commit(struct net *
switch (trans->msg_type) {
case NFT_MSG_NEWTABLE:
if (nft_trans_table_update(trans)) {
Expand All @@ -86,7 +86,7 @@ Signed-off-by: Pablo Neira Ayuso <[email protected]>
} else {
nft_clear(net, trans->ctx.table);
}
@@ -8125,11 +8128,9 @@ static int __nf_tables_abort(struct net
@@ -8135,11 +8138,9 @@ static int __nf_tables_abort(struct net
switch (trans->msg_type) {
case NFT_MSG_NEWTABLE:
if (nft_trans_table_update(trans)) {
Expand Down
2 changes: 1 addition & 1 deletion target/linux/generic/hack-5.10/251-kconfig.patch
Original file line number Diff line number Diff line change
Expand Up @@ -92,7 +92,7 @@ Signed-off-by: John Crispin <[email protected]>
bool
--- a/lib/Kconfig
+++ b/lib/Kconfig
@@ -418,16 +418,16 @@ config BCH_CONST_T
@@ -420,16 +420,16 @@ config BCH_CONST_T
# Textsearch support is select'ed if needed
#
config TEXTSEARCH
Expand Down
2 changes: 1 addition & 1 deletion target/linux/generic/hack-5.10/253-ksmbd-config.patch
Original file line number Diff line number Diff line change
Expand Up @@ -11,7 +11,7 @@
that can be interpreted by the ASN.1 stream decoder and used to
--- a/lib/Kconfig
+++ b/lib/Kconfig
@@ -589,7 +589,7 @@ config LIBFDT
@@ -591,7 +591,7 @@ config LIBFDT
bool

config OID_REGISTRY
Expand Down
2 changes: 1 addition & 1 deletion target/linux/generic/hack-5.10/261-lib-arc4-unhide.patch
Original file line number Diff line number Diff line change
Expand Up @@ -4,7 +4,7 @@ from backports.

--- a/lib/crypto/Kconfig
+++ b/lib/crypto/Kconfig
@@ -4,7 +4,7 @@ config CRYPTO_LIB_AES
@@ -6,7 +6,7 @@ config CRYPTO_LIB_AES
tristate

config CRYPTO_LIB_ARC4
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -1087,7 +1087,7 @@ Signed-off-by: Alexandros C. Couloumbis <[email protected]>
#define JFFS2_NODE_ACCURATE 0x2000
--- a/lib/Kconfig
+++ b/lib/Kconfig
@@ -315,6 +315,12 @@ config ZSTD_DECOMPRESS
@@ -317,6 +317,12 @@ config ZSTD_DECOMPRESS

source "lib/xz/Kconfig"

Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -40,7 +40,7 @@ Signed-off-by: Robert Marko <[email protected]>
help
--- a/drivers/net/phy/Makefile
+++ b/drivers/net/phy/Makefile
@@ -86,6 +86,7 @@ obj-$(CONFIG_MICROSEMI_PHY) += mscc/
@@ -88,6 +88,7 @@ obj-$(CONFIG_MICROSEMI_PHY) += mscc/
obj-$(CONFIG_NATIONAL_PHY) += national.o
obj-$(CONFIG_NXP_TJA11XX_PHY) += nxp-tja11xx.o
obj-$(CONFIG_QSEMI_PHY) += qsemi.o
Expand Down
2 changes: 1 addition & 1 deletion target/linux/realtek/patches-5.10/705-add-rtl-phy.patch
Original file line number Diff line number Diff line change
Expand Up @@ -15,7 +15,7 @@
help
--- a/drivers/net/phy/Makefile
+++ b/drivers/net/phy/Makefile
@@ -87,6 +87,7 @@ obj-$(CONFIG_NATIONAL_PHY) += national.o
@@ -89,6 +89,7 @@ obj-$(CONFIG_NATIONAL_PHY) += national.o
obj-$(CONFIG_NXP_TJA11XX_PHY) += nxp-tja11xx.o
obj-$(CONFIG_QSEMI_PHY) += qsemi.o
obj-$(CONFIG_REALTEK_PHY) += realtek.o
Expand Down

0 comments on commit f800f8d

Please sign in to comment.