Skip to content

Commit

Permalink
toolchain: bump GCC 12 to 12.2.0
Browse files Browse the repository at this point in the history
Refreshed patches:
- 910-mbsd_multi.patch
- 970-macos_arm64-building-fix.patch

Signed-off-by: Nick Hainke <[email protected]>
  • Loading branch information
PolynomialDivision authored and hauke committed Aug 28, 2022
1 parent f0adf25 commit fac1f38
Show file tree
Hide file tree
Showing 19 changed files with 9 additions and 9 deletions.
2 changes: 1 addition & 1 deletion toolchain/gcc/Config.version
Original file line number Diff line number Diff line change
Expand Up @@ -14,5 +14,5 @@ config GCC_VERSION
string
default "8.4.0" if GCC_VERSION_8
default "10.3.0" if GCC_VERSION_10
default "12.1.0" if GCC_VERSION_12
default "12.2.0" if GCC_VERSION_12
default "11.3.0"
4 changes: 2 additions & 2 deletions toolchain/gcc/common.mk
Original file line number Diff line number Diff line change
Expand Up @@ -40,8 +40,8 @@ ifeq ($(PKG_VERSION),11.3.0)
PKG_HASH:=b47cf2818691f5b1e21df2bb38c795fac2cfbd640ede2d0a5e1c89e338a3ac39
endif

ifeq ($(PKG_VERSION),12.1.0)
PKG_HASH:=62fd634889f31c02b64af2c468f064b47ad1ca78411c45abe6ac4b5f8dd19c7b
ifeq ($(PKG_VERSION),12.2.0)
PKG_HASH:=e549cf9cf3594a00e27b6589d4322d70e0720cdd213f39beb4181e06926230ff
endif

PATCH_DIR=../patches/$(GCC_VERSION)
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -134,7 +134,7 @@ Date: Tue Jul 31 00:52:27 2007 +0000
@opindex Wno-stack-protector
--- a/gcc/opts.cc
+++ b/gcc/opts.cc
@@ -2658,6 +2658,9 @@ common_handle_option (struct gcc_options
@@ -2692,6 +2692,9 @@ common_handle_option (struct gcc_options
add_comma_separated_to_vector (&opts->x_flag_ignored_attributes, arg);
break;

Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -17,7 +17,7 @@ Date: Mon Aug 16 13:16:21 2021 +0100

--- a/gcc/config/aarch64/aarch64.h
+++ b/gcc/config/aarch64/aarch64.h
@@ -1236,7 +1236,7 @@ extern const char *aarch64_rewrite_mcpu
@@ -1290,7 +1290,7 @@ extern const char *aarch64_rewrite_mcpu
#define MCPU_TO_MARCH_SPEC_FUNCTIONS \
{ "rewrite_mcpu", aarch64_rewrite_mcpu },

Expand All @@ -28,18 +28,18 @@ Date: Mon Aug 16 13:16:21 2021 +0100
# define EXTRA_SPEC_FUNCTIONS \
--- a/gcc/config/host-darwin.cc
+++ b/gcc/config/host-darwin.cc
@@ -22,6 +22,8 @@
#include "coretypes.h"
@@ -23,6 +23,8 @@
#include "options.h"
#include "diagnostic-core.h"
#include "config/host-darwin.h"
+#include "hosthooks.h"
+#include "hosthooks-def.h"
#include <errno.h>

/* For Darwin (macOS only) platforms, without ASLR (PIE) enabled on the
@@ -79,3 +81,5 @@ darwin_gt_pch_use_address (void *addr, s
@@ -181,3 +183,5 @@ darwin_gt_pch_use_address (void *&addr,

return ret;
return 1;
}
+
+const struct host_hooks host_hooks = HOST_HOOKS_INITIALIZER;

0 comments on commit fac1f38

Please sign in to comment.