Skip to content

Commit

Permalink
dev-lua/busted-htest: update EAPI 7 -> 8
Browse files Browse the repository at this point in the history
Signed-off-by: Conrad Kostecki <[email protected]>
  • Loading branch information
ConiKost committed Feb 9, 2022
1 parent 05ed6c3 commit 023117f
Showing 1 changed file with 35 additions and 0 deletions.
35 changes: 35 additions & 0 deletions dev-lua/busted-htest/busted-htest-1.0.0-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,35 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

LUA_COMPAT=( lua5-{1..4} luajit )

inherit lua

DESCRIPTION="Pretty output handler for Busted"
HOMEPAGE="https://github.com/hishamhm/busted-htest"
SRC_URI="https://github.com/hishamhm/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 arm arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc x86"
REQUIRED_USE="${LUA_REQUIRED_USE}"

RDEPEND="
dev-lua/busted[${LUA_USEDEP}]
${LUA_DEPS}
"

BDEPEND="virtual/pkgconfig"

lua_src_install() {
insinto $(lua_get_lmod_dir)
doins src/busted/outputHandlers/htest.lua

einstalldocs
}

src_install() {
lua_foreach_impl lua_src_install
}

0 comments on commit 023117f

Please sign in to comment.