Skip to content

Commit

Permalink
app-crypt/kbfs: Add kbfs systemd service
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.40, Repoman-2.3.9
  • Loading branch information
nicolasbock committed Jun 9, 2018
1 parent aff1af8 commit 03d1281
Show file tree
Hide file tree
Showing 2 changed files with 54 additions and 6 deletions.
50 changes: 50 additions & 0 deletions app-crypt/kbfs/kbfs-1.0.44-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,50 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit systemd

DESCRIPTION="Keybase Filesystem (KBFS)"
HOMEPAGE="https://keybase.io/docs/kbfs"
SRC_URI="https://github.com/keybase/kbfs/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="git"

DEPEND=">=dev-lang/go-1.6:0"
RDEPEND="
app-crypt/gnupg
sys-fs/fuse
"

S="${WORKDIR}/src/github.com/keybase/kbfs"

src_unpack() {
unpack "${P}.tar.gz"
mkdir -p "$(dirname "${S}")" || die
mv "kbfs-${PV}" "${S}" || die
}

src_compile() {
GOPATH="${WORKDIR}" \
go build -v -x \
-tags production \
-o "${T}/kbfsfuse" \
github.com/keybase/kbfs/kbfsfuse
use git && \
GOPATH="${WORKDIR}" \
go build -v -x \
-tags production \
-o "${T}/git-remote-keybase" \
github.com/keybase/kbfs/kbfsgit/git-remote-keybase
}

src_install() {
dobin "${T}/kbfsfuse"
use git && \
dobin "${T}/git-remote-keybase"
systemd_douserunit "${S}/packaging/linux/systemd/kbfs.service"
}
10 changes: 4 additions & 6 deletions app-crypt/kbfs/kbfs-9999.ebuild
Original file line number Diff line number Diff line change
@@ -1,9 +1,9 @@
# Copyright 1999-2017 Gentoo Foundation
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit git-r3
inherit git-r3 systemd

DESCRIPTION="Keybase Filesystem (KBFS)"
HOMEPAGE="https://keybase.io/docs/kbfs"
Expand All @@ -14,10 +14,7 @@ SLOT="0"
KEYWORDS=""
IUSE="git"

DEPEND="
>=dev-lang/go-1.6:0
>=app-crypt/keybase-1.0.17
"
DEPEND=">=dev-lang/go-1.6:0"
RDEPEND="
app-crypt/gnupg
sys-fs/fuse
Expand Down Expand Up @@ -49,4 +46,5 @@ src_install() {
dobin "${T}/kbfsfuse"
use git && \
dobin "${T}/git-remote-keybase"
systemd_douserunit "${S}/packaging/linux/systemd/kbfs.service"
}

0 comments on commit 03d1281

Please sign in to comment.