Skip to content

Commit

Permalink
app-laptop/laptop-mode-tools: version bump
Browse files Browse the repository at this point in the history
Bug: 559266
  • Loading branch information
alonbl committed Aug 31, 2015
1 parent 051d652 commit 079ade6
Show file tree
Hide file tree
Showing 2 changed files with 94 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-laptop/laptop-mode-tools/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST laptop-mode-tools_1.66.tar.gz 111175 SHA256 0e8488d6112fa7edfa7e4b1084b16f8c7c6726d935029e4afd7d7034caed5f62 SHA512 8649f70ab63ca0a1e5edf5c4c69062b01dce97b34ef6686a2c044f177aaac59008d4275b237e2c97a2541b6b824c0513d32323c156a43684264ba6d2c5fc8b6c WHIRLPOOL 4fc981f00c4afd74da74e192beb292c5d39e2a3bcc23d77e5daf37c71b75acb4df81c70a68586c0704b47fbe08dce69b1921d0d151777b5451b8d6302bac5b0f
DIST laptop-mode-tools_1.67.tar.gz 111730 SHA256 5205e5b4fa0eddcbb14e06a496a9e405cf3873eb5065e03e6a1237e29c8f3cd0 SHA512 a0f8f5c6c2616bbdbe86f82b0dc7ad1bd4b4315fc074b7b97ad29a9dec4e63164d625da732f6b6b9a73dd039d415c06da51c83c5aa1056e7893b65691da1437f WHIRLPOOL 03fd0f7bc7300d7357d6b1f27a38aed54c7b77a7f8633910d3bfa6aede862f24238bde9322398cedea0e6b9d1bcd85b988e56ff1f2aeb62d691a209aa6f2acab
DIST laptop-mode-tools_1.68.tar.gz 112695 SHA256 a9ceca49a623fecf0d8067cd71d11610a254af7e87a3a462cb4277527a905558 SHA512 1870c0400b32f4bb95f407db64f9e8920391c0758f37fa493545865ba0801ed6d67491c8d69bd7565d72a3437fe01524153fdd4dcf2cd69b49e7f1b0a54ff0c4 WHIRLPOOL 28b5e9fe7744824c4b562e8123e9403020a6096e32960f23592cc4393fce1379cc359602e83ff959187a953965e353d85c42c901c7ec6e382dd1ff67e0fb5699
93 changes: 93 additions & 0 deletions app-laptop/laptop-mode-tools/laptop-mode-tools-1.68.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,93 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
inherit eutils multilib systemd udev

MY_P=${PN}_${PV}

DESCRIPTION="Linux kernel laptop_mode user-space utilities"
HOMEPAGE="http://www.samwel.tk/laptop_mode/"
SRC_URI="http://www.samwel.tk/laptop_mode/tools/downloads/${MY_P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="+acpi apm bluetooth scsi"

RDEPEND="net-wireless/wireless-tools
sys-apps/iproute2
sys-apps/ethtool
sys-apps/hdparm
sys-apps/which
acpi? ( sys-power/acpid )
apm? ( sys-apps/apmd )
bluetooth? ( net-wireless/bluez:= )
scsi? ( sys-apps/sdparm )"
DEPEND=""

S=${WORKDIR}/${MY_P}

src_prepare() {
# This should avoid conflict with pm-powersave wrt #327443 and #396703
cat <<-EOF > "${T}"/${PN}
HOOK_BLACKLIST="00powersave"
EOF
}

src_compile() { :; }

src_install() {
DESTDIR="${D}" \
INIT_D="none" \
MAN_D="/usr/share/man" \
LIB_D="/usr/$(get_libdir)" \
UDEV_D="$(get_udevdir)" \
SYSTEMD_UNIT_D="$(systemd_get_unitdir)" \
TMPFILES_D="/usr/lib/tmpfiles.d" \
ACPI="$(use acpi && echo force || echo disabled)" \
PMU="$(false && echo force || echo disabled)" \
APM="$(use apm && echo force || echo disabled)" \
SYSTEMD=yes \
sh ./install.sh || die

dodoc Documentation/*.txt README.md
newinitd "${FILESDIR}"/laptop_mode.init-1.4 laptop_mode

# See src_prepare()
insinto /etc/pm/config.d
doins "${T}"/${PN}
}

pkg_postinst() {
if use acpi || use apm; then
if use acpi; then
daemon_name="acpid"
elif use apm; then
deamon_name="apmd"
fi
if [ "$(rc-config list default | grep laptop_mode)" = "" ] || [ "$(rc-config list default | grep ${daemon_name} )" = "" ]; then
ewarn "To enable automatic power state event handling,"
ewarn "e.g. enabling laptop_mode after unplugging the battery,"
ewarn "both laptop_mode and the ${daemon_name} daemon must be"
ewarn "added to default runlevel:"
if [ "$(rc-config list default | grep laptop_mode)" = "" ]; then
ewarn "# rc-update add laptop_mode default"
fi
if [ "$(rc-config list default | grep ${daemon_name} )" = "" ]; then
ewarn "# rc-update add ${daemon_name} default"
fi
fi
else
ewarn "Without USE=\"acpi\" or USE=\"apm\" ${PN} can not"
ewarn "automatically disable laptop_mode on low battery."
ewarn
ewarn "This means you can lose up to 10 minutes of work if running"
ewarn "out of battery while laptop_mode is enabled."
ewarn
ewarn "Please see laptop-mode.txt in /usr/share/doc/${PF} for further"
ewarn "information."
ewarn
fi
}

0 comments on commit 079ade6

Please sign in to comment.