Skip to content

Commit

Permalink
app-admin/doctl: new ebuild
Browse files Browse the repository at this point in the history
A command line tool for DigitalOcean services

Package-Manager: Portage-3.0.13, Repoman-3.0.2
Signed-off-by: Vladimir Pavljuchenkov <[email protected]>
Closes: gentoo#11546
Signed-off-by: Joonas Niilola <[email protected]>
  • Loading branch information
SpiderX authored and juippis committed Feb 1, 2021
1 parent a96f316 commit 0cb85bc
Show file tree
Hide file tree
Showing 4 changed files with 107 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-admin/doctl/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST doctl-1.55.0.tar.gz 5157504 BLAKE2B 1d3db2ee4ca71a459456e72f035648c5ba73c5372c3369b360e1ee3cc44ec1155295e5f425611c307371f902c7ffed7dbce2f959266f79ecb8f149144fc86596 SHA512 6cea86e184ea25d5a6740d4090148fbe053ce93ebe8f2344f5a2bf62283381ed2a9574862a5ba39f34a52bf85af550313b7dd316a321f31089673f898d37cf78
40 changes: 40 additions & 0 deletions app-admin/doctl/doctl-1.55.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,40 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit bash-completion-r1 go-module

DESCRIPTION="A command line tool for DigitalOcean services"
HOMEPAGE="https://github.com/digitalocean/doctl"
SRC_URI="https://github.com/digitalocean/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="Apache-2.0 MIT BSD BSD-2 ISC MPL-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""

src_compile() {
GOFLAGS="-v -x -mod=vendor" \
go build ./cmd/... || die "build failed"

./doctl completion bash > doctl.bash || die "completion for bash failed"
./doctl completion zsh > doctl.zsh || die "completion for sh failed"
./doctl completion fish > doctl.fish || die "completion for fish failed"
}

src_test() {
GOFLAGS="-v -x -mod=vendor" \
go test -work ./do/... ./pkg/... . || die "test failed"
}

src_install() {
einstalldocs
dobin doctl

newbashcomp doctl.bash doctl
insinto /usr/share/zsh/site-functions
newins doctl.zsh _doctl
insinto /usr/share/fish/completion
newins doctl.fish doctl
}
46 changes: 46 additions & 0 deletions app-admin/doctl/doctl-9999.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,46 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

EGIT_REPO_URI="https://github.com/digitalocean/${PN}.git"

inherit bash-completion-r1 git-r3 go-module

DESCRIPTION="A command line tool for DigitalOcean services"
HOMEPAGE="https://github.com/digitalocean/doctl"
SRC_URI=""

LICENSE="Apache-2.0 MIT BSD BSD-2 ISC MPL-2.0"
SLOT="0"
KEYWORDS=""
IUSE=""

src_unpack() {
git-r3_src_unpack
}

src_compile() {
GOFLAGS="-v -x -mod=vendor" \
go build ./cmd/... || die "build failed"

./doctl completion bash > doctl.bash || die "completion for bash failed"
./doctl completion zsh > doctl.zsh || die "completion for sh failed"
./doctl completion fish > doctl.fish || die "completion for fish failed"
}

src_test() {
GOFLAGS="-v -x -mod=vendor" \
go test -work ./do/... ./pkg/... . || die "test failed"
}

src_install() {
einstalldocs
dobin doctl

newbashcomp doctl.bash doctl
insinto /usr/share/zsh/site-functions
newins doctl.zsh _doctl
insinto /usr/share/fish/completion
newins doctl.fish doctl
}
20 changes: 20 additions & 0 deletions app-admin/doctl/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,20 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>[email protected]</email>
<name>Vladimir Pavljuchenkov</name>
</maintainer>
<maintainer type="project">
<email>[email protected]</email>
<name>Proxy Maintainers</name>
</maintainer>
<longdescription lang="en">
The official DigitalOcean command-line client,
which leverages the DigitalOcean API to provide access
to DigitalOcean services.
</longdescription>
<upstream>
<remote-id type="github">digitalocean/doctl</remote-id>
</upstream>
</pkgmetadata>

0 comments on commit 0cb85bc

Please sign in to comment.