Skip to content

Commit

Permalink
dev-vcs/darcs: update EAPI 7 -> 8
Browse files Browse the repository at this point in the history
Signed-off-by: Jack Todaro <[email protected]>
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
solpeth authored and thesamesam committed Jul 24, 2022
1 parent d029b2a commit 10310dc
Show file tree
Hide file tree
Showing 2 changed files with 96 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-vcs/darcs/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST darcs-2.16.3.tar.gz 1244848 BLAKE2B 59754a782a456b3c6bba2b382d485b5de00ae3fc7ac1107bcf89877aff9650eb823704eb23912a83643685612a0cfc84ccf2af2303b52249d9e7a3e55c08c7b7 SHA512 267787c5b3111a20158858b42a8b9c2698b80dc40f7d340175e26d74b955643cefffc2f4de9811fa26464eac2e79913150fb3cd73871275725d10a690b9d73c3
DIST darcs-2.16.5.tar.gz 1271154 BLAKE2B 84c9005d7bcb789cfa5d1de636221e7647ac469aa9f1e27d55bb07a8b155659d38dbda8a46b98698f348248b0384b4e5bc275737bfede13ebb1a9d11b4e9e304 SHA512 9116043943315417ff314197f6a143435b5545f614c6e6210c3645987a68c69c31f53f823ee5269cb663ccba393f8caf1834120783f15128e43b132c731a0edb
95 changes: 95 additions & 0 deletions dev-vcs/darcs/darcs-2.16.5-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,95 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

# ebuild generated by hackport 0.7.1.1.9999
#hackport: flags: +library,+executable,-hpc,-warn-as-error,+pkgconfig,-rts,-static,-optimize,hashed-storage-diff:diff,+http

CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
inherit haskell-cabal

DESCRIPTION="a distributed, interactive, smart revision control system"
HOMEPAGE="http://darcs.net/"
SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"

LICENSE="GPL-2+"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
IUSE="curl +terminfo +threaded"

RDEPEND=">=dev-haskell/async-2.0.2:=[profile?] <dev-haskell/async-2.3:=[profile?]
>=dev-haskell/attoparsec-0.13.0.1:=[profile?]
>=dev-haskell/base16-bytestring-0.1.1.7:=[profile?] <dev-haskell/base16-bytestring-1.1:=[profile?]
>=dev-haskell/conduit-1.3.0:=[profile?] <dev-haskell/conduit-1.4:=[profile?]
>=dev-haskell/constraints-0.11:=[profile?]
>=dev-haskell/cryptonite-0.24:=[profile?] <dev-haskell/cryptonite-0.30:=[profile?]
>=dev-haskell/data-ordlist-0.4:=[profile?] <dev-haskell/data-ordlist-0.5:=[profile?]
>=dev-haskell/fgl-5.5.2.3:=[profile?] <dev-haskell/fgl-5.8:=[profile?]
>=dev-haskell/hashable-1.2.3.3:=[profile?]
>=dev-haskell/haskeline-0.7.2:=[profile?] <dev-haskell/haskeline-0.9:=[profile?]
>=dev-haskell/html-1.0.1.2:=[profile?] <dev-haskell/html-1.1:=[profile?]
>=dev-haskell/http-conduit-2.3:=[profile?] <dev-haskell/http-conduit-2.4:=[profile?]
>=dev-haskell/http-types-0.12.1:=[profile?] <dev-haskell/http-types-0.12.4:=[profile?]
>=dev-haskell/memory-0.14:=[profile?] <dev-haskell/memory-0.17:=[profile?]
>=dev-haskell/mmap-0.5.9:=[profile?] <dev-haskell/mmap-0.6:=[profile?]
>=dev-haskell/network-2.6:=[profile?] <dev-haskell/network-3.2:=[profile?]
>=dev-haskell/network-uri-2.6:=[profile?] <dev-haskell/network-uri-2.8:=[profile?]
>=dev-haskell/old-time-1.1.0.3:=[profile?] <dev-haskell/old-time-1.2:=[profile?]
>=dev-haskell/regex-applicative-0.2:=[profile?] <dev-haskell/regex-applicative-0.4:=[profile?]
>=dev-haskell/regex-base-0.94.0.1:=[profile?] <dev-haskell/regex-base-0.94.1:=[profile?]
>=dev-haskell/regex-tdfa-1.3.1.0:=[profile?] <dev-haskell/regex-tdfa-1.3.2:=[profile?]
>=dev-haskell/stm-2.1:=[profile?] <dev-haskell/stm-2.6:=[profile?]
>=dev-haskell/tar-0.5:=[profile?] <dev-haskell/tar-0.6:=[profile?]
>=dev-haskell/temporary-1.2.1:=[profile?] <dev-haskell/temporary-1.4:=[profile?]
>=dev-haskell/unix-compat-0.5:=[profile?] <dev-haskell/unix-compat-0.6:=[profile?]
>=dev-haskell/utf8-string-1:=[profile?] <dev-haskell/utf8-string-1.1:=[profile?]
>=dev-haskell/vector-0.11:=[profile?] <dev-haskell/vector-0.13:=[profile?]
>=dev-haskell/zip-archive-0.3:=[profile?] <dev-haskell/zip-archive-0.5:=[profile?]
>=dev-haskell/zlib-0.6.1.2:=[profile?] <dev-haskell/zlib-0.7.0.0:=[profile?]
>=dev-lang/ghc-8.4.3:=
curl? ( net-misc/curl )
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-2.4 <dev-haskell/cabal-3.7
test? ( >=dev-haskell/cmdargs-0.10.10 <dev-haskell/cmdargs-0.11
>=dev-haskell/exceptions-0.6
>=dev-haskell/findbin-0.0.5 <dev-haskell/findbin-0.1
>=dev-haskell/hunit-1.3 <dev-haskell/hunit-1.7
>=dev-haskell/leancheck-0.9 <dev-haskell/leancheck-0.10
>=dev-haskell/monad-control-0.3.2 <dev-haskell/monad-control-1.1
>=dev-haskell/quickcheck-2.13 <dev-haskell/quickcheck-2.15
<dev-haskell/system-fileio-0.4
>=dev-haskell/system-filepath-0.4.7 <dev-haskell/system-filepath-0.5
>=dev-haskell/test-framework-0.8.1.1 <dev-haskell/test-framework-0.9
>=dev-haskell/test-framework-hunit-0.3.0.2 <dev-haskell/test-framework-hunit-0.4
>=dev-haskell/test-framework-leancheck-0.0.1 <dev-haskell/test-framework-leancheck-0.1
>=dev-haskell/test-framework-quickcheck2-0.3.0.3 <dev-haskell/test-framework-quickcheck2-0.4
dev-haskell/transformers-base )
curl? ( virtual/pkgconfig )
"

src_prepare() {
default

cabal_chdeps \
'constraints >= 0.11 && < 0.13' 'constraints >=0.11' \
'hashable >= 1.2.3.3 && < 1.4' 'hashable >=1.2.3.3' \
'attoparsec >= 0.13.0.1 && < 0.14' 'attoparsec >=0.13.0.1'
}

src_configure() {
haskell-cabal_src_configure \
$(cabal_flag curl curl) \
--flag=executable \
--flag=-hpc \
--flag=http \
--flag=library \
--flag=-optimize \
--flag=pkgconfig \
--flag=-rts \
--flag=-static \
$(cabal_flag terminfo terminfo) \
$(cabal_flag threaded threaded) \
--flag=-warn-as-error
}

0 comments on commit 10310dc

Please sign in to comment.