forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Signed-off-by: Conrad Kostecki <[email protected]>
- Loading branch information
Showing
2 changed files
with
34 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST level-zero-1.16.1.tar.gz 999641 BLAKE2B 845964416526428d4848ccc3beebf0eac426ba39ce292cea3dced13803dbeb1d4393930b46a60fc2c59dc9e2f4bba1188b211a57574c58fb7180c44b7a8a028b SHA512 c53b5663494613b7a536816bf8367895aa055ce74d9abc8e8aacc3efb7c081de60480d03693861e2b348698b7da6224ac21fb590bf9311d342a19ca4f416b051 | ||
DIST level-zero-1.16.14.tar.gz 1001744 BLAKE2B a02d3b04a127bb43a3b2507c00f6c536d319d11e6196ad347f3d82a22d11f094118b5115589f463945b8763c9fb5c22a09965c637e72b14c7364813f8d69e05f SHA512 8c80d75909398245c0173a4198748d1a1e469e21a09138f60b314061ff556e7f529807e02c6ec1f3a47f2871e17c24b7be6d363810a25fee11e73b5c97c7c62a | ||
DIST level-zero-1.16.15.tar.gz 1001798 BLAKE2B 176a2152f9dbc292d221b3a75f7fbf28b863eb2fc3d83e54d3b0b7d504cde866ce376bd57d30b64f4619297732480c7a9add60538953a0cb600af43e465eaf65 SHA512 37f1770f1bfa71fa08d56afed53a4dd1107ff36d8790f7bb0f921237d9d0e90076ef22349e8f289cf8f154ca0e1e0fff6a7dcd55b71468989322b9892962b874 | ||
DIST level-zero-1.17.0.tar.gz 1003951 BLAKE2B 10b7f7513b42e9f4c7671957959c0f7ff1ba3a05c2f39f23964b415e1b1984ae40d13be92c1a2587711181ac35b46d9f1132637aa41c2dfceef2f39f96ac35f6 SHA512 97b9d06b5cd84b1644ca252ac5009d1350f8c72aeb908a3b93bf8e07f91354589ce4fffdd8069b301eac6b704489ca04022aa4a44a7269bc0da3ace7103b5802 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,33 @@ | ||
# Copyright 1999-2024 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=8 | ||
|
||
inherit cmake | ||
|
||
DESCRIPTION="oneAPI Level Zero headers, loader and validation layer" | ||
HOMEPAGE="https://github.com/oneapi-src/level-zero" | ||
SRC_URI="https://github.com/oneapi-src/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz" | ||
|
||
LICENSE="MIT" | ||
SLOT="0/${PV}" | ||
KEYWORDS="~amd64" | ||
|
||
RDEPEND=" | ||
dev-libs/libfmt:= | ||
dev-libs/spdlog:= | ||
" | ||
DEPEND="${RDEPEND}" | ||
|
||
PATCHES=( "${FILESDIR}/${PN}-1.16.14-spdlog-libfmt.patch" ) | ||
|
||
src_prepare() { | ||
# Don't hardcore -Werror | ||
sed -e 's/-Werror//g' -i CMakeLists.txt || die | ||
|
||
cmake_src_prepare | ||
|
||
# According to upstream, release tarballs should contain this file but at least | ||
# some of them do not. Fortunately it is trivial to make one ourselves. | ||
echo "$(ver_cut 3)" > "${S}"/VERSION_PATCH || die | ||
} |