forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-python/license-expression: Bump to 30.3.0
Signed-off-by: Michał Górny <[email protected]>
- Loading branch information
Showing
2 changed files
with
35 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST license-expression-30.2.0.gh.tar.gz 170391 BLAKE2B 38e934fa4c442b797be34b4431955bba5eae589247288f827753fdd167177839faac057448422fe1176127b0c96734c19c185c11814dc7d7765538b3d4184bd1 SHA512 13a9dea381088d95421aca8d096c54e9537bd0671000a21067257d01ced28a5c778bf8adff3d6e83ed89559ed62a0d08ccf98c88c0974c913b199f68d0a4336c | ||
DIST license-expression-30.3.0.gh.tar.gz 170159 BLAKE2B 6db3c9c3a1c6551fd22a338c74b75b595df5fe59fcde526baf2ddc52329b20cc4fd9848b986acc62709054c8d1f297879d0636e0c75ec30112cc654c41c7efec SHA512 10e141c9f7d05353ff2d76053497a72aebee6bbda6f263cb4fa69d1ab0ada8331bd0a126558b89bd7db428fc55a87bb5c88f1d5217cfb9640dbd10c1975bd08c |
34 changes: 34 additions & 0 deletions
34
dev-python/license-expression/license-expression-30.3.0.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,34 @@ | ||
# Copyright 2022-2024 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=8 | ||
|
||
DISTUTILS_USE_PEP517=setuptools | ||
PYTHON_COMPAT=( pypy3 python3_{10..12} ) | ||
|
||
inherit distutils-r1 | ||
|
||
DESCRIPTION="Parse, compare, simplify and normalize license expressions" | ||
HOMEPAGE=" | ||
https://pypi.org/project/license-expression/ | ||
https://github.com/nexB/license-expression/ | ||
" | ||
SRC_URI=" | ||
https://github.com/nexB/license-expression/archive/v${PV}.tar.gz | ||
-> ${P}.gh.tar.gz | ||
" | ||
|
||
LICENSE="Apache-2.0" | ||
SLOT="0" | ||
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86" | ||
|
||
RDEPEND=" | ||
>=dev-python/boolean-py-4.0[${PYTHON_USEDEP}] | ||
" | ||
BDEPEND=" | ||
>=dev-python/setuptools-scm-4[${PYTHON_USEDEP}] | ||
" | ||
|
||
distutils_enable_tests pytest | ||
|
||
export SETUPTOOLS_SCM_PRETEND_VERSION=${PV} |