forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
media-gfx/cura: version bump to 4.3.0
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Michael Perlov <[email protected]> Signed-off-by: Joonas Niilola <[email protected]>
- Loading branch information
Showing
2 changed files
with
54 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST cura-3.4.1.tar.gz 21720836 BLAKE2B 228ad51d189f83d2a34c2af7a6edcbe468bc32ee6ac012141eac1b7332046790e2e85c4e643c1ebb13ceded6024cd52aeab2bcd0db555db8f355a7b568bed728 SHA512 5d1935c923173a5ea6d3a95181d61c8deffbb51f3ee4f3e4cb2c5a58f79581d3dd9adc6a9583e6ca0ab5da4c36b63695d7479e67d1237c132354616aa990e3c1 | ||
DIST cura-3.6.0.tar.gz 23388945 BLAKE2B bd2f2e688306e7ef060141abae22c858e9fbb9385e49110079b48e69955c3f6630f8f69ad67fdf2d9e5c1ac0c969cd2d2f416642fc61a63867f79f88985c5c86 SHA512 b56e5575cb0eb15d759999dcd2f4c33873a0a57805a8ba0ec7860811a2137658a656216c969c6e3316d65fbd5e43f2def10a6385ccbf4fc306d15098569ef279 | ||
DIST cura-4.2.1.tar.gz 29288696 BLAKE2B 1332030e63d7056dcb8dd680208b0da8dd33e5c7809957779849bac808fccad9a222505ddbe80d4071474d10ace842aa4459f14560198a9f3eebb5be53f923e1 SHA512 4f47f3f5597d1a56d88207eacacece49edb766c75ae18ddc9fb8689b76c16fd4decc9c8af7cab485aac3c9cffe13095aaad34e1c60634249ae2923ead771ac52 | ||
DIST cura-4.3.0.tar.gz 30433646 BLAKE2B 8490d703cfd4ad07fd5b30d5f776d978baa17ad8751dad53870714596998becebc85cc2fe49fa05eab37b95106315ace97eaa0bbed65b488b522ebbbcba488dc SHA512 3f4ae11e4e28b151e9587c197f814bc97bc225fb2819f4dabaab392ef9896bb119d6fab0df48c9eb4a390a815815d27045eefa933e2e4a9d53331db8d79ea815 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,53 @@ | ||
# Copyright 1999-2019 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
PYTHON_COMPAT=( python3_{5,6} ) | ||
inherit cmake-utils desktop python-single-r1 xdg | ||
|
||
MY_PN=Cura | ||
|
||
DESCRIPTION="A 3D model slicing application for 3D printing" | ||
HOMEPAGE="https://github.com/Ultimaker/Cura" | ||
SRC_URI="https://github.com/Ultimaker/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz" | ||
|
||
LICENSE="LGPL-3" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="+usb zeroconf" | ||
REQUIRED_USE="${PYTHON_REQUIRED_USE}" | ||
|
||
BDEPEND="sys-devel/gettext" | ||
RDEPEND="${PYTHON_DEPS} | ||
>=dev-python/uranium-${PV:0:3}[${PYTHON_USEDEP}] | ||
>=media-gfx/curaengine-${PV:0:3} | ||
>=media-gfx/fdm-materials-${PV:0:3} | ||
>=dev-libs/libsavitar-${PV:0:3}:=[python,${PYTHON_USEDEP}] | ||
>=dev-libs/libcharon-${PV:0:3}[${PYTHON_USEDEP}] | ||
usb? ( dev-python/pyserial[${PYTHON_USEDEP}] ) | ||
zeroconf? ( dev-python/zeroconf[${PYTHON_USEDEP}] )" | ||
|
||
DEPEND="${RDEPEND}" | ||
|
||
DOCS=( README.md ) | ||
PATCHES=( "${FILESDIR}/${PN}-4.2.1-fix-install-paths.patch" ) | ||
S="${WORKDIR}/${MY_PN}-${PV}" | ||
|
||
src_prepare() { | ||
sed -i "s/set(CURA_VERSION \"master\"/set(CURA_VERSION \"${PV}\"/" CMakeLists.txt || die | ||
cmake-utils_src_prepare | ||
} | ||
|
||
src_configure() { | ||
local mycmakeargs=( | ||
-DPYTHON_SITE_PACKAGES_DIR="$(python_get_sitedir)" | ||
) | ||
cmake-utils_src_configure | ||
} | ||
|
||
src_install() { | ||
cmake-utils_src_install | ||
doicon icons/*.png | ||
python_optimize "${D}${get_libdir}" | ||
} |