forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Signed-off-by: Sebastian Pipping <[email protected]>
- Loading branch information
Showing
2 changed files
with
43 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST pychess-1.0.4.tar.gz 14553786 BLAKE2B 25855090d8d24f75ac519cc3f28f97c82229a72ca1e9c96bdb129271e487ff84b32fd644c953628c917bb2a1f5c71d3feaa18e10883cb207441ecf3c5119c64e SHA512 668fef78352f6aab9dabb3c061403dd7cad4db9b699d4f562820f0ae6732c337ba2aab789ad70c7e01eb3bd6f2602291afd43ddc25826f5f132b4e78b3dba4b4 | ||
DIST pychess-1.0.5.tar.gz 14543243 BLAKE2B 1ae3bf93e9f5ecf642c518ccaafe44068094276ed81c9d0b6f6346f94f56acc99359993d5cd75c1f7a20ff94bc3aa66e5c306361706ddcf946b3ea8fdd716513 SHA512 ac5f652706d50fe3c4cbf5d0f91531e6112c5f670de206434b02ded08b17921b5f11ec2d4842209d6d081a198d35cd235d7539f3c012aa6b7093d713aefc4951 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,42 @@ | ||
# Copyright 1999-2024 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=8 | ||
|
||
DISTUTILS_SINGLE_IMPL=1 | ||
DISTUTILS_USE_PEP517=setuptools | ||
PYTHON_COMPAT=( python3_{9..12} ) | ||
PYTHON_REQ_USE="sqlite" | ||
inherit distutils-r1 xdg | ||
|
||
DESCRIPTION="GTK chess client" | ||
HOMEPAGE="https://pychess.github.io/" | ||
SRC_URI="https://github.com/pychess/pychess/releases/download/${PV}/${P}.tar.gz" | ||
|
||
LICENSE="GPL-3" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~arm64 ~x86" | ||
IUSE="gstreamer" | ||
|
||
RDEPEND=" | ||
$(python_gen_cond_dep ' | ||
dev-python/pexpect[${PYTHON_USEDEP}] | ||
dev-python/psutil[${PYTHON_USEDEP}] | ||
dev-python/pycairo[${PYTHON_USEDEP}] | ||
dev-python/pygobject:3[${PYTHON_USEDEP},cairo] | ||
>=dev-python/sqlalchemy-2[${PYTHON_USEDEP},sqlite] | ||
dev-python/websockets[${PYTHON_USEDEP}] | ||
gstreamer? ( dev-python/gst-python:1.0[${PYTHON_USEDEP}] )') | ||
gnome-base/librsvg:2[introspection] | ||
x11-libs/gtk+:3[introspection] | ||
x11-libs/gtksourceview:3.0[introspection] | ||
x11-libs/pango[introspection] | ||
x11-themes/adwaita-icon-theme" | ||
BDEPEND="${RDEPEND}" # setup.py fails if introspection deps not found | ||
|
||
src_install() { | ||
distutils-r1_src_install | ||
|
||
# https://github.com/pychess/pychess/pull/1825 | ||
gunzip -v "${ED}"/usr/share/man/man1/${PN}.1.gz || die | ||
} |