Skip to content

Commit

Permalink
games-sports/speed-dreams: fix build w/newer glibc #580054
Browse files Browse the repository at this point in the history
  • Loading branch information
vapier committed Apr 20, 2016
1 parent 2141097 commit 23aeb75
Show file tree
Hide file tree
Showing 2 changed files with 28 additions and 1 deletion.
25 changes: 25 additions & 0 deletions games-sports/speed-dreams/files/speed-dreams-1.4.0-math-hack.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,25 @@
https://sourceforge.net/p/speed-dreams/tickets/952/
https://bugs.gentoo.org/580054

--- a/src/modules/simu/simuv2/simu.cpp
+++ b/src/modules/simu/simuv2/simu.cpp
@@ -61,7 +61,7 @@
if (isnan(car->ctrl->brakeCmd) || isinf(car->ctrl->brakeCmd)) car->ctrl->brakeCmd = 0;
if (isnan(car->ctrl->clutchCmd) || isinf(car->ctrl->clutchCmd)) car->ctrl->clutchCmd = 0;
if (isnan(car->ctrl->steer) || isinf(car->ctrl->steer)) car->ctrl->steer = 0;
- if (isnan(car->ctrl->gear) || isinf(car->ctrl->gear)) car->ctrl->gear = 0;
+ if (isnan((float)car->ctrl->gear) || isinf((float)car->ctrl->gear)) car->ctrl->gear = 0;
#else
if (isnan(car->ctrl->accelCmd)) car->ctrl->accelCmd = 0;
if (isnan(car->ctrl->brakeCmd)) car->ctrl->brakeCmd = 0;
--- a/src/modules/simu/simuv3/simu.cpp
+++ b/src/modules/simu/simuv3/simu.cpp
@@ -61,7 +61,7 @@
if (isnan(car->ctrl->brakeCmd) || isinf(car->ctrl->brakeCmd)) car->ctrl->brakeCmd = 0;
if (isnan(car->ctrl->clutchCmd) || isinf(car->ctrl->clutchCmd)) car->ctrl->clutchCmd = 0;
if (isnan(car->ctrl->steer) || isinf(car->ctrl->steer)) car->ctrl->steer = 0;
- if (isnan(car->ctrl->gear) || isinf(car->ctrl->gear)) car->ctrl->gear = 0;
+ if (isnan((float)car->ctrl->gear) || isinf((float)car->ctrl->gear)) car->ctrl->gear = 0;
#else
if (isnan(car->ctrl->accelCmd)) car->ctrl->accelCmd = 0;
if (isnan(car->ctrl->brakeCmd)) car->ctrl->brakeCmd = 0;
4 changes: 3 additions & 1 deletion games-sports/speed-dreams/speed-dreams-1.4.0.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -45,7 +45,8 @@ src_prepare() {
epatch \
"${FILESDIR}"/${P}-asneeded.patch \
"${FILESDIR}"/${P}-automake.patch \
"${FILESDIR}"/${P}-libpng15.patch
"${FILESDIR}"/${P}-libpng15.patch \
"${FILESDIR}"/${P}-math-hack.patch

sed -i \
-e '/ADDCFLAGS/s: -O2::' \
Expand All @@ -54,6 +55,7 @@ src_prepare() {
-e '/COPYING/s:=.*:= \\:' \
Makefile || die
sed -i \
-e '/LDFLAGS/s:-L/usr/lib::' \
-e "/^datadir/s:=.*:= ${GAMES_DATADIR}/${PN}:" \
Make-config.in || die

Expand Down

0 comments on commit 23aeb75

Please sign in to comment.