Skip to content

Commit

Permalink
dev-vcs/mercurial: Bump to version 4.4.1
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.13, Repoman-2.3.4
  • Loading branch information
Lars Wendler committed Nov 8, 2017
1 parent 0e45fce commit 244ab95
Show file tree
Hide file tree
Showing 2 changed files with 135 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-vcs/mercurial/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -3,3 +3,4 @@ DIST mercurial-4.1.3.tar.gz 5134965 SHA256 103d2ae187d5c94110c0e86ccc3b46f55fcd8
DIST mercurial-4.3.2.tar.gz 5491214 SHA256 0f5bf688ba2add6f5db98a633edef43411ecf2c7ada5f2e14b9265820a96cd48 SHA512 e69b7cff941d83531d59d91c30e336807f868302dfda565e1421b7d34c2769221220686774af236d86ac0f67dba6e8a0947ed1185b30d89463a8d211e20d1cbc WHIRLPOOL 079d05e75cde63ff907b485a45a6a9cf8b42001525a799939647d05dd60d85c1faa0cbf14b9da95488103ec9f0b177f59ad7d8bde93dca3ffe428d697669bd4e
DIST mercurial-4.3.3.tar.gz 5491634 SHA256 47a63c78698bc735667984bbc5b76619ff29a38d742f20cdf9f44cce59752374 SHA512 2d5249b6b2ec6b21c548702af2cf6b8e0858197a370514465aa7a880391f2e9efd6aecefb67fc547dfb8759c1c678009dc5a33fc48743bee30fcbdd853ee1cc6 WHIRLPOOL ef42493fdb4547a4e37d5f311cf5ac6fed90eb991d48ece6b2cbb3efe6722dec1513f044800cc58708c7a680eb1828c7888873b1849772e82901ad5d6d8a757d
DIST mercurial-4.3.tar.gz 5469979 SHA256 ebf11176e9b5354ec7a1bde6c5382c914d10c397410531faf89f8b5124a7cb65 SHA512 d74ae5f35d8c415c07737b59e6c5455963dfbf5d038c43d683fd34dd84423b9ccf9cd670667f458db20d8580fc7c7d9e5609d29d990e1e94683734694211c417 WHIRLPOOL 54583dbc826fdec3e737dc49d1a8ce180d29579d091c86e48a3b7c68bb4a2d399c5aff3b2ff0e30cd911e8955537a621c73c330d70a55f7efcdeafd21257178f
DIST mercurial-4.4.1.tar.gz 5636532 SHA256 8f2a5512d6cc2ffb08988aef639330a2f0378e4ac3ee0e1fbbdb64d9fff56246 SHA512 4c87adb6d3d30f7f9211eee64df727aefdac246be3ca9e3af412b76c32b76d701b19e00ca339168446ee5e20fad2ffc24f0c87438b6bda954560108235ab14a8 WHIRLPOOL f4fdfe28c4c5e6ac146429cc85d14fcd327fd22f8aed8383979bc16ea4a4fd64826d0ec7f78961f849a449e2cf611f6bf1672206f6c60264ab29c524eb07bb85
134 changes: 134 additions & 0 deletions dev-vcs/mercurial/mercurial-4.4.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,134 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

PYTHON_COMPAT=( python2_7 )
PYTHON_REQ_USE="threads"

inherit bash-completion-r1 elisp-common eutils distutils-r1 flag-o-matic

DESCRIPTION="Scalable distributed SCM"
HOMEPAGE="https://www.mercurial-scm.org/"
SRC_URI="https://www.mercurial-scm.org/release/${P}.tar.gz"

LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="bugzilla emacs gpg test tk"

RDEPEND="bugzilla? ( dev-python/mysql-python[${PYTHON_USEDEP}] )
gpg? ( app-crypt/gnupg )
tk? ( dev-lang/tk )
app-misc/ca-certificates"
DEPEND="emacs? ( virtual/emacs )
test? ( app-arch/unzip
dev-python/pygments[${PYTHON_USEDEP}] )"

SITEFILE="70${PN}-gentoo.el"

PATCHES=( "${FILESDIR}/${PN}-3.0.1-po_fixes.patch" )

python_prepare_all() {
# fix up logic that won't work in Gentoo Prefix (also won't outside in
# certain cases), bug #362891
sed -i -e 's:xcodebuild:nocodebuild:' setup.py || die

distutils-r1_python_prepare_all
}

python_configure_all() {
strip-flags -ftracer -ftree-vectorize
# Note: make it impl-conditional if py3 is supported
append-flags -fno-strict-aliasing

"${PYTHON}" setup.py build_mo || die
}

python_compile_all() {
rm -r contrib/{win32,macosx} || die
if use emacs; then
cd contrib || die
elisp-compile mercurial.el || die "elisp-compile failed!"
fi
}

python_install_all() {
distutils-r1_python_install_all

newbashcomp contrib/bash_completion hg

insinto /usr/share/zsh/site-functions
newins contrib/zsh_completion _hg

rm -f doc/*.?.txt
dodoc CONTRIBUTORS
cp hgweb*.cgi "${ED}"/usr/share/doc/${PF}/ || die

dobin hgeditor
dobin contrib/hgk
python_foreach_impl python_doscript contrib/hg-ssh

if use emacs; then
elisp-install ${PN} contrib/mercurial.el* || die "elisp-install failed!"
elisp-site-file-install "${FILESDIR}"/${SITEFILE}
fi

local RM_CONTRIB=(hgk hg-ssh bash_completion zsh_completion wix buildrpm plan9
*.el mercurial.spec)
for f in ${RM_CONTRIB[@]}; do
rm -r contrib/$f || die
done

dodoc -r contrib
docompress -x /usr/share/doc/${PF}/contrib
doman doc/*.?

insinto /etc/mercurial/hgrc.d
doins "${FILESDIR}/cacerts.rc"
}

src_test() {
pushd tests &>/dev/null || die
rm -rf *svn* # Subversion tests fail with 1.5
rm -f test-archive* # Fails due to verbose tar output changes
rm -f test-convert-baz* # GNU Arch baz
rm -f test-convert-cvs* # CVS
rm -f test-convert-darcs* # Darcs
rm -f test-convert-git* # git
rm -f test-convert-mtn* # monotone
rm -f test-convert-tla* # GNU Arch tla
#rm -f test-doctest* # doctest always fails with python 2.5.x
rm -f test-largefiles* # tends to time out

popd &>/dev/null || die
distutils-r1_src_test
}

python_test() {
local TEST_DIR

rm -rf "${TMPDIR}"/test
distutils_install_for_testing
cd tests || die
"${PYTHON}" run-tests.py --verbose \
--tmpdir="${TMPDIR}"/test \
--with-hg="${TEST_DIR}"/scripts/hg \
|| die "Tests fail with ${EPYTHON}"
}

pkg_postinst() {
use emacs && elisp-site-regen

elog "If you want to convert repositories from other tools using convert"
elog "extension please install correct tool:"
elog " dev-vcs/cvs"
elog " dev-vcs/darcs"
elog " dev-vcs/git"
elog " dev-vcs/monotone"
elog " dev-vcs/subversion"
}

pkg_postrm() {
use emacs && elisp-site-regen
}

0 comments on commit 244ab95

Please sign in to comment.