forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Signed-off-by: Sam James <[email protected]>
- Loading branch information
1 parent
fd2291e
commit 2b7dcc2
Showing
2 changed files
with
63 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST unrar-6.2.10.tar.gz 246383 BLAKE2B 6f7e7bf099f5a9de71c01b941c4cceaaf568709ac8b8e2f490f2f037c27adabc3bcde595e1330476f72204e6c5611e8c995c4c2842d9248731d876e67abc1086 SHA512 26e7febc4e62bcace7aa36e05d5341ab57813cc0c224c6a924ca909828879b0172d2cea9ab6cfdfe4bc3b51d49feb48f46df3874fa6f070f6062a15e1020271d | ||
DIST unrar-6.2.12.tar.gz 246918 BLAKE2B 3c7744ee5839b4d87362625a03f30e3cac3d74df988479692023b9c242c136044666ebf0470197b28b95171dae076faecf815ef50caffb747185b8433707612c SHA512 261ac3728f917f36a03c7c3c563d7775abdb06b598ab48a299d837e8fc0ca75ad885ec8e292aeb1775e87e775ed274e9e0f033001598229ec96db69d69824ddb | ||
DIST unrar-6.2.8.tar.gz 246249 BLAKE2B 3766f7ebd0379835cff7cce8bb2deaf86d3de7c4a37d211d8a41effeb13a5a9efc53deabb5f10cd7f49d8e144cd9c1a93cce2ca3ae74e8a2142ab3ae97ab4759 SHA512 9b956d0c4b6a13f9ff4d9e57de7284dc879070746e3792e7640481a5b5b8336142b21c4d0c66c64627630cafbed0ff019a41b8f8536299ac7cbfdb933f92f75a | ||
DIST unrar-6.2.9.tar.gz 246388 BLAKE2B 495af1b78d2213c6bac0e75462b3d5e9fc3bfea809bcbb672216da47cd483bcc5867b504358125c51147a0e1869568c8a822946ca8148f204eeb087671029d9d SHA512 80424348946a56b47c107b2cd78c8bc7ce7f223a4d923b137860ec50678c4f279114dd7cdc9eb6a2fa6ff8c8a059ab8d35e16e3feae9dd1433fe51479501b61c |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,62 @@ | ||
# Copyright 1999-2023 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=8 | ||
|
||
inherit multilib toolchain-funcs | ||
|
||
MY_PN="${PN}src" | ||
|
||
DESCRIPTION="Uncompress rar files" | ||
HOMEPAGE="https://www.rarlab.com/rar_add.htm" | ||
SRC_URI="https://www.rarlab.com/rar/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz" | ||
S="${WORKDIR}/unrar" | ||
|
||
LICENSE="unRAR" | ||
SLOT="0/6" # subslot = soname version | ||
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos" | ||
|
||
PATCHES=( "${FILESDIR}/${PN}-6.2.6-honor-flags.patch" ) | ||
|
||
src_prepare() { | ||
default | ||
|
||
local sed_args=( -e "/libunrar/s:.so:$(get_libname ${PV%.*.*}):" ) | ||
if [[ ${CHOST} == *-darwin* ]] ; then | ||
sed_args+=( -e "s:-shared:-dynamiclib -install_name ${EPREFIX}/usr/$(get_libdir)/libunrar$(get_libname ${PV%.*.*}):" ) | ||
else | ||
sed_args+=( -e "s:-shared:& -Wl,-soname -Wl,libunrar$(get_libname ${PV%.*.*}):" ) | ||
fi | ||
sed -i "${sed_args[@]}" makefile || die | ||
} | ||
|
||
src_configure() { | ||
mkdir -p build-{lib,bin} || die | ||
printf 'VPATH = ..\ninclude ../makefile' > build-lib/Makefile || die | ||
cp build-{lib,bin}/Makefile || die | ||
} | ||
|
||
src_compile() { | ||
unrar_make() { | ||
emake AR="$(tc-getAR)" CXX="$(tc-getCXX)" CXXFLAGS="${CXXFLAGS}" STRIP=true "$@" | ||
} | ||
|
||
unrar_make CXXFLAGS+=" -fPIC" -C build-lib lib | ||
ln -s libunrar$(get_libname ${PV%.*.*}) build-lib/libunrar$(get_libname) || die | ||
ln -s libunrar$(get_libname ${PV%.*.*}) build-lib/libunrar$(get_libname ${PV}) || die | ||
|
||
unrar_make -C build-bin | ||
} | ||
|
||
src_install() { | ||
dobin build-bin/unrar | ||
dodoc readme.txt | ||
|
||
dolib.so build-lib/libunrar* | ||
|
||
insinto /usr/include/libunrar${PV%.*.*} | ||
doins *.hpp | ||
dosym libunrar${PV%.*.*} /usr/include/libunrar | ||
|
||
find "${ED}" -type f -name "*.a" -delete || die | ||
} |