Skip to content

Commit

Permalink
app-emulation/runc: Use full commit hash
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.28, Repoman-2.3.9
  • Loading branch information
mrueg committed Apr 6, 2018
1 parent c04e049 commit 338877c
Showing 1 changed file with 54 additions and 0 deletions.
54 changes: 54 additions & 0 deletions app-emulation/runc/runc-1.0.0_rc5-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,54 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
EGO_PN="github.com/opencontainers/${PN}"

if [[ ${PV} == *9999 ]]; then
inherit golang-build golang-vcs
else
MY_PV="${PV/_/-}"
EGIT_COMMIT="v${MY_PV}"
RUNC_COMMIT="4fc53a81fb7c994640722ac585fa9ca548971871" # Change this when you update the ebuild
SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm ~ppc64"
inherit golang-build golang-vcs-snapshot
fi

DESCRIPTION="runc container cli tools"
HOMEPAGE="http://runc.io"

LICENSE="Apache-2.0"
SLOT="0"
IUSE="+ambient apparmor hardened +seccomp"

RDEPEND="
apparmor? ( sys-libs/libapparmor )
seccomp? ( sys-libs/libseccomp )
!app-emulation/docker-runc
"

src_compile() {
# Taken from app-emulation/docker-1.7.0-r1
export CGO_CFLAGS="-I${ROOT}/usr/include"
export CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')
-L${ROOT}/usr/$(get_libdir)"

# build up optional flags
local options=(
$(usex ambient 'ambient')
$(usex apparmor 'apparmor')
$(usex seccomp 'seccomp')
)

GOPATH="${S}"\
emake BUILDTAGS="${options[*]}" \
COMMIT="${RUNC_COMMIT}" -C src/${EGO_PN}
}

src_install() {
pushd src/${EGO_PN} || die
dobin runc
dodoc README.md PRINCIPLES.md
popd || die
}

0 comments on commit 338877c

Please sign in to comment.