Skip to content

Commit

Permalink
games-action/xblast: remove deprecated games eclass
Browse files Browse the repository at this point in the history
Also update to EAPI 6

Gentoo-Bug: https://bugs.gentoo.org/574082

Package-Manager: Portage-2.3.2, Repoman-2.3.1
  • Loading branch information
austin987 committed Jan 31, 2017
1 parent b88f193 commit 3e08015
Showing 1 changed file with 71 additions and 0 deletions.
71 changes: 71 additions & 0 deletions games-action/xblast/xblast-2.10.4-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,71 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6
inherit autotools

# Change these as releases changes
IMAGES="images-2005-01-06"
LEVELS="levels-2005-01-06"
MODELS="models-2005-01-06"
MUSICS="musics-2005-01-06"
SOUNDS="sounds"

DESCRIPTION="Bomberman clone w/network support for up to 6 players"
HOMEPAGE="http://xblast.sourceforge.net/"
SRC_URI="mirror://sourceforge/xblast/${P}.tar.gz
mirror://sourceforge/xblast/${IMAGES}.tar.gz
mirror://sourceforge/xblast/${LEVELS}.tar.gz
mirror://sourceforge/xblast/${MODELS}.tar.gz
mirror://sourceforge/xblast/${MUSICS}.tar.gz
mirror://sourceforge/xblast/${SOUNDS}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""

RDEPEND="
media-libs/libpng:0
x11-libs/libICE
x11-libs/libX11"
DEPEND="${RDEPEND}
x11-libs/libXt"

src_prepare() {
default

eautoreconf #255857
}

src_configure() {
econf \
--with-otherdatadir=/usr/share/${PN} \
--enable-sound
}

src_install() {
local IMAGE_INSTALL_DIR="/usr/share/${PN}/image"

default

# Images
dodir "${IMAGE_INSTALL_DIR}"
cp -pPR "${WORKDIR}/${IMAGES}"/* "${D}/${IMAGE_INSTALL_DIR}" || die

# Levels
insinto "$/usr/share/${PN}/level"
doins "${WORKDIR}/${LEVELS}"/*

# Models
insinto "/usr/share/${PN}/image/sprite"
doins "${WORKDIR}/${MODELS}"/*

# Music and sound
insinto "/usr/share/${PN}/sounds"
doins "${WORKDIR}/${MUSICS}"/* "${WORKDIR}/${SOUNDS}"/*

# Cleanup
find "${D}" -name Imakefile -exec rm \{\} \;
}

0 comments on commit 3e08015

Please sign in to comment.