forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Signed-off-by: Matthew Thode <[email protected]>
- Loading branch information
1 parent
3b451f1
commit 4ab67f8
Showing
2 changed files
with
59 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST tgt-1.0.88.tar.gz 305767 BLAKE2B d9a35da5c12ba1621473a04f59ffc85364412443854e4b9d88ba7ae7a7120dbbf6cf233852ef33cca2f19bb67acd54dcdd97041812277cc7eb9359d2483289d4 SHA512 b1ac4da634ff65edfd67cfcbd4509772216ba411b8c389cd209d3abe7c72b19f8e261c627e3ad8343faeebe3d8b758855184b50ab9e635d11c707ba3bb79fe70 | ||
DIST tgt-1.0.89.tar.gz 305773 BLAKE2B c128e307246c938ee9b41fa9d0783cfa488e103f38c8907768bc46ec46dfc6fa7b8aad5e14f43dfd111a5b6590b41ce6cf77683c2dc123ab5917f89e7c3d951c SHA512 4a3f2e1e2a9e98fbb6892fb8171633efd15ce131f0e9294d95a7d8b23b6df739f11529e50ed03869d65a8a84a57f7337901f36e010a770a051caaa7ba2b47e7a | ||
DIST tgt-1.0.90.tar.gz 305964 BLAKE2B ee8696013af85e9171dae09501502dbdc26e72568ff55d5c4867a7122baabf39d034e648a2d09c23b31563aea844129397c8ca803caca5d8fa59e3f73b4cbf34 SHA512 5fe0a1d25f60d80d840432ed74d906b45bad6f11274ec580e8844ee802008cf09f2086b39e0d868868e65d314221d48057c1473a11488eb8cabc7b05ee03dbbb | ||
DIST tgt-1.0.91.tar.gz 305813 BLAKE2B 8ab714ff6ce29ead7800a2538241ed93e3c363881c0d37009bf7074063ff88daa25969cb5ebcac2ac55ec475cd02756656c82bfaa855da88569f0b577034a8c0 SHA512 ea3a2d82c2533267a58b52d8db7cd8576447f1713ce5431955d2871272976b0e1c155c27c28e0bbf29b75b3e3a9fcf608e1fc1ce9ebeb558ae0219b0be2b5ad5 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,58 @@ | ||
# Copyright 1999-2024 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
inherit toolchain-funcs systemd | ||
|
||
DESCRIPTION="Linux SCSI target framework (tgt)" | ||
HOMEPAGE="https://github.com/fujita/tgt" | ||
SRC_URI="https://github.com/fujita/tgt/archive/v${PV}.tar.gz -> ${P}.tar.gz" | ||
|
||
LICENSE="GPL-2" | ||
SLOT="0" | ||
KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~ia64 ~loong ~ppc ppc64 ~riscv ~sparc x86" | ||
IUSE="infiniband rbd selinux" | ||
|
||
DEPEND=" | ||
app-text/docbook-xsl-stylesheets | ||
dev-libs/libxslt | ||
dev-perl/Config-General | ||
rbd? ( sys-cluster/ceph ) | ||
infiniband? ( sys-cluster/rdma-core ) | ||
" | ||
RDEPEND=" | ||
${DEPEND} | ||
dev-libs/libaio | ||
sys-apps/sg3_utils | ||
selinux? ( sec-policy/selinux-tgtd ) | ||
" | ||
|
||
pkg_setup() { | ||
tc-export CC | ||
} | ||
|
||
src_prepare() { | ||
default | ||
sed -i -e 's:\($(CC)\) $^:\1 $(LDFLAGS) $^:' usr/Makefile || die | ||
# make sure xml docs are generated before trying to install them | ||
sed -i -e "s@install: @& all @g" doc/Makefile || die | ||
sed -i -e 's|-Werror||g' usr/Makefile || die | ||
} | ||
|
||
src_compile() { | ||
local myconf | ||
use infiniband && myconf="${myconf} ISCSI_RDMA=1" | ||
use rbd && myconf="${myconf} CEPH_RBD=1" | ||
|
||
emake -C usr/ KERNELSRC="${KERNEL_DIR}" ISCSI=1 ${myconf} | ||
emake -C doc | ||
} | ||
|
||
src_install() { | ||
emake install-programs install-scripts install-doc DESTDIR="${D}" docdir=/usr/share/doc/${PF} | ||
newinitd "${FILESDIR}"/tgtd.initd-new tgtd | ||
newconfd "${FILESDIR}"/tgtd.confd-new tgtd | ||
systemd_dounit "${S}"/scripts/tgtd.service | ||
dodir /etc/tgt | ||
keepdir /etc/tgt | ||
} |