Skip to content

Commit

Permalink
sci-mathematics/fricas: bump to 1.3.3
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.19, Repoman-2.3.6
  • Loading branch information
Andrey Grozin committed Mar 13, 2018
1 parent 601b58b commit 55c1976
Show file tree
Hide file tree
Showing 2 changed files with 103 additions and 0 deletions.
1 change: 1 addition & 0 deletions sci-mathematics/fricas/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST fricas-1.3.0-full.tar.bz2 10459788 BLAKE2B 93f57290fa17b25688454fba3f54bbc6de7aaf4e336fcd3117011a49a2d8705c3df07f1dd79472f7fe879bc8f2087c65eca6638229156e15b51534c5f054e09b SHA512 fd084c3d3ada76424b0159eff76660872da63c1e25f392d98bc7175b37c05fe23a117587addc89828ff38a368f5161d34febcc269f530710ff7da6b53860653f
DIST fricas-1.3.1-full.tar.bz2 10522387 BLAKE2B c1315bbb30ac94fe2b1b612a053f378f7d044111ba8d0405fd35e80902cd269b515f61d184b025b707b01d74aed26bf093e9af166b8b4f10d50e2ce0357d26b2 SHA512 d492686fc03ed704cc015ec0ba250ab7928b637ff6ef8cf1aa924190e7fe22bd63a512074439dbf7ce44dce786d51ad5e27857522a1e21136b4b8d6cf014c486
DIST fricas-1.3.2-full.tar.bz2 10523665 BLAKE2B 23de3147177e7c3c75dafa6de0f4f17432f323512aa38aef85e27c8cf1b9e335009870dc608219f0e1c4f53f1790a41b00b915aedd71633459f789cfda9f5244 SHA512 679dffbe8a991d4ae3d6667a6163337ffa24d48b9d1d776ba1a39569cb3b9f17e8d484075746b75b7eb6bbe5b9d26af3e526850a19118274988b9e88ad52a679
DIST fricas-1.3.3-full.tar.bz2 10506559 BLAKE2B 1a9822f0a94db5c7e7a3e2a52287b475c382caaaf9c5e1830621a17b6634f6f72958f0c81995463d135b4567a74c588f33c88d51a83b0a8749479d65645de4bc SHA512 74ac88ffbbacba33883498a75382ef351003ce8499f6b458367ca0de3041a9bba496693eb90f798945aa6e11c5072137227efa385ee6d8e2051f93dfea6d7fbe
102 changes: 102 additions & 0 deletions sci-mathematics/fricas/fricas-1.3.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,102 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
inherit multilib elisp-common

DESCRIPTION="FriCAS is a fork of Axiom computer algebra system"
HOMEPAGE="http://${PN}.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}-full.tar.bz2"
LICENSE="BSD-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"

# Supported lisps, number 0 is the default
LISPS=( sbcl cmucl gcl ecls clisp clozurecl )
# Version restrictions, . means no restrictions
REST=( . . . . . . )
# command name: . means just ${LISP}
COMS=( . lisp . ecl . ccl )

IUSE="${LISPS[*]} X emacs gmp"
RDEPEND="X? ( x11-libs/libXpm x11-libs/libICE )
emacs? ( virtual/emacs )
gmp? ( dev-libs/gmp:= )"

# Generating lisp deps
n=${#LISPS[*]}
for ((n--; n > 0; n--)); do
LISP=${LISPS[$n]}
if [ "${REST[$n]}" = "." ]; then
DEP="dev-lisp/${LISP}"
else
DEP="${REST[$n]}"
fi
RDEPEND="${RDEPEND} ${LISP}? ( ${DEP}:= ) !${LISP}? ("
done
if [ "${REST[0]}" = "." ]; then
DEP="dev-lisp/${LISPS[0]}"
else
DEP="${REST[0]}"
fi
RDEPEND="${RDEPEND} ${DEP}:="
n=${#LISPS[*]}
for ((n--; n > 0; n--)); do
RDEPEND="${RDEPEND} )"
done

DEPEND="${RDEPEND}"

# necessary for clisp and gcl
RESTRICT="strip"

src_configure() {
local LISP n
LISP=sbcl
n=${#LISPS[*]}
for ((n--; n > 0; n--)); do
if use ${LISPS[$n]}; then
LISP=${COMS[$n]}
if [ "${LISP}" = "." ]; then
LISP=${LISPS[$n]}
fi
fi
done
einfo "Using lisp: ${LISP}"

# aldor is not yet in portage
econf --disable-aldor --with-lisp=${LISP} $(use_with X x) $(use_with gmp)
}

src_compile() {
# bug #300132
emake -j1
}

src_test() {
emake -j1 all-input
}

src_install() {
emake -j1 DESTDIR="${D}" install
dodoc README FAQ

if use emacs; then
sed -e "s|(setq load-path (cons (quote \"/usr/$(get_libdir)/fricas/emacs\") load-path)) ||" \
-i "${D}"/usr/bin/efricas \
|| die "sed efricas failed"
elisp-install ${PN} "${D}"/usr/$(get_libdir)/${PN}/emacs/*.el
elisp-site-file-install "${FILESDIR}"/64${PN}-gentoo.el
else
rm "${D}"/usr/bin/efricas || die "rm efricas failed"
fi
rm -r "${D}"/usr/$(get_libdir)/${PN}/emacs || die "rm -r emacs failed"
}

pkg_postinst() {
use emacs && elisp-site-regen
}

pkg_postrm() {
use emacs && elisp-site-regen
}

0 comments on commit 55c1976

Please sign in to comment.