Skip to content

Commit

Permalink
games-emulation/dosbox-staging: 0.75.1 bump
Browse files Browse the repository at this point in the history
Also fix compilation with USE=-alsa

Closes: https://bugs.gentoo.org/736234
Package-Manager: Portage-3.0.4, Repoman-3.0.1
Signed-off-by: Bernard Cafarelli <[email protected]>
  • Loading branch information
voyageur committed Aug 20, 2020
1 parent 4b34462 commit 5b94739
Show file tree
Hide file tree
Showing 3 changed files with 61 additions and 0 deletions.
1 change: 1 addition & 0 deletions games-emulation/dosbox-staging/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST dosbox-staging-0.75.0.tar.gz 1805354 BLAKE2B e376006a2c3890d98efdaa8041634bfca8b95f6c6471f36f8fdd53e319aad8d37f20bd195a20264bade1e6974327f1f888dec6050da493fc8a6e6bb6c5739150 SHA512 2e049ed44928ad4adeaca73d328cf8f415bcb8c1a399306b1e8a5fd2b7cd7c3d3fe10017b47e5d2f3e54c34042ee901b98486f5b47a3d2eaf43f4e13891f8b70
DIST dosbox-staging-0.75.1.tar.gz 1806471 BLAKE2B 5f9f8038327eb46c2c2b5035ca8e2cc93660bb6ce1dfa9572bf67278f14455db723104c0ab4e90b805cc7dbf253f61528ad6a31edb574af57e106f613958aede SHA512 3e14354e4eb697514c4348af2e73e9f2fb84cc3796b5cfea37faac355bd93a54b0f9c717bf0ab75d824cf34e3ee0d40546e2bbf80bc924a37bd8f981f054e4e9
49 changes: 49 additions & 0 deletions games-emulation/dosbox-staging/dosbox-staging-0.75.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,49 @@
# Copyright 2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
inherit autotools desktop

DESCRIPTION="Modernized DOSBox soft-fork"
HOMEPAGE="https://dosbox-staging.github.io/"
SRC_URI="https://github.com/dosbox-staging/dosbox-staging/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="alsa debug dynrec opengl opus"

RDEPEND="alsa? ( media-libs/alsa-lib )
debug? ( sys-libs/ncurses:0= )
opengl? ( virtual/opengl )
opus? ( media-libs/opusfile )
media-libs/libpng:0=
media-libs/libsdl2[joystick,opengl?,video,X]
media-libs/sdl-net
sys-libs/zlib
!games-emulation/dosbox"
DEPEND="${RDEPEND}"
BDEPEND=""

PATCHES=( "${FILESDIR}"/${P}-pthread.patch )

src_prepare() {
default
eautoreconf
}

src_configure() {
econf \
$(use_enable alsa alsa-midi) \
$(use_enable debug) \
$(use_enable !dynrec dynamic-x86) \
$(use_enable dynrec) \
$(use_enable opengl) \
$(use_enable opus opus-cdda)
}

src_install() {
default
doicon contrib/icons/${PN}.svg
make_desktop_entry dosbox DOSBox-staging ${PN}
}
Original file line number Diff line number Diff line change
@@ -0,0 +1,11 @@
--- dosbox-staging-0.75.1/configure.ac.orig 2020-08-20 14:25:41.295432272 +0200
+++ dosbox-staging-0.75.1/configure.ac 2020-08-20 14:26:00.614461707 +0200
@@ -37,7 +37,7 @@
:,
AC_MSG_ERROR([*** SDL version $SDL_VERSION not found!])
)
-LIBS="$LIBS $SDL_LIBS"
+LIBS="$LIBS -lpthread $SDL_LIBS"
CPPFLAGS="$CPPFLAGS $SDL_CFLAGS"

dnl Checks for header files.

0 comments on commit 5b94739

Please sign in to comment.