Skip to content

Commit

Permalink
games-emulation/mednafen-jg: add 1.32.1
Browse files Browse the repository at this point in the history
Signed-off-by: orbea <[email protected]>
Signed-off-by: Joonas Niilola <[email protected]>
  • Loading branch information
orbea authored and juippis committed Apr 29, 2024
1 parent 52e1c00 commit 625db2b
Show file tree
Hide file tree
Showing 2 changed files with 69 additions and 0 deletions.
1 change: 1 addition & 0 deletions games-emulation/mednafen-jg/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST mednafen-1.31.0.tar.bz2 4400375 BLAKE2B 691d449f55cf2702bdeed06470a1e56507ee09407929e1d742996f54212146a2cdd96e6e31a30ca8d94e807ea95c3a2766297df0f0a38e9c1d28e6615705b536 SHA512 908bdd717b916066f3fca46019fa70c789adf0b159250d3ea3b485ca30c8e41e1b86274bf857530943189461ec8165dcd5242456cbf2e259341731af33f00dfa
DIST mednafen-1.32.0.tar.bz2 4427616 BLAKE2B 71a210de8fc3de9169c1f839b942ccf83adeca66863868db4eaba1290c31eb874c7a941a19b5d7ae79464f505e785c5c45949f497b1ba5fc98449dcecad19b47 SHA512 9f4b4afa493c4f08c7c6d6867f58f267f60e1d9c7a341f187c8f7b048a894e532f507a484d2bf12e68156625388923e7091e555c43ef0dd5547e644c8a8c4fea
DIST mednafen-1.32.1.tar.bz2 4428510 BLAKE2B b85ef506e9d0f76b08469f12dc1f57e0cdb789c9b36b50ad03ed1dbbc9640e2109a37f639acb5d9f7f8d17f97f9aca97700c75ffcfcd53c3a8098fb7f0d3d128 SHA512 1cbf88a3f95ead46cd4e106a701e7adefd54cd1869394e6e907f89370ba434b3999d8a5372e5f2ded43135716aed739fb5313f680687de20f1c4b8e74af54b60
68 changes: 68 additions & 0 deletions games-emulation/mednafen-jg/mednafen-jg-1.32.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,68 @@
# Copyright 2022-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit autotools toolchain-funcs

MY_PN=${PN%-*}
MY_P=${MY_PN}-${PV}
DESCRIPTION="Jolly Good Port of Mednafen"
HOMEPAGE="https://gitlab.com/jgemu/mednafen"
if [[ "${PV}" == *9999 ]] ; then
inherit git-r3
EGIT_REPO_URI="https://gitlab.com/jgemu/${MY_PN}.git"
else
SRC_URI="https://gitlab.com/jgemu/${MY_PN}/-/archive/${PV}/${MY_P}.tar.bz2"
S="${WORKDIR}/${MY_P}"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
fi

LICENSE="BSD GPL-2 GPL-2+ LGPL-2.1+ ZLIB"
SLOT="1"
IUSE="cpu_flags_x86_avx"

DEPEND="
app-arch/zstd
dev-libs/lzo:2
>=dev-libs/trio-1.17
media-libs/flac
media-libs/jg:1=
sys-libs/zlib:=[minizip]
"
RDEPEND="
${DEPEND}
games-emulation/jgrf
"
BDEPEND="
virtual/pkgconfig
"

src_prepare() {
default

cd jollygood/conf || die
eautoreconf
}

src_configure() {
cd jollygood/conf || die
econf $(use_enable cpu_flags_x86_avx avx)
}

src_compile() {
emake -C jollygood \
CC="$(tc-getCC)" \
CXX="$(tc-getCXX)" \
PKG_CONFIG="$(tc-getPKG_CONFIG)" \
USE_EXTERNAL_TRIO=1
}

src_install() {
emake -C jollygood install \
DESTDIR="${D}" \
PREFIX="${EPREFIX}"/usr \
DOCDIR="${EPREFIX}"/usr/share/doc/${PF} \
LIBDIR="${EPREFIX}/usr/$(get_libdir)" \
USE_EXTERNAL_TRIO=1
}

0 comments on commit 625db2b

Please sign in to comment.