forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-editors/scite: Version bump to 4.4.4
Actual enhancements and upstream bugfixes. See http://www.scintilla.org/ScintillaHistory.html Signed-off-by: Ervin Peters <[email protected]> Package-Manager: Portage-2.3.103, Repoman-2.3.23 Closes: gentoo#17080 Signed-off-by: Joonas Niilola <[email protected]>
- Loading branch information
1 parent
dbe0cbd
commit 68824c1
Showing
2 changed files
with
116 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST scite-4.2.1.tgz 2633438 BLAKE2B cddf23f60eb1791266e38eba03ed8708aa02e0d91470344b19bfad7519930691a4b6a79b1eed3ac06234509b20fbd6b299c13c48a6990e0d8ced1a99a1d01220 SHA512 b2ad499f1c4d1a15b009516d24186c7d84f48ccdd40d2e9ca614de3cf36725a710523beaacda499186f040869e87339c2292e23eec959c2cdaa5fedfbb94d565 | ||
DIST scite-4.3.3.tgz 2714086 BLAKE2B f31db7147c102ea19317d5a0bfb64e2ccd34914a8b615cd6c02f2e79f1788433dd3ecd6a565599d43a0c4da34ac30e9434037a042d77170f14969d3b008a742f SHA512 85bc76bc9bb817fb0f7ddecad5e01d83d7090e788c2f74b9b23a86284f452a62c2fed64d0cf7c24cb57043228b8c91212742b644756d2ab185b10ead8785b82b | ||
DIST scite-4.4.4.tgz 2775628 BLAKE2B a7607b53bf529c56f6525d44b052a08c914d8aa1d90d475dcf46927ac5ce83c06d68b70e8d8e8969c77c367240ba1e7ac10d599c77002575e84b9baf6445d03b SHA512 1e8529286206d542e0c07353b73ab38aa9ee2e2256ed8e15328965e00a33eb026f79bd7d330253e8743cf5503fadb32c64162973ad21da16993f11e124842ec0 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,115 @@ | ||
# Copyright 1999-2020 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
inherit toolchain-funcs xdg-utils | ||
|
||
DESCRIPTION="A very powerful, highly configurable, small editor with syntax coloring" | ||
HOMEPAGE="https://www.scintilla.org/SciTE.html" | ||
SRC_URI="https://www.scintilla.org/${PN}${PV//./}.tgz -> ${P}.tgz" | ||
|
||
LICENSE="HPND lua? ( MIT )" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~arm-linux ~x86-linux" | ||
IUSE="lua" | ||
|
||
RDEPEND=" | ||
dev-libs/glib:2 | ||
x11-libs/cairo | ||
x11-libs/gdk-pixbuf | ||
x11-libs/gtk+:3 | ||
x11-libs/pango | ||
lua? ( >=dev-lang/lua-5:= )" | ||
|
||
DEPEND="${RDEPEND}" | ||
|
||
BDEPEND=" | ||
virtual/pkgconfig" | ||
|
||
DOCS=("../README") | ||
|
||
S="${WORKDIR}/${PN}/gtk" | ||
|
||
pkg_pretend() { | ||
if tc-is-clang ; then | ||
# need c++17 features | ||
[[ "${MERGE_TYPE}" != "binary" && | ||
$(clang-major-version) -lt 5 ]] && | ||
die "Sorry, SCiTE uses C++17 Features and needs >sys-devel/clang-5 | ||
($(clang-major-version))." | ||
|
||
elif tc-is-gcc; then | ||
# older gcc is not supported | ||
[[ "${MERGE_TYPE}" != "binary" && | ||
$(gcc-major-version) -lt 7 ]] && | ||
die "Sorry, Scite uses C++17 Features, need >sys-devel/gcc-7." | ||
else | ||
die "Either gcc or clang should be configured for building scite" | ||
fi | ||
} | ||
|
||
src_prepare() { | ||
tc-export AR CC CXX RANLIB | ||
|
||
# remove hardcoded CC, Optimizations and clang unknown flags | ||
sed -i "${WORKDIR}/scintilla/gtk/makefile" \ | ||
-e "s#^CC = gcc#CC = ${CC}#" \ | ||
-e "s#^CC = clang#CC = ${CC}#" \ | ||
-e "s#^CXX = clang++#CXX = ${CXX}#" \ | ||
-e "s#-Os##" \ | ||
-e "s#-Wno-misleading-indentation##" \ | ||
|| die "error patching /scintilla/gtk/makefile" | ||
|
||
sed -i "${S}/makefile" \ | ||
-e "s#^CC = clang#CC = ${CC}#" \ | ||
-e "s#^CXX = clang++#CXX = ${CXX}#" \ | ||
-e "s#-rdynamic#-rdynamic ${LDFLAGS}#" \ | ||
-e "s#-Os##" \ | ||
|| die "error patching gtk/makefile" | ||
|
||
# repair and enhance the .desktop file | ||
sed -i "${S}/SciTE.desktop" \ | ||
-e "s#text/plain#text/\*;application/xhtml+xml#" \ | ||
-e "s#^Categories=\(.*\)#Categories=Development;#" \ | ||
|| die "error patching /scite/gtk/SciTe.desktop" | ||
|
||
# add the ebuild suffix as shell type for working with ebuilds | ||
sed -i "${WORKDIR}/scite/src/perl.properties" \ | ||
-e "s#\*.sh;\*.bsh;#\*.ebuild;\*.sh;\*.bsh;#" \ | ||
|| die "error patching /scite/src/perl.properties" | ||
|
||
# it seems that pwd here is ${S}, but user patches are relative to ${workdir} | ||
# Bug #576162 | ||
|
||
cd "${WORKDIR}" || die "couldn't cd into ${WORKDIR}" | ||
eapply_user | ||
} | ||
|
||
src_compile() { | ||
# prepare make options | ||
local emake_pars=("GTK3=1") | ||
|
||
tc-is-clang && emake_pars+=("CLANG=1") | ||
use !lua && emake_pars+=("NO_LUA=1") | ||
|
||
emake -C "${WORKDIR}/scintilla/gtk" "${emake_pars[@]}" | ||
emake "${emake_pars[@]}" | ||
} | ||
|
||
# want to use the base src_install() as base_src_install() | ||
|
||
src_install() { | ||
default | ||
dosym SciTE /usr/bin/scite | ||
} | ||
|
||
pkg_postinst() { | ||
xdg_icon_cache_update | ||
xdg_desktop_database_update | ||
} | ||
|
||
pkg_postrm() { | ||
xdg_icon_cache_update | ||
xdg_desktop_database_update | ||
} |