Skip to content

Commit

Permalink
net-irc/soju: add 0.6.1
Browse files Browse the repository at this point in the history
Signed-off-by: Alfred Persson Forsberg <[email protected]>
Closes: gentoo#30753
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
alfredfo authored and thesamesam committed Apr 26, 2023
1 parent 1497dac commit 6a8d0b8
Show file tree
Hide file tree
Showing 2 changed files with 65 additions and 0 deletions.
2 changes: 2 additions & 0 deletions net-irc/soju/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,4 @@
DIST soju-0.6.0-deps.tar.xz 146900140 BLAKE2B 0ecf3844694a6d2dbb8f90fbb44c87e6918c4502960356cbf7c7f12103ba2134257b9d0bfcce673352c256b9aa367368c280991069913f3764f916af731d4d21 SHA512 ccaf6cde616114a8afb9f7c2f41a816c458f685d7895cbb47a36135e5f1b12e39580ce81973ee9a5d61f3efb603e71f40820abd515dfb9bbbb539163f140cd25
DIST soju-0.6.0.tar.gz 161364 BLAKE2B c8dcf2d8355f90e362f5f1cd5f5f2bb2ab84dce0dbbd07be3d3b492d944f5d8aa35d93038e2d1134f285e248c8bd8b4e83eab27a959bcefcc38198a3de24a4cd SHA512 99e80a82c3ceda6567524bb4b7aab74095b0c4b18d1f268b84e4173770f3ded26bba5092f3adf105c90c28bffd86001801c0bad9f57fd2a3302bb816b77ac423
DIST soju-0.6.1-deps.tar.xz 147239188 BLAKE2B c76cce444d78f6e1efa92835211af6b3e955f1960103e9b62e8a46f69015ba269ec3142822f726c67ab2d695d44395e7029991b5e229ca46a66d61144b345e3b SHA512 c02cc46c22cc396f7ee56a94376674ec0cc543e7105278c4649ae8d0a0df9d73bbdb0d94add0b402be02fb37511b60a2f03aeebbfe9382928e2bb99221da345d
DIST soju-0.6.1.tar.gz 161536 BLAKE2B 3e61f13a2f711c9a1a280c158113fd75da53525c32cf8d04cf5459f25e55286e090fbf64c844e19bdf60780a9db37ee45976714500b12e92023330a426706c23 SHA512 12c939a050bf7276ee9e8fec05285533907a2787530ebe113a6be012cbfbcaac3c5cb5c42c3791618136cd45df6c9fb5739bcbec068650bf0d7ea2995443c0bf
63 changes: 63 additions & 0 deletions net-irc/soju/soju-0.6.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,63 @@
# Copyright 2022-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8

inherit go-module systemd

DESCRIPTION="soju is a user-friendly IRC bouncer"
HOMEPAGE="https://soju.im/"
SRC_URI="https://git.sr.ht/~emersion/${PN}/refs/download/v${PV}/${P}.tar.gz"
SRC_URI+=" https://github.com/alfredfo/${PN}-deps/raw/master/${P}-deps.tar.xz"

LICENSE="AGPL-3"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~riscv"
IUSE="moderncsqlite +sqlite pam"
REQUIRED_USE="?? ( moderncsqlite sqlite )"

BDEPEND="
app-text/scdoc
"
RDEPEND="
acct-user/soju
acct-group/soju
sqlite? ( dev-db/sqlite:3 )
"
DEPEND="${RDEPEND}"

src_compile() {
if use sqlite; then
GOFLAGS+=" -tags=libsqlite3"
elif use moderncsqlite; then
GOFLAGS+=" -tags=moderncsqlite"
else
GOFLAGS+=" -tags=nosqlite"
fi
use pam && GOFLAGS+=" -tags=pam"

ego build ${GOFLAGS} ./cmd/soju
ego build ${GOFLAGS} ./cmd/sojudb
ego build ${GOFLAGS} ./cmd/sojuctl

scdoc <doc/soju.1.scd >doc/soju.1 || die
}

src_install() {
dobin soju
dobin sojudb
dobin sojuctl

doman doc/soju.1
systemd_dounit contrib/soju.service
keepdir /etc/soju
insinto /etc/soju
newins config.in config
newinitd "${FILESDIR}"/soju.initd soju
einstalldocs
}

pkg_postinst() {
elog "${PN} requires a user database for authenticating clients."
elog "As the soju user, create a database using:"
elog "$ sojudb -config ${EROOT}/etc/soju/config create-user <username> [-admin]"
}

0 comments on commit 6a8d0b8

Please sign in to comment.