Skip to content

Commit

Permalink
x11-terms/xterm: add 385
Browse files Browse the repository at this point in the history
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
thesamesam committed Oct 8, 2023
1 parent d80461a commit 76fd064
Show file tree
Hide file tree
Showing 2 changed files with 112 additions and 0 deletions.
2 changes: 2 additions & 0 deletions x11-terms/xterm/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -10,3 +10,5 @@ DIST xterm-383.tgz 1538968 BLAKE2B 9d9e0aff91b829b8e3d7dfcf0ad461d4f823545ebb7d0
DIST xterm-383.tgz.asc 729 BLAKE2B 144f78cde591454e09da11e98ba4b455faddf8dc2cba403c28cc02a9b9bd49e296be473d5404cb98a6ae420efd3f851bb5307f3a16cdcc9abe9ed93add4fece2 SHA512 5ec5ac94ac031a91d0ddabeb09afb1a72bf3f926f6fe7d840000729194923a7495463c0ff91f63a2bc920703ba07c0bb1b21a05c35a539a7b948eb42c574e358
DIST xterm-384.tgz 1539955 BLAKE2B aef38aa61da46c29eacd15c239975cf8fecf140968c72c9dc1bdd66bf28f45905f750a54ae73ed38e6966d78686624e24aff023ef60e2c8c73d23a3460985537 SHA512 f9fb2b3f4a58035dfa25063d4e401ca5a2f321d0eedb4cbaf92eeee38e92b4b107cc2f6520ef9c5e57a6cf2bc0f3363316af2b5840d89a0d6bda829ebe955ad8
DIST xterm-384.tgz.asc 729 BLAKE2B 604ec0856dfdf06994f89d2725f3fa61d472c85cbc1a31075272d65ec8dedaef6040133ff9d03c4d0b866c66be98dbdab9c8716d3dad75578f37e5f437872911 SHA512 91eec76c3a0a2359275aad40b1df32035cf73c2d461cebfbcf7c3af1bee4274b66364e29c07b4bef24db9627a944d8c81ac76f6cf3cea193b28edbf411080d60
DIST xterm-385.tgz 1543993 BLAKE2B f0724a1715b340b57c6f975dad30fbcc14d84a2209092163d40212050f78173f7eaa4696ed91d4704574a07a1d5c7af30f6fa381a9f45c32e9d23b84dee1dacf SHA512 e00601a91238b6f0dc6cb973c928387ef7c41a3244cdb463d931c23e0ff93a76498b0d17ea90656a6bed7fcf0a24a788f1cbc02f1ff73e3fbc5ad0540f4982f7
DIST xterm-385.tgz.asc 729 BLAKE2B 06b1c14e2b3e773f8d2fcfc119168c38c10c3302a00dcb5f5510467acb903eeb55eb4c4702bd1c027ab2809c48656f38e611f374dd90b27fc463676527a0889e SHA512 c60550a65f2b866274c0be830972471c5c6e80c96020588aad5dcb4d6c4e48c3b974f1a0bea5af9fc57b0181f1cee631dbf7154d9827b5446343268cca60484e
110 changes: 110 additions & 0 deletions x11-terms/xterm/xterm-385.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,110 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/thomasdickey.asc
inherit desktop flag-o-matic toolchain-funcs verify-sig xdg

DESCRIPTION="Terminal Emulator for X Windows"
HOMEPAGE="https://invisible-island.net/xterm/"
SRC_URI="https://invisible-island.net/archives/${PN}/${P}.tgz"
SRC_URI+=" verify-sig? ( https://invisible-island.net/archives/${PN}/${P}.tgz.asc )"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
IUSE="+openpty sixel toolbar truetype unicode Xaw3d xinerama"

DEPEND="
kernel_linux? ( sys-libs/libutempter )
media-libs/fontconfig:1.0
>=sys-libs/ncurses-5.7-r7:=
x11-apps/xmessage
x11-libs/libICE
x11-libs/libX11
x11-libs/libXaw
x11-libs/libXft
x11-libs/libxkbfile
x11-libs/libXmu
x11-libs/libXrender
x11-libs/libXt
unicode? ( x11-apps/luit )
Xaw3d? ( x11-libs/libXaw3d )
xinerama? ( x11-libs/libXinerama )"
RDEPEND="${DEPEND}
media-fonts/font-misc-misc
x11-apps/rgb"
DEPEND+=" x11-base/xorg-proto"
BDEPEND="
virtual/pkgconfig
verify-sig? ( sec-keys/openpgp-keys-thomasdickey )
"

DOCS=( README{,.i18n} ctlseqs.txt )

PATCHES=(
"${FILESDIR}"/${PN}-384-unconditional-gnusource.patch
)

src_configure() {
DEFAULTS_DIR="${EPREFIX}"/usr/share/X11/app-defaults

# bug #454736
# Workaround for ncurses[tinfo] until upstream fixes their buildsystem using
# something sane like pkg-config or ncurses5-config and stops guessing libs
# Everything gets linked against ncurses anyways, so don't shout
append-libs $($(tc-getPKG_CONFIG) --libs ncurses)

local myeconfargs=(
--disable-full-tgetent
--disable-imake
--disable-setgid
--disable-setuid
--enable-256-color
--enable-broken-osc
--enable-broken-st
--enable-dabbrev
--enable-exec-xterm
--enable-i18n
--enable-load-vt-fonts
--enable-logging
--enable-screen-dumps
--enable-warnings
--enable-wide-chars
--libdir="${EPREFIX}"/etc
--with-app-defaults="${DEFAULTS_DIR}"
--with-icon-theme=hicolor
--with-icondir="${EPREFIX}"/usr/share/icons
--with-utempter
--with-x
$(use_enable openpty)
$(use_enable sixel sixel-graphics)
$(use_enable toolbar)
$(use_enable truetype freetype)
$(use_enable unicode luit)
$(use_enable unicode mini-luit)
$(use_with Xaw3d)
$(use_with xinerama)
)

econf "${myeconfargs[@]}"
}

src_install() {
default

docinto html
dodoc xterm.log.html
sed -i -e 's/_48x48//g' *.desktop || die
domenu *.desktop

# Fix permissions -- it grabs them from live system, and they can
# be suid or sgid like they were in pre-unix98 pty or pre-utempter days,
# respectively (#69510).
# (info from Thomas Dickey) - Donnie Berkholz <[email protected]>
fperms 0755 /usr/bin/xterm

# restore the navy blue
sed -i -e 's:blue2$:blue:' "${D}${DEFAULTS_DIR}"/XTerm-color || die
}

0 comments on commit 76fd064

Please sign in to comment.