Skip to content

Commit

Permalink
dev-python/botocore: Bump to 1.34.95
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed May 1, 2024
1 parent f3a0937 commit 84eb1f0
Show file tree
Hide file tree
Showing 2 changed files with 68 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/botocore/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST botocore-1.34.84.gh.tar.gz 12910232 BLAKE2B 3a9f9073e34d203f05ae44f9dc437f4
DIST botocore-1.34.88.gh.tar.gz 12931548 BLAKE2B b3cc4c44ec0fa93798e842226487f293f0206b27a1fad834ecd3d4b02319da7d6ee67fad3a3a168f6dcdf8a822cd778c742d9c975738ef3bf4d9661963a83624 SHA512 bba25daa8c93ad5454e25089c062363b97a80c1004d670be6694b898b6d7735cbb92ec816b138093c48a89fe2bf5972a6d2dcf3da2a617141a460e265e506806
DIST botocore-1.34.93.gh.tar.gz 12982900 BLAKE2B 3225279b85101e04da3be11f01ac3f4ca74cf77235fcb8878bc12d7aca61472155c8319329beb54ffe335f9da9023fb3ccce99256f3a31c6588389dfa1746de9 SHA512 505e8c9b3915b1c2da3863b62c85c392a58c12376c3e71493025445b7b672ba320474087b446fda876ffee5d6260909bc1d1442ff6dbfeb49fd6661d3d7840a1
DIST botocore-1.34.94.gh.tar.gz 12986670 BLAKE2B 27299e44f2acf9d51c056c3612f60dbb11bacd8411272238fe8ac1c89acd84c1a70594877139a71e2892c152b9902456ed0f9868f82e95366871904aea4d757a SHA512 24b4b5e9a2009a3bc9e14ed04aeb3d7d51c3073b38e1b33f95892ec3bacc94562e1b8c69cf17fff38c4a979d2958cc3a88e9be66e098fcb8f67765d22543e75d
DIST botocore-1.34.95.gh.tar.gz 12998063 BLAKE2B 2616d558d82f022393cf267f9131644310d5a406bfcd9374c52640d998671af40d0407a7e23d21f7571dbdb293a44886760059b770f2b589931be476971c9fff SHA512 b2be04b61d27c30b690f5c6e5504670938bd5d2f13ae6e194ecc77b2b15092726f07a7abf0165fad304c919652c36e9defd8383448a6ce916e995327cd145d7f
67 changes: 67 additions & 0 deletions dev-python/botocore/botocore-1.34.95.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,67 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{10..12} )

inherit distutils-r1

DESCRIPTION="Low-level, data-driven core of boto 3"
HOMEPAGE="
https://github.com/boto/botocore/
https://pypi.org/project/botocore/
"
SRC_URI="
https://github.com/boto/botocore/archive/${PV}.tar.gz
-> ${P}.gh.tar.gz
"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"

RDEPEND="
<dev-python/jmespath-2[${PYTHON_USEDEP}]
dev-python/python-dateutil[${PYTHON_USEDEP}]
>=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
"
# unbundled packages
RDEPEND+="
dev-python/requests[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
"
BDEPEND="
test? (
dev-python/jsonschema[${PYTHON_USEDEP}]
)
"

EPYTEST_XDIST=1
distutils_enable_tests pytest

src_prepare() {
# unpin deps
sed -i -e "s:>=.*':':" setup.py || die

# unbundle deps
rm -r botocore/vendored || die
find -name '*.py' -exec sed -i \
-e 's:from botocore[.]vendored import:import:' \
-e 's:from botocore[.]vendored[.]:from :' \
{} + || die

distutils-r1_src_prepare
}

python_test() {
local EPYTEST_DESELECT=(
# rely on bundled six
tests/functional/test_six_imports.py::test_no_bare_six_imports
tests/functional/test_six_threading.py::test_six_thread_safety
)

local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
epytest tests/{functional,unit}
}

0 comments on commit 84eb1f0

Please sign in to comment.