Skip to content

Commit

Permalink
dev-dotnet/libgdiplus: bump to 4.2, fixes #571610
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.26
  • Loading branch information
sbraz authored and cnd committed Jan 21, 2016
1 parent 3d8a6b0 commit 89964fa
Show file tree
Hide file tree
Showing 2 changed files with 52 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-dotnet/libgdiplus/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST libgdiplus-2.10.9.tar.bz2 2074317 SHA256 6ddeb6c327bada7cb6e06d1a20714f526a0c69520dfd42c12ddd032c3c5d964e SHA512 7f1944795c7ede5fd92a6d7e8d7d6cf2ef3c154e656b83e769b417f8f7195dd975084afe3c3cd1dda1ecb2c1167f76c0b5714cd16d549ff056add09763c6b26c WHIRLPOOL 0930cb2ad191c34b7ebd073f687536663bcfe9a44ed3296cf81bc9d43cfc7ee39d8f60f9b9f83f89847164b7366e514ee945737be50b82257209507c3b6e9c5d
DIST libgdiplus-3.12.tar.gz 688120 SHA256 e61c4dc1bc2ba993e4f79029472efcf5760eb9e60eb20d9cd31f0ebe9113bfc9 SHA512 12c58e7ad99e5aa7caf19f64f47bddd399648292f3c2b9ade64e9051b0495bb8772af8ca9cdb6cb664d20c845d7136f028e10e659548bffd35e7604548bb8743 WHIRLPOOL 288ea9f2b8f5599278f039be1af32f54d0496da6ce70c3e937485d0a3a40494680a7c0fc55430602c256c487df1d57c0b6d8f6220a52b8ac0d7a48e6211d6ead
DIST libgdiplus-4.2.tar.gz 687398 SHA256 f332b9b8b44fd1c50b8d8d01a7296360b806c790b8297614739b3de1edbadfeb SHA512 102d1e07a106fa32640a20c4843bf82b3f628c5b7a3813d39c7712f2cd09d80dc5adb337a8d5bdbae065f876a0c433a5d8fcb7d761dff5ee08c48cac2cd2344e WHIRLPOOL a2580f026ec7d767ca038fa4e41c94a5613b69581c836b144c29b5cf1d97895d9c1c17b077caef760ceae65d35e809a7ef9b6c9089c43c0ec5be1d2bcc453ee0
51 changes: 51 additions & 0 deletions dev-dotnet/libgdiplus/libgdiplus-4.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,51 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

inherit eutils dotnet

DESCRIPTION="Library for using System.Drawing with mono"
HOMEPAGE="http://www.mono-project.com"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
SRC_URI="http://download.mono-project.com/sources/${PN}/${P}.tar.gz"

IUSE="cairo"

RDEPEND=">=dev-libs/glib-2.2.3:2
>=media-libs/freetype-2.3.7
>=media-libs/fontconfig-2.6
>=media-libs/libpng-1.4:0
x11-libs/libXrender
x11-libs/libX11
x11-libs/libXt
>=x11-libs/cairo-1.8.4[X]
media-libs/libexif
>=media-libs/giflib-4.2.3
virtual/jpeg:0
media-libs/tiff:0
!cairo? ( >=x11-libs/pango-1.20 )"
DEPEND="${RDEPEND}"

src_configure() {
econf \
--disable-dependency-tracking \
--disable-static \
$(use_with cairo pango)
}

src_install () {
default

dotnet_multilib_comply
local commondoc=( AUTHORS ChangeLog README TODO )
for docfile in "${commondoc[@]}"; do
[[ -e "${docfile}" ]] && dodoc "${docfile}"
done
[[ "${DOCS[@]}" ]] && dodoc "${DOCS[@]}"
prune_libtool_files
}

0 comments on commit 89964fa

Please sign in to comment.