forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-libs/sord: move PCRE dependency under tools USE flag
Signed-off-by: Cristian Othón Martínez Vera <[email protected]> Closes: gentoo#33518 Signed-off-by: Miroslav Šulc <[email protected]>
- Loading branch information
Showing
3 changed files
with
57 additions
and
2 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,55 @@ | ||
# Copyright 1999-2023 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=8 | ||
|
||
inherit meson-multilib | ||
|
||
if [[ ${PV} == 9999 ]]; then | ||
inherit git-r3 | ||
EGIT_REPO_URI="https://github.com/drobilla/sord.git" | ||
else | ||
SRC_URI="https://download.drobilla.net/${P}.tar.xz" | ||
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86" | ||
fi | ||
|
||
DESCRIPTION="Library for storing RDF data in memory" | ||
HOMEPAGE="https://drobilla.net/software/sord.html" | ||
|
||
LICENSE="ISC" | ||
SLOT="0" | ||
IUSE="doc test tools" | ||
RESTRICT="!test? ( test )" | ||
|
||
BDEPEND=" | ||
virtual/pkgconfig | ||
doc? ( app-doc/doxygen ) | ||
" | ||
# Take care on bumps to check minimum versions! | ||
RDEPEND=" | ||
>=dev-libs/serd-0.30.10[${MULTILIB_USEDEP}] | ||
tools? ( dev-libs/libpcre[${MULTILIB_USEDEP}] ) | ||
" | ||
DEPEND="${RDEPEND}" | ||
|
||
src_prepare() { | ||
default | ||
|
||
# fix doc installation path | ||
sed -i "s/versioned_name/'${PF}'/g" doc/meson.build || die | ||
} | ||
|
||
multilib_src_configure() { | ||
local emesonargs=( | ||
$(meson_native_use_feature doc docs) | ||
$(meson_feature test tests) | ||
$(meson_feature tools) | ||
) | ||
|
||
meson_src_configure | ||
} | ||
|
||
multilib_src_install_all() { | ||
local DOCS=( AUTHORS NEWS README.md ) | ||
einstalldocs | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters