Skip to content

Commit

Permalink
dev-go/godep: add live ebuild
Browse files Browse the repository at this point in the history
  • Loading branch information
williamh committed Nov 30, 2015
1 parent bc4d0e9 commit 93152a3
Showing 1 changed file with 29 additions and 0 deletions.
29 changes: 29 additions & 0 deletions dev-go/godep/godep-9999.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,29 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
EGO_PN=github.com/tools/godep

if [[ ${PV} = *9999* ]]; then
inherit golang-vcs
else
KEYWORDS="~amd64"
EGIT_COMMIT=v${PV}
SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
inherit golang-vcs-snapshot
fi
inherit golang-build

DESCRIPTION="dependency tool for go"
HOMEPAGE="https://github.com/tools/godep"
LICENSE="BSD"
SLOT="0"
IUSE=""
DEPEND=""
RDEPEND=""

src_install() {
dobin godep
dodoc src/${EGO_PN}/*.md
}

0 comments on commit 93152a3

Please sign in to comment.