forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-portage/gentoolkit: Version bump, add python-3.5
Add python3_5 compat to 0.3.1 and 9999 versions. First release with the python revdep-rebuild as the primary app. Package-Manager: portage-2.2.26
- Loading branch information
Showing
3 changed files
with
76 additions
and
1 deletion.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST gentoolkit-0.3.0.8.tar.gz 3192497 SHA256 0338dee7c295c32b60a84e529b764d2bc61536fa3aca021cd5a75c6e534864a6 SHA512 50efd701d0d056740bcf7c7cdce652ae7c9e2786f799f5d30946e752b8aa735489d3e0dc5c7664a5810a0f22cec05b9bc7ccc10292b07ac4dd0777658651f72d WHIRLPOOL 5a2455e50d4e0f4df8abab5b81deb6bb00e078dfed1687ae046ce97a0427eafea2d3de9b83ac6de8155d207653d001c6684ac92226fa2320515c6e14c8fea6e0 | ||
DIST gentoolkit-0.3.0.9.tar.gz 3194703 SHA256 c660d150dfccbaea6f291fb7fc2659c8e0e38eaebe6e68f92dee728c8c7e320d SHA512 75b2d15b2b9ed08055840b56b239ed5d63838a10e8d31ec3ed8822cf1d3ef32841609763433736e17f93a5fdd293ccbda4a3dfa0f007241321aec3333bcde847 WHIRLPOOL 5e9dc038c161361eb2dd8f0cd17e8efaa41183a281d6fcf620c1631c6da661673d085c60572424cd48504222c29613473591f8dd276792ab96ba3cfda88f1fe1 | ||
DIST gentoolkit-0.3.1.tar.gz 3195571 SHA256 ec494d81c8d24e1a69347464733459c0dba0e4c1881d7d5bdc34f7c770f9e3a6 SHA512 6593bc3cad4b9716b9b126bd17fd6662b9aad05b89941297a23deca4651fe4c1552c8fd92b0e284b5a5eeb3f76b1c350d753966abbcc6d2ce8a9e8341f5de794 WHIRLPOOL 82064735ebb64b3cac9ac80f31f24524e9180c78b37472189c1aa72baa698a7eec79009e95ae6e26dbda4c3fd77c1b9dc6f949513511f96fe7cf79d25ac37e28 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,74 @@ | ||
# Copyright 1999-2015 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI="5" | ||
|
||
PYTHON_COMPAT=(python{2_7,3_3,3_4,3_5} pypy) | ||
PYTHON_REQ_USE="xml(+),threads(+)" | ||
|
||
inherit distutils-r1 | ||
|
||
DESCRIPTION="Collection of administration scripts for Gentoo" | ||
HOMEPAGE="https://www.gentoo.org/proj/en/portage/tools/index.xml" | ||
SRC_URI="http://dev.gentoo.org/~dolsen/releases/gentoolkit/${P}.tar.gz" | ||
|
||
LICENSE="GPL-2" | ||
SLOT="0" | ||
IUSE="" | ||
|
||
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris" | ||
|
||
DEPEND="sys-apps/portage[${PYTHON_USEDEP}]" | ||
RDEPEND="${DEPEND} | ||
!<=app-portage/gentoolkit-dev-0.2.7 | ||
|| ( >=sys-apps/coreutils-8.15 app-misc/realpath sys-freebsd/freebsd-bin ) | ||
sys-apps/gawk | ||
sys-apps/gentoo-functions | ||
sys-apps/grep" | ||
|
||
python_prepare_all() { | ||
python_setup | ||
echo VERSION="${PVR}" "${PYTHON}" setup.py set_version | ||
VERSION="${PVR}" "${PYTHON}" setup.py set_version | ||
distutils-r1_python_prepare_all | ||
} | ||
|
||
python_install_all() { | ||
distutils-r1_python_install_all | ||
|
||
# Create cache directory for revdep-rebuild | ||
keepdir /var/cache/revdep-rebuild | ||
use prefix || fowners root:0 /var/cache/revdep-rebuild | ||
fperms 0700 /var/cache/revdep-rebuild | ||
|
||
# remove on Gentoo Prefix platforms where it's broken anyway | ||
if use prefix; then | ||
elog "The revdep-rebuild command is removed, the preserve-libs" | ||
elog "feature of portage will handle issues." | ||
rm "${ED}"/usr/bin/revdep-rebuild* | ||
rm "${ED}"/usr/share/man/man1/revdep-rebuild.1 | ||
rm -rf "${ED}"/etc/revdep-rebuild | ||
rm -rf "${ED}"/var | ||
fi | ||
} | ||
|
||
pkg_postinst() { | ||
# Only show the elog information on a new install | ||
if [[ ! ${REPLACING_VERSIONS} ]]; then | ||
elog | ||
elog "For further information on gentoolkit, please read the gentoolkit" | ||
elog "guide: https://www.gentoo.org/doc/en/gentoolkit.xml" | ||
elog | ||
elog "Another alternative to equery is app-portage/portage-utils" | ||
elog | ||
elog "Additional tools that may be of interest:" | ||
elog | ||
elog " app-admin/eclean-kernel" | ||
elog " app-portage/diffmask" | ||
elog " app-portage/flaggie" | ||
elog " app-portage/install-mask" | ||
elog " app-portage/portpeek" | ||
elog " app-portage/smart-live-rebuild" | ||
fi | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters