Skip to content

Commit

Permalink
sys-fs/mtd-utils: bump to 2.2.1
Browse files Browse the repository at this point in the history
Signed-off-by: Robin H. Johnson <[email protected]>
  • Loading branch information
robbat2 committed Sep 25, 2024
1 parent 24151a3 commit bdde1d3
Show file tree
Hide file tree
Showing 2 changed files with 59 additions and 0 deletions.
1 change: 1 addition & 0 deletions sys-fs/mtd-utils/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST mtd-utils-2.1.6.tar.bz2 458333 BLAKE2B 799c19fbee1a690fa695edfa7e2ab1691e37fccb3f83685065e93b5ceea96e550eecdba4576b7d1a58a1b0ce06e3e551ee635fe9ed16521952fc85986f74ae6f SHA512 470902475b9e583d3a12801c1cab5492c671ec3ccf853cc3336c4e2b8771eac489d67b1414b9f1e827c42ebdba0fe2cdc681297477d67a796af04d81160442bd
DIST mtd-utils-2.2.1.tar.bz2 476562 BLAKE2B 81403a5c6a94ad9147cda56a3f821d6b46b2718d7b1e084aa5236802c22e6b75223c68073abdd35f2ceb8b4857880e923dd49274c6ba3e9fce0ec1a0314fef22 SHA512 ef1cf4d6fa5219b8bbe4728282d0d73fd3234c36743cdfb901908269632f55a7993fdbeb22cc2b6841add1a9f320c4504a42980f5856626e259401e8e2f17f7d
58 changes: 58 additions & 0 deletions sys-fs/mtd-utils/mtd-utils-2.2.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,58 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit toolchain-funcs

DESCRIPTION="MTD userspace tools (NFTL, JFFS2, NAND, FTL, UBI)"
HOMEPAGE="https://git.infradead.org/?p=mtd-utils.git;a=summary"
SRC_URI="https://infraroot.at/pub/mtd/${P}.tar.bz2"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~loong ~mips ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
IUSE="+lzo +ssl test xattr +zstd"
RESTRICT="!test? ( test )"

DEPEND="
sys-apps/util-linux:=
sys-libs/zlib:=
lzo? ( dev-libs/lzo:= )
ssl? ( dev-libs/openssl:0= )
xattr? ( sys-apps/acl )
zstd? ( app-arch/zstd:= )
"
RDEPEND="${DEPEND}"
BDEPEND="test? ( dev-util/cmocka )"

DOCS=( jffsX-utils/device_table.txt ubifs-utils/mkfs.ubifs/README )

src_prepare() {
default
sed -i '/if test.*then/s: == : = :' configure || die
}

src_configure() {
# --enable-tests is for test programs that are installed
local myeconfargs=(
--enable-tests
$(use_enable test unit-tests)
$(use_with lzo)
$(use_with ssl ubifs)
$(use_with xattr)
$(use_with zstd)
)
econf "${myeconfargs[@]}"
}

src_compile() {
emake AR="$(tc-getAR)"
}

src_install() {
default
doman \
jffsX-utils/mkfs.jffs2.1 \
ubi-utils/ubinize.8
}

0 comments on commit bdde1d3

Please sign in to comment.