Skip to content

Commit

Permalink
dev-python/Nuitka: Bump to 2.2
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed May 1, 2024
1 parent eb48757 commit c37e956
Show file tree
Hide file tree
Showing 2 changed files with 53 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/Nuitka/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST Nuitka-2.1.6.tar.gz 3637189 BLAKE2B c3ec642ab8b3edfba12133622619082abade48d98bf5c053882fa037fdbe422f22d10f1008179683fc1091b2a7feed7ec406f85485b1f8a216d4e97343296051 SHA512 13eeec833c66a03f4e82c0b5ab543c6622364a99f23b28cfeb63c2658d542ec1007f700de296e67ccc9c40e0217422cf2f14fcf062b72d5d102a9ae5432588f5
DIST Nuitka-2.2.tar.gz 3655576 BLAKE2B a5c88da5c585163cf7efcc238697b2c930426674d89203e12dbf2bc00e579c523a74527269039e2a155a13821c5ae4d7022215db88b2ba201f3b13224c3e8223 SHA512 0e21ccbf2c35176e3f1b704f599ef79e65f19529c2de362ae384e61e6b0e5d7e86a8489fe0cb25e6800e169833d50e54853bd6c4bd860c139162e22e39249aff
52 changes: 52 additions & 0 deletions dev-python/Nuitka/Nuitka-2.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,52 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

DISTUTILS_USE_PEP517=setuptools
PYPI_NO_NORMALIZE=1
PYTHON_COMPAT=( python3_{10..11} )

inherit distutils-r1 flag-o-matic optfeature pypi

DESCRIPTION="Python to native compiler"
HOMEPAGE="
https://nuitka.net/
https://github.com/Nuitka/Nuitka/
https://pypi.org/project/Nuitka/
"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~loong ~x86"
IUSE="test"
RESTRICT="!test? ( test )"

RDEPEND="
dev-build/scons[${PYTHON_USEDEP}]
"
BDEPEND="
${RDEPEND}
test? ( dev-util/ccache )
"

distutils-r1_src_prepare() {
# remove vendored version of SCons that is Python2 only
# this should be removed when upstream removes support for Python2
rm -vR "nuitka/build/inline_copy/lib/scons-2.3.2/SCons" || die
eapply_user
}

python_install() {
distutils-r1_python_install
doman doc/nuitka.1 doc/nuitka-run.1
}

python_test() {
append-ldflags -Wl,--no-warn-search-mismatch
./tests/basics/run_all.py search || die
}

pkg_postinst() {
optfeature "support for stand-alone executables" dev-util/patchelf
}

0 comments on commit c37e956

Please sign in to comment.