Skip to content

Commit

Permalink
dev-php/swoole: remove libressl support
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.18, Repoman-3.0.2
Signed-off-by: Mikle Kolyada <[email protected]>
  • Loading branch information
Zlogene committed May 3, 2021
1 parent 1eb56d9 commit c47ac53
Show file tree
Hide file tree
Showing 7 changed files with 21 additions and 27 deletions.
6 changes: 3 additions & 3 deletions dev-php/swoole/swoole-4.2.13.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2019 Gentoo Authors
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI="7"
Expand Down Expand Up @@ -27,7 +27,7 @@ DEPEND="
dev-libs/boost:0=
dev-libs/libpcre
http2? ( net-libs/nghttp2:0= )
ssl? ( !libressl? ( dev-libs/openssl:0= ) libressl? ( dev-libs/libressl:0= ) )
ssl? ( dev-libs/openssl:0= )
php_targets_php7-1? ( dev-lang/php:7.1[cli,sockets?] )
php_targets_php7-2? ( dev-lang/php:7.2[cli,sockets?] )
php_targets_php7-3? ( dev-lang/php:7.3[cli,sockets?] )
Expand All @@ -40,7 +40,7 @@ DEPEND="

RDEPEND="${DEPEND}"

IUSE="debug http2 libressl mysql sockets ssl"
IUSE="debug http2 mysql sockets ssl"

src_configure() {
# PostgreSQL disabled due to Gentoo's slot system
Expand Down
7 changes: 3 additions & 4 deletions dev-php/swoole/swoole-4.4.12.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2019 Gentoo Authors
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI="7"
Expand Down Expand Up @@ -30,8 +30,7 @@ DEPEND="
sys-libs/zlib:0=
http2? ( net-libs/nghttp2:0= )
ssl? (
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:0= )
dev-libs/openssl:0=
)
php_targets_php7-1? ( dev-lang/php:7.1[cli,sockets?] )
php_targets_php7-2? ( dev-lang/php:7.2[cli,sockets?] )
Expand All @@ -47,7 +46,7 @@ DEPEND="

RDEPEND="${DEPEND}"

IUSE="debug http2 libressl mysql sockets ssl"
IUSE="debug http2 mysql sockets ssl"

src_configure() {
# JEMalloc not included as it refuses to find a ${EROOT}/usr/includes/jemalloc subdirectory
Expand Down
7 changes: 3 additions & 4 deletions dev-php/swoole/swoole-4.4.14.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2020 Gentoo Authors
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI="7"
Expand Down Expand Up @@ -30,8 +30,7 @@ DEPEND="
sys-libs/zlib:0=
http2? ( net-libs/nghttp2:0= )
ssl? (
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:0= )
dev-libs/openssl:0=
)
php_targets_php7-1? ( dev-lang/php:7.1[cli,sockets?] )
php_targets_php7-2? ( dev-lang/php:7.2[cli,sockets?] )
Expand All @@ -47,7 +46,7 @@ DEPEND="

RDEPEND="${DEPEND}"

IUSE="debug http2 libressl mysql sockets ssl"
IUSE="debug http2 mysql sockets ssl"

src_configure() {
# JEMalloc not included as it refuses to find a ${EROOT}/usr/includes/jemalloc subdirectory
Expand Down
7 changes: 3 additions & 4 deletions dev-php/swoole/swoole-4.4.15.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2020 Gentoo Authors
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI="7"
Expand Down Expand Up @@ -30,8 +30,7 @@ DEPEND="
sys-libs/zlib:0=
http2? ( net-libs/nghttp2:0= )
ssl? (
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:0= )
dev-libs/openssl:0=
)
php_targets_php7-1? ( dev-lang/php:7.1[cli,sockets?] )
php_targets_php7-2? ( dev-lang/php:7.2[cli,sockets?] )
Expand All @@ -47,7 +46,7 @@ DEPEND="

RDEPEND="${DEPEND}"

IUSE="debug http2 libressl mysql sockets ssl"
IUSE="debug http2 mysql sockets ssl"

src_configure() {
# JEMalloc not included as it refuses to find a ${EROOT}/usr/includes/jemalloc subdirectory
Expand Down
7 changes: 3 additions & 4 deletions dev-php/swoole/swoole-4.4.16.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2020 Gentoo Authors
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI="7"
Expand Down Expand Up @@ -30,8 +30,7 @@ DEPEND="
sys-libs/zlib:0=
http2? ( net-libs/nghttp2:0= )
ssl? (
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:0= )
dev-libs/openssl:0=
)
php_targets_php7-1? ( dev-lang/php:7.1[cli,sockets?] )
php_targets_php7-2? ( dev-lang/php:7.2[cli,sockets?] )
Expand All @@ -47,7 +46,7 @@ DEPEND="

RDEPEND="${DEPEND}"

IUSE="debug http2 libressl mysql sockets ssl"
IUSE="debug http2 mysql sockets ssl"

src_configure() {
# JEMalloc not included as it refuses to find a ${EROOT}/usr/includes/jemalloc subdirectory
Expand Down
7 changes: 3 additions & 4 deletions dev-php/swoole/swoole-4.4.19.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2020 Gentoo Authors
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI="7"
Expand Down Expand Up @@ -30,8 +30,7 @@ DEPEND="
sys-libs/zlib:0=
http2? ( net-libs/nghttp2:0= )
ssl? (
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:0= )
dev-libs/openssl:0=
)
php_targets_php7-1? ( dev-lang/php:7.1[cli,sockets?] )
php_targets_php7-2? ( dev-lang/php:7.2[cli,sockets?] )
Expand All @@ -47,7 +46,7 @@ DEPEND="

RDEPEND="${DEPEND}"

IUSE="debug http2 libressl mysql sockets ssl"
IUSE="debug http2 mysql sockets ssl"

src_configure() {
# JEMalloc not included as it refuses to find a ${EROOT}/usr/includes/jemalloc subdirectory
Expand Down
7 changes: 3 additions & 4 deletions dev-php/swoole/swoole-4.5.9.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2020 Gentoo Authors
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI="7"
Expand Down Expand Up @@ -28,8 +28,7 @@ DEPEND="
dev-libs/libpcre
sys-libs/zlib:0=
ssl? (
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:0= )
dev-libs/openssl:0=
)
mysql? (
php_targets_php7-2? ( dev-lang/php:7.2[mysql,mysqli(+)] )
Expand All @@ -41,7 +40,7 @@ DEPEND="

RDEPEND="${DEPEND}"

IUSE="debug http2 libressl mysql sockets ssl"
IUSE="debug http2 mysql sockets ssl"

src_configure() {
# JEMalloc not included as it refuses to find a ${EROOT}/usr/includes/jemalloc subdirectory
Expand Down

0 comments on commit c47ac53

Please sign in to comment.