forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-editors/scite: Version bump to 5.1.6
Enhancement and upstream fixes: https://www.scintilla.org/SciTEHistory.html Signed-off-by: Ervin Peters <[email protected]> Package-Manager: Portage-3.0.28, Repoman-3.0.3 Closes: gentoo#23253 Signed-off-by: Joonas Niilola <[email protected]>
- Loading branch information
1 parent
994ea44
commit cf17a10
Showing
2 changed files
with
116 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST scite-5.1.1.tgz 3374717 BLAKE2B b7a45a86008eb592adacc8fde90cb637cc7cac821f339bb65920aaf912ee10d52badde3ed2e71118a7ce4690a0536b298c5fe5f673b886902ad4634b3a1ffaa6 SHA512 4d6c9b3ca4caed4fcb70a6b1c86a2ace13b023241f16d6faa01b3f692bcbfa14e0ce186bb08776ee0cf62768b2b77c4ffcae610ddbb6b04dcb7584fd8b3f27bb | ||
DIST scite-5.1.3.tgz 3427245 BLAKE2B ca765b61cb1fa96934c1e28d76a97cd7086a6c692ae33bb57591dfbc8637ffc94c4a3f20f9c6b55d11da8a76664f1d521f7e393bf6f31db55cbe02e0bf5052ba SHA512 ef86a18f739062598d3c7bf19bcd2f38ca012e890b9b4685c1f1b809e928762ab60d24c33a1f45ca33133ce5007e3a22a76e80222b121c9a4089d3c57aa0bc4c | ||
DIST scite-5.1.6.tgz 3436413 BLAKE2B 3bf578d750c844cebc187662d658556ba58934929872b74012b299e10f6057352d184542e37433e3e031fa566b28e91d51a5d00687c6a4df35301d8ceb75a795 SHA512 3983034e5a14d696a455375eb4ca922c458c9f74fd1d2e6c7b1735914a733978b65119b9370167227e50d20d4c6f636b96bb4d1d8eb8fe8ae1d7f7ca1c143e20 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,115 @@ | ||
# Copyright 1999-2021 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=8 | ||
|
||
LUA_COMPAT=( lua5-4 ) | ||
|
||
inherit lua-single toolchain-funcs xdg | ||
|
||
DESCRIPTION="A very powerful, highly configurable, small editor with syntax coloring" | ||
HOMEPAGE="https://www.scintilla.org/SciTE.html" | ||
SRC_URI="https://www.scintilla.org/${PN}${PV//./}.tgz -> ${P}.tgz" | ||
|
||
LICENSE="HPND lua? ( MIT )" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~arm-linux ~x86-linux" | ||
IUSE="lua" | ||
|
||
REQUIRED_USE="lua? ( ${LUA_REQUIRED_USE} )" | ||
|
||
RDEPEND=" | ||
dev-libs/atk | ||
dev-libs/glib:2 | ||
x11-libs/cairo | ||
x11-libs/gdk-pixbuf:2 | ||
x11-libs/gtk+:3 | ||
x11-libs/pango | ||
lua? ( ${LUA_DEPS} )" | ||
|
||
DEPEND="${RDEPEND}" | ||
|
||
BDEPEND=" | ||
virtual/pkgconfig" | ||
|
||
DOCS=("../README") | ||
|
||
S="${WORKDIR}/${PN}/gtk" | ||
|
||
pkg_pretend() { | ||
if tc-is-clang ; then | ||
# need c++17 features | ||
[[ "${MERGE_TYPE}" != "binary" && | ||
$(clang-major-version) -lt 5 ]] && | ||
die "Sorry, SCiTE uses C++17 Features and needs >sys-devel/clang-5 | ||
($(clang-major-version))." | ||
|
||
elif tc-is-gcc; then | ||
# older gcc is not supported | ||
[[ "${MERGE_TYPE}" != "binary" && | ||
$(gcc-major-version) -lt 7 ]] && | ||
die "Sorry, Scite uses C++17 Features, need >sys-devel/gcc-7." | ||
else | ||
die "Either gcc or clang should be configured for building scite" | ||
fi | ||
} | ||
|
||
pkg_setup() { | ||
use lua && lua-single_pkg_setup | ||
} | ||
|
||
src_prepare() { | ||
tc-export AR CC CXX RANLIB | ||
|
||
# remove hardcoded CC, Optimizations and clang unknown flags | ||
sed -i "${WORKDIR}/scintilla/gtk/makefile" \ | ||
-e "s#^CC = gcc#CC = ${CC}#" \ | ||
-e "s#^CC = clang#CC = ${CC}#" \ | ||
-e "s#^CXX = clang++#CXX = ${CXX}#" \ | ||
-e "s#-Os##" \ | ||
-e "s#-Wno-misleading-indentation##" \ | ||
|| die "error patching /scintilla/gtk/makefile" | ||
|
||
sed -i "${S}/makefile" \ | ||
-e "s#^CC = clang#CC = ${CC}#" \ | ||
-e "s#^CXX = clang++#CXX = ${CXX}#" \ | ||
-e "s#-rdynamic#-rdynamic ${LDFLAGS}#" \ | ||
-e "s#-Os##" \ | ||
|| die "error patching gtk/makefile" | ||
|
||
# repair and enhance the .desktop file | ||
sed -i "${S}/SciTE.desktop" \ | ||
-e "s#text/plain#text/\*;application/xhtml+xml#" \ | ||
-e "s#^Categories=\(.*\)#Categories=Development;#" \ | ||
|| die "error patching /scite/gtk/SciTe.desktop" | ||
|
||
# add the ebuild suffix as shell type for working with ebuilds | ||
sed -i "${WORKDIR}/scite/src/perl.properties" \ | ||
-e "s#\*.sh;\*.bsh;#\*.ebuild;\*.sh;\*.bsh;#" \ | ||
|| die "error patching /scite/src/perl.properties" | ||
|
||
# it seems that pwd here is ${S}, but user patches are relative to ${workdir} | ||
# Bug #576162 | ||
|
||
cd "${WORKDIR}" || die "couldn't cd into ${WORKDIR}" | ||
eapply_user | ||
} | ||
|
||
src_compile() { | ||
# prepare make options | ||
local emake_pars=("GTK3=1") | ||
|
||
tc-is-clang && emake_pars+=("CLANG=1") | ||
use !lua && emake_pars+=("NO_LUA=1") | ||
|
||
emake -C "${WORKDIR}/lexilla/src" "${emake_pars[@]}" | ||
emake -C "${WORKDIR}/scintilla/gtk" "${emake_pars[@]}" | ||
emake "${emake_pars[@]}" | ||
} | ||
|
||
# want to use the base src_install() as base_src_install() | ||
|
||
src_install() { | ||
default | ||
dosym SciTE /usr/bin/scite | ||
} |