forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-i18n/man-pages-l10n: Version bump to 4.2.0
Closes: https://bugs.gentoo.org/769002 Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Ulrich Müller <[email protected]>
- Loading branch information
Showing
2 changed files
with
72 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST manpages-l10n-v4.0.0.tar.bz2 34796889 BLAKE2B 6413278ab2c9482ffdd2cf6ef1f4c6e05f2f1d7be8c8d556cb137ca4c5c2d6297f9547725f3afcf8023478c05e41d99d595a0b5a44da0d0188ed0287c630e5b6 SHA512 9c83363ffaa9ff9015934869623958594e64f1cbb52367dd8274425a5cb45dac06109d231fd7f165eb35248b4229f3bbf252a6a4630e7d5a47edbf41d4a646a9 | ||
DIST manpages-l10n-v4.2.0.tar.bz2 51747352 BLAKE2B 97c3e3fdb11b47753c9c179751fb001af0a9f79324d594d297981735f82b3917bd31fc5c100462d6093e621a98773f23543548efb957113ade39e9c315cd4d72 SHA512 b2de542fdb97868b5fa96f24947c7a37216dc6a6a5ee66142023dd1036017f7128ca26ac8367b0edbd76cfa049174892749efafef9dbf4221e90dd9166b82652 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,71 @@ | ||
# Copyright 1999-2021 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
MY_P="${PN/-}-v${PV}" | ||
DESCRIPTION="A somewhat comprehensive collection of man page translations" | ||
HOMEPAGE="https://manpages-l10n-team.pages.debian.net/manpages-l10n/" | ||
SRC_URI="https://salsa.debian.org/manpages-l10n-team/manpages-l10n/-/archive/v${PV}/${MY_P}.tar.bz2" | ||
S="${WORKDIR}/${MY_P}" | ||
|
||
LICENSE="GPL-3+" | ||
SLOT="0" | ||
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux" | ||
MY_L10N=(de es fr it nl pl pt-BR ro) | ||
IUSE="${MY_L10N[@]/#/l10n_}" | ||
REQUIRED_USE="|| ( ${MY_L10N[@]/#/l10n_} )" | ||
|
||
RDEPEND="virtual/man | ||
l10n_de? ( !app-i18n/man-pages-de ) | ||
l10n_fr? ( !app-i18n/man-pages-fr ) | ||
l10n_it? ( !app-i18n/man-pages-it ) | ||
l10n_nl? ( !app-i18n/man-pages-nl ) | ||
l10n_pl? ( !app-i18n/man-pages-pl )" | ||
|
||
BDEPEND="app-text/po4a | ||
dev-lang/perl" | ||
|
||
DOCS=(AUTHORS.md CHANGES.md README.md) | ||
|
||
src_prepare() { | ||
default | ||
sed -i -e "/^SUBDIRS/s/=.*/= ${L10N//-/_}/" po/Makefile.{am,in} || die | ||
|
||
# some packages have their own translations | ||
local noinst_manpages=( | ||
# app-arch/xz-utils | ||
de/xz.1 | ||
de/xzdec.1 | ||
de/xzdiff.1 | ||
de/xzgrep.1 | ||
de/xzless.1 | ||
de/xzmore.1 | ||
# sys-apps/shadow | ||
{de,nl,pl}/groups.1 | ||
de/su.1 | ||
# sys-process/procps | ||
{de,fr,pl}/free.1 | ||
{de,nl,pl}/fuser.1 | ||
{de,pl}/killall.1 | ||
{de,fr}/pgrep.1 | ||
{de,fr}/pmap.1 | ||
de/peekfd.1 | ||
de/prtstat.1 | ||
de/pslog.1 | ||
{de,pl}/pstree.1 | ||
{de,fr}/pwdx.1 | ||
{de,fr}/tload.1 | ||
{de,fr,pl}/uptime.1 | ||
{de,fr}/sysctl.conf.5 | ||
{de,fr}/sysctl.8 | ||
{de,fr}/vmstat.8 | ||
) | ||
printf '%s\n' "${noinst_manpages[@]}" \ | ||
| sed 's%^\(.*\)/\(.*\)\.\(.*\)$%po/\1/man\3/\2.\3.po%' | xargs rm | ||
assert | ||
} | ||
|
||
src_configure() { | ||
econf --enable-compression=none | ||
} |