Skip to content

Commit

Permalink
app-admin/doctl: version bump to 1.56.0, introduce version support
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.13, Repoman-3.0.2
Signed-off-by: Vladimir Pavljuchenkov <[email protected]>
Signed-off-by: Joonas Niilola <[email protected]>
  • Loading branch information
SpiderX authored and juippis committed Feb 14, 2021
1 parent 95c6e2c commit eea5f3c
Show file tree
Hide file tree
Showing 2 changed files with 45 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-admin/doctl/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST doctl-1.55.0.tar.gz 5157504 BLAKE2B 1d3db2ee4ca71a459456e72f035648c5ba73c5372c3369b360e1ee3cc44ec1155295e5f425611c307371f902c7ffed7dbce2f959266f79ecb8f149144fc86596 SHA512 6cea86e184ea25d5a6740d4090148fbe053ce93ebe8f2344f5a2bf62283381ed2a9574862a5ba39f34a52bf85af550313b7dd316a321f31089673f898d37cf78
DIST doctl-1.56.0.tar.gz 5163349 BLAKE2B 10f169f7ccf31b416509043f42bff3fd60a5618530217b46d2bd0797d70eba914d314b376b5fdd801ba12ee4746e17b4e7a33316d9adcb95403ac3a92152d86e SHA512 4102f58ea0925b110d4ddf2146cdec0a4252881b7724c34c4ef0c86f848b107380d6b425e11a885841d39f52d6cb00bfab5671d663efcfe5ba02dcae8b5975c9
44 changes: 44 additions & 0 deletions app-admin/doctl/doctl-1.56.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,44 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit bash-completion-r1 go-module

DESCRIPTION="A command line tool for DigitalOcean services"
HOMEPAGE="https://github.com/digitalocean/doctl"
SRC_URI="https://github.com/digitalocean/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="Apache-2.0 MIT BSD BSD-2 ISC MPL-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""

src_compile() {
LDFLAGS="-X github.com/digitalocean/doctl.Major=$(ver_cut 1)
-X github.com/digitalocean/doctl.Minor=$(ver_cut 2)
-X github.com/digitalocean/doctl.Patch=$(ver_cut 3-)
-X github.com/digitalocean/doctl.Label=release"
GOFLAGS="-v -x -mod=vendor" \
go build -ldflags "$LDFLAGS" ./cmd/... || die "build failed"

./doctl completion bash > doctl.bash || die "completion for bash failed"
./doctl completion zsh > doctl.zsh || die "completion for sh failed"
./doctl completion fish > doctl.fish || die "completion for fish failed"
}

src_test() {
GOFLAGS="-v -x -mod=vendor" \
go test -work ./do/... ./pkg/... . || die "test failed"
}

src_install() {
einstalldocs
dobin doctl

newbashcomp doctl.bash doctl
insinto /usr/share/zsh/site-functions
newins doctl.zsh _doctl
insinto /usr/share/fish/completion
newins doctl.fish doctl
}

0 comments on commit eea5f3c

Please sign in to comment.