Skip to content

Commit

Permalink
sys-kernel/asahi-sources: add 6.8.8_p2
Browse files Browse the repository at this point in the history
Signed-off-by: Janne Grunau <[email protected]>
Closes: gentoo#36494
Signed-off-by: Mart Raudsepp <[email protected]>
  • Loading branch information
jannau authored and leio committed Apr 30, 2024
1 parent c84ba1b commit f5b2587
Show file tree
Hide file tree
Showing 2 changed files with 77 additions and 0 deletions.
1 change: 1 addition & 0 deletions sys-kernel/asahi-sources/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST asahi-sources-6.6.0_p16-rust-alloc-fix.patch 52132 BLAKE2B 3ba12bf87decb581626739786b8c0b6686c8a1d2c964ac534e2701473b117d59b084c686ba8e09bb65f27fbe57574ec2ddf8e89b544f3bdaaebc7acd4f0d2d5f SHA512 d4d1edab5a67152326a4712493a783660f68c1353e058536d19ed7a7f7d288e77b9916fc07639edd1f13f8a1948028fad3b92a90c03152522159b7f79ab54aa1
DIST asahi-sources-6.6.0_p16.tar.gz 229861406 BLAKE2B e8f90373fe3cfb0ee8824158c59d548af05d1e68626715a65dcf086b35cfe7f4d44b184f02bbfad33474040b86f488e4fa99c8886ae329cf138933161658f94c SHA512 fc62cf346b95229aa31bc1483c9fcffaeacf94d09d13801a3e8e50ed3ba7f3d1b1d4dd8083051879955e1f99bffa61bf411cd38fcc45e176d372fc1d205b9c76
DIST linux-asahi-6.8.6-4.tar.gz 235255308 BLAKE2B 47b789a1cd0284d722937001ce934ef4ed0eab3f25dbc6f1add5fdf2aac58c60b2c9b24f71d34f2f1cc7044c1bca50fa0cab2d2d6f2d7acc0789c0ae05be778d SHA512 a3b2041754ae7b73a8612b3623683229788744652037983bc092f77dc9371938a82f4641a93e4f909d5cd4b0ea25d77714ffe05f686ff92a96efbe23e3dfe4c6
DIST linux-asahi-6.8.8-2.tar.gz 235265018 BLAKE2B cf543955971865d65c048b7021a8bf4d9711294afd49e4ce31bf3e4761dea8724950a52a7b6b852645760e0abb1ca2abe1ac6c3feafbcb933a53e56dcc4044e4 SHA512 101566de3777517d151effcdd2e38b6a5d5961754734cdabfae7c359bbf0f35e2c7a4ecb912d4c300adb3f09ecaa31eafaf076d849171e0e5244ec29a0bf30a4
76 changes: 76 additions & 0 deletions sys-kernel/asahi-sources/asahi-sources-6.8.8_p2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,76 @@
# Copyright 2023-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI="8"
K_SECURITY_UNSUPPORTED="1"
ETYPE="sources"
#K_WANT_GENPATCHES="base extras experimental"
#K_GENPATCHES_VER="5"
K_NODRYRUN="1"

inherit kernel-2
detect_version
detect_arch

if [[ ${PV} != ${PV/_rc} ]] ; then
# $PV is expected to be of following form: 6.0_rc5_p1
MY_TAG="$(ver_cut 6)"
MY_P="asahi-$(ver_rs 2 - $(ver_cut 1-4))-${MY_TAG}"
else
# $PV is expected to be of following form: 5.19.0_p1
MY_TAG="$(ver_cut 5)"
if [[ "$(ver_cut 3)" == "0" ]] ; then
MY_P="asahi-$(ver_cut 1-2)-${MY_TAG}"
else
MY_P="asahi-$(ver_cut 1-3)-${MY_TAG}"
fi
fi

DESCRIPTION="Asahi Linux kernel sources"
HOMEPAGE="https://asahilinux.org"
KERNEL_URI="https://github.com/AsahiLinux/linux/archive/refs/tags/${MY_P}.tar.gz -> linux-${MY_P}.tar.gz"
SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI}
"

KEYWORDS="~arm64"
IUSE="rust"

DEPEND="
${DEPEND}
rust? (
|| (
>=dev-lang/rust-bin-1.76[rust-src,rustfmt]
>=dev-lang/rust-1.76[rust-src,rustfmt]
)
dev-util/bindgen
)
"

PATCHES=(
"${FILESDIR}/asahi-sources-6.6.0_p16-enable-speakers-stage1.patch"
"${FILESDIR}/asahi-sources-6.6.0_p16-enable-speakers-stage2.patch"
)

src_unpack() {
unpack linux-${MY_P}.tar.gz
mv linux-${MY_P} linux-${KV_FULL} || die "Could not move source tree"
}

src_prepare() {
default
cd "${WORKDIR}/linux-${KV-FULL}" || die
# XXX: Genpatches do not yet work with Rust kernels
#handle_genpatches --set-unipatch-list
#[[ -n ${UNIPATCH_LIST} || -n ${UNIPATCH_LIST_GENPATCHES} || -n ${UNIPATCH_LIST_DEFAULT} ]] && \
# unipatch "${UNIPATCH_LIST_DEFAULT} ${UNIPATCH_LIST_GENPATCHES} ${UNIPATCH_LIST}"
#unpack_fix_install_path
#env_setup_xmakeopts
echo "-${MY_TAG}" > localversion.10-pkgrel || die
cd "${S}" || die
}

pkg_postinst() {
einfo "For more information about Asahi Linux please visit ${HOMEPAGE},"
einfo "or consult the Wiki at https://github.com/AsahiLinux/docs/wiki."
kernel-2_pkg_postinst
}

0 comments on commit f5b2587

Please sign in to comment.